Jump to content
Not connected, Your IP: 54.236.58.220
Sign in to follow this  
EzioAuditore

TLS Error: Handshake failed

Recommended Posts

Well, just today I got the premium trial code and hell's smashed on me again...

Everytime I try to connect, it fails, the reason maybe is "TLS Error: TLS Handshake Failed".. These things didn't happen before the free server shutdown..

I tried different ports and protocols, to no avail.

Can anyone help me regarding this? Please? :S

I'm not that good at Networking... :blush:

Here's the OpenVPN log attached. I'm on Linux, Ubuntu to be precise by the way, just in case if it could be of any help..

Colored out is the error part.

=====================

Thu Mar 31 01:00:40 2011 OpenVPN 2.1.0 i686-pc-linux-gnu [sSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 12 2010

Thu Mar 31 01:00:40 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

Thu Mar 31 01:00:40 2011 WARNING: file 'user.key' is group or others accessible

Thu Mar 31 01:00:40 2011 /usr/bin/openssl-vulnkey -q -b 2048 -m <modulus omitted>

Thu Mar 31 01:00:40 2011 LZO compression initialized

Thu Mar 31 01:00:40 2011 Control Channel MTU parms [ L:1558 D:138 EF:38 EB:0 ET:0 EL:0 ]

Thu Mar 31 01:00:40 2011 Data Channel MTU parms [ L:1558 D:1450 EF:58 EB:135 ET:0 EL:0 AF:3/1 ]

Thu Mar 31 01:00:40 2011 Local Options hash (VER=V4): '22188c5b'

Thu Mar 31 01:00:40 2011 Expected Remote Options hash (VER=V4): 'a8f55717'

Thu Mar 31 01:00:40 2011 Socket Buffers: R=[114688->131072] S=[114688->131072]

Thu Mar 31 01:00:40 2011 UDPv4 link local: [undef]

Thu Mar 31 01:00:40 2011 UDPv4 link remote: [AF_INET]178.162.181.105:53

Thu Mar 31 01:01:40 2011 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

Thu Mar 31 01:01:40 2011 TLS Error: TLS handshake failed

Thu Mar 31 01:01:40 2011 TCP/UDP: Closing socket

Thu Mar 31 01:01:40 2011 SIGUSR1[soft,tls-error] received, process restarting

Thu Mar 31 01:01:40 2011 Restart pause, 2 second(s)

Thu Mar 31 01:01:42 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

Thu Mar 31 01:01:42 2011 Re-using SSL/TLS context

Thu Mar 31 01:01:42 2011 LZO compression initialized

Thu Mar 31 01:01:42 2011 Control Channel MTU parms [ L:1558 D:138 EF:38 EB:0 ET:0 EL:0 ]

Thu Mar 31 01:01:42 2011 Data Channel MTU parms [ L:1558 D:1450 EF:58 EB:135 ET:0 EL:0 AF:3/1 ]

Thu Mar 31 01:01:42 2011 Local Options hash (VER=V4): '22188c5b'

Thu Mar 31 01:01:42 2011 Expected Remote Options hash (VER=V4): 'a8f55717'

Thu Mar 31 01:01:42 2011 Socket Buffers: R=[114688->131072] S=[114688->131072]

Thu Mar 31 01:01:42 2011 UDPv4 link local: [undef]

Thu Mar 31 01:01:42 2011 UDPv4 link remote: [AF_INET]178.162.181.105:53

Share this post


Link to post

Hello!

It looks like you did not activate your account, so you have no authorization to connect to that server and the TLS handshaking fails. Which key are you using? How did you generate it?

If you activated your account, then either you did not copy properly your key, or something is blocking the handshaking (check your connectivity, including the firewall). There is no difference with the previous connection method and as before you must have downloaded valid key and certificate.

Do not hesitate to open a ticket if you can't solve the problem.

Kind regards

AirVPN admins

Share this post


Link to post

Thanks for your reply sir/madam.

Here's what i followed-

1. Followed the instructions to activate trial period.

2. Downloaded the configuration files and pasted them to /etc/openvpn.

3. CD'ed to the openvpn directory and issued sudo openvpn --config air.ovpn.

4. Tried with firewall disabled also but no joy.

Am i doing something wrong or maybe missing something?

Share this post


Link to post

EzioAuditore wrote:

Thanks for your reply sir/madam.

Here's what i followed-

1. Followed the instructions to activate trial period.

2. Downloaded the configuration files and pasted them to /etc/openvpn.

3. CD'ed to the openvpn directory and issued sudo openvpn --config air.ovpn.

4. Tried with firewall disabled also but no joy.

Am i doing something wrong or maybe missing something?

Hello!

The steps you have followed are correct. However, we have just performed a deep check of your account and everything is fine. The system authorizes you to connect to any server.

Make sure that user.key has been copied properly from air.zip and pasted into the correct directory.

Finally, there is a slight chance that the UDP protocol is causing problems: UDP packets not arriving from client to server or vice versa. This may be caused by low quality connection, router not forwarding properly UDP packets or your ISP capping/throttling UDP ports (several providers from Italy, China, Egypt and many more do that). We don't know if you're using UDP; if it's the case, try to switch to proto TCP.

If that does not solve the issue, please do not hesitate to open a ticket.

Kind regards

AirVPN admins

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...