Jump to content
Not connected, Your IP: 3.227.240.72
firefox4dawin

ANSWERED Zerotier network interface being selected by 'Interface used for connection'

Recommended Posts

Started using zero tier to play LAN games with a friend recently and now today (after a windows update - might have been the cause), I began having trouble connecting to any airvpn servers.

it was something like this in the log.
2024.04.01 20:39:47 - Routes, add () for interface "Zerotier network device".

I went to change it from automatic to my ethernet interface but it would not properly switch, it kept trying to use the Zerotier interface.

I got it working by disabling the zerotier interface in windows and then restarting eddie. Switching it back to automatic finally worked.

Is there any fix for this so I don't have to enable / disable the zerotier interface every time? Or perhaps a reason why it would default to that interface instead of the usual ethernet interface?




 

Share this post


Link to post
@choonietookie

Hello!

We have moved your message into this thread because the problem is related to the "ZeroTier" interface for both of you. The interface is apparently causing troubles to Eddie. We'll investigate. In the meantime @firefox4dawin you can disable the interface to solve the problem, as reported by choonietookie.

Can you please verify (you both) whether the same problem occurs with Eddie 2.24.x (with the ZeroTier interface enabled)? Please see here to download it. https://airvpn.org/forums/topic/57401-eddie-desktop-224-beta-released/

Kind regards
 

Share this post


Link to post
Posted ... (edited)
10 hours ago, Staff said:
@choonietookie

Hello!

We have moved your message into this thread because the problem is related to the "ZeroTier" interface for both of you. The interface is apparently causing troubles to Eddie. We'll investigate. In the meantime @firefox4dawin you can disable the interface to solve the problem, as reported by choonietookie.

Can you please verify (you both) whether the same problem occurs with Eddie 2.24.x (with the ZeroTier interface enabled)? Please see here to download it. https://airvpn.org/forums/topic/57401-eddie-desktop-224-beta-released/

Kind regards
 
Hi, thank you for the response.

Initially I was using the stable branch version 2.21.8. In an attempt to fix the problem, I uninstalled and reinstalled using the current experimental branch, 2.42.2. I also tried restarting my pc a couple times lol.

Both versions seem to have the issue.

Eddie is working again today even with the zerotier interface enabled.
 
 
 
Edited ... by choonietookie

Share this post


Link to post
Posted ... (edited)
14 hours ago, firefox4dawin said:

The vpn seems to be doing a connection loop again for some reason, and again, none of the above fixes are solving the problem  :(

log.txt 32.46 kB · 3 downloads

Open up start menu, type settings, go to network and internet, and at the bottom click advanced network settings. Click the disable button next to the zerotier virtual port interface. Restart eddie and it should work.
I was then able to re-enable the zerotier interface and it did not interfere with eddie anymore. 🤷 Edited ... by choonietookie

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...