Jump to content
Not connected, Your IP: 100.28.132.102

Recommended Posts

Hi,

I've recently had to do a complete reset on my windows 8 PC. Following that I have tried to install the eddie-ui client. The windows 8/7 installer completed without issue, however the UI will not open giving an error of "Object reference not set to an instance of an object".

To fix I have tried:

  • The portable version of windows 8/7 gives the same error.
  • The CLI for either version results in opening, and near immediate closure of the command prompt - I've been able to determine there are three lines printed, the first being "Method not found ... (something here I can't determine) ... System.Array.Empty".
  • Disabling my PC's firewall has no impact on the UI executable or the CLI
  • Running in administrator mode also does not make any change
  • Running PC or network diagnostics (through the inbuilt windows services) does not make any change
  • Rerunning the installer gives several errors for "Error opening file for writing: C :\Program Files\AirVPN\Eddie-UI.exe Click Abort to stop the installation, Retry to try again, or Ignore to skip this file.". Other files also impacted are Lib.Core.dll, Lib.Forms.dll, Lib.Forms.Skin.dll, and Lib.Platform.Windows.dll. The installer then completes without issue however the UI still does not open.
  • The windows 10/11 portable version gives the same error attempting to open the UI.

My installed versiono is eddie-ui_2.21.8_windows-7_x64_installer.

System Details

Windows 8
Processor: Intel(R) Core(TM) i5-3470 CPU @ 3.2GHz 3.20Ghz
Installed memory (RAM): 10.0 GB (9.79 GB usable)
System Type: 64-bit Operating System, x64-based processor


Directory Contents

 Volume in drive C is Windows8_OS
 Volume Serial Number is REDACTED

 Directory of C:\Program Files\AirVPN

12/02/2023  08:10 AM    <DIR>          .
12/02/2023  08:10 AM    <DIR>          ..
05/26/2022  03:07 AM           323,800 Eddie-CLI-Elevated.exe
05/26/2022  03:07 AM            65,752 Eddie-CLI.exe
05/26/2022  03:08 AM           750,808 Eddie-Service-Elevated.exe
05/26/2022  03:08 AM            66,264 Eddie-UI.exe
05/26/2022  03:08 AM           343,256 Lib.Core.dll
05/26/2022  03:08 AM         2,177,752 Lib.Forms.dll
05/26/2022  03:08 AM           120,024 Lib.Forms.Skin.dll
05/26/2022  03:08 AM            78,552 Lib.Platform.Windows.dll
05/26/2022  03:08 AM           560,856 Lib.Platform.Windows.Native.dll
12/15/2021  12:57 AM         3,482,288 libcrypto-1_1-x64.dll
12/15/2021  12:57 AM            93,872 libpkcs11-helper-1.dll
12/15/2021  12:57 AM           694,448 libssl-1_1-x64.dll
12/15/2021  12:57 AM           121,008 lzo2.dll
04/19/2022  01:45 AM         1,439,328 ndp48-web.exe
12/15/2021  12:57 AM           847,536 openvpn.exe
06/12/2020  03:23 AM           678,312 plink.exe
12/02/2023  08:10 AM                 0 print.txt
12/01/2023  09:45 PM    <DIR>          res
07/27/2021  04:06 AM         4,814,984 stunnel.exe
10/30/2019  11:34 PM           587,928 tap-windows.exe
06/17/2021  12:51 AM            45,432 tapctl.exe
12/02/2023  08:01 AM            93,256 uninstall.exe
04/21/2022  04:26 AM        25,314,320 VC_redist.x64.exe
12/16/2021  02:50 AM         3,000,552 wgtunnel.dll
06/25/2021  12:03 PM           604,848 wintun.dll
10/15/2021  11:47 PM         1,340,728 wireguard.dll
              25 File(s)     47,645,904 bytes
               3 Dir(s)  448,830,984,192 bytes free


List of installed programs - attached.

When the installer first ran it installed the latest Microsoft Visual C++ redistributable however there doesn't appear to be an issue with this.

Any help getting this running would be appreciated.
I previously had AirVPN working through the Eddie-UI installer on this PC before a system reset  I was confident it was the same version as well.

Kind Regards,

 

Installed Programs 02.12.2023.PNG

Share this post


Link to post

Please note to those reviewing this topic may that it may stay unapproved and remain unresolved. Since posting I have moved from Windows 8 to linux mint XFCE and have not been having any issues.

Share this post


Link to post

I will mark this as solved to underline that Linux Is The Solution. :) Especially to all kinds of Windows problems :D


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...