Jump to content
Not connected, Your IP: 44.210.77.106
Staff

Eddie Android edition 3.0 preview available

Recommended Posts

experiencing strange behaviour...
after connecting it manually at 16,58 it disconnects and reconnects well
log in client area

Share this post


Link to post

today eddie disconnects and reconnects two-three times and reconnects but the third or fourth time it fails to reconnect
I left the screen on for 5-6 minutes after failing to reconnect but nothing happens, eddie icon change to key and nothing can connect

Share this post


Link to post
32 minutes ago, harold.lewis said:

today eddie disconnects and reconnects two-three times and reconnects but the third or fourth time it fails to reconnect
I left the screen on for 5-6 minutes after failing to reconnect but nothing happens, eddie icon change to key and nothing can connect


Thank you, this is a relevant information. You can stop sending us reports, we have collected enough data. Now you should tell us, if you can, and this is very important too, the exact name and version of your phone custom ROM.

Kind regards
 

Share this post


Link to post

Hello!

We're very glad to inform you that Eddie Android edition 3.0 Beta 3 is now available. The original post has been updated accordingly.
 

New in Beta 3:

  • objects management change in order to prevent Android GC from destroying them and causing various issues while Eddie is connected through WireGuard and swiped out
  • latest OpenVPN3-AirVPN library, linked against OpenSSL 1.1.1r
  • bug fixes resolving app crashes after peculiar actions
  • minor bug fixes
The first change is critically important and resolves the multiple problems reported both in the current thread and privately. When Eddie 3.0 preview up to beta 2 version is connected via WireGuard and swiped out, if you recall Eddie after some time (especially but not exclusively when the device screen had been turned off or the device had been locked), you may find it reporting incorrect status, reset and stuck connection statistics, quick connection button frozen. All the problems affect every previous Eddie 3.0 preview version, in every Android version, only with WireGuard connections, and have a single common cause which was finally found. The latest beta 3 resolves the whole issue according to our tests. If you experienced any of the above problems we warmly invite you to test again in the same conditions and report back.

Find full description, download link and SHA256 signature in the first post of this very thread.

Thank you very much for your tests and please report and describe any bug you find!

Kind regards
 

Share this post


Link to post

You forgot to update Beta 2 to 3 in text: "You can download Eddie Android 3.0 Beta 2 AP K directly from our repository:" :)

Share this post


Link to post
6 hours ago, Alexei Sator said:

When will this be available on Playstore?


Hello!

When a stable version is available. Since there are no bug reports so far and the internal testing is just fine, it could be quite soon.

Kind regards
 

Share this post


Link to post
3 hours ago, Staff said:

Hello!

When a stable version is available. Since there are no bug reports so far and the internal testing is just fine, it could be quite soon.

Kind regards
 
Thanks

Share this post


Link to post
@harold.lewis

Hello!

Yes, please send us the report. As you notice, maybe it's not an Eddie bug. Let's see and check. Thank you for your tests again!

Kind regards
 

Share this post


Link to post
On 10/21/2022 at 2:10 PM, harold.lewis said:
https://twitter.com/GrapheneOS/status/1563215751833477120

Well, I've experienced disconnection without reconnection at list once a day, I've not posted the log because may not be related to Eddie but if you want I may post the log if needed...
I'm seeing the same thing, sometimes multiple times a day, since I updated to beta 3.
A support email with logs is in the making.

Share this post


Link to post

Hi, testing appears to work okay. I was getting random WG disconnections on one device however on the other (with a more newer kernel, grapheneOS) it works okay. Does the @Staff know whether latest Android/Pixel kernels have WG in the kernel or is this an app/userspace implementation?

Two suggestions:

1: When there is 5 or more devices connected there is no error notifying you of such, nor can you manage those devices. It may be worth adding the ability to use the API and manage devices within the app (renew keys with the new API, disconnect devices etc). At the moment it keeps infinitely trying to connect before giving up eventually.

The second is a bigger request but absolutely a desired feature

2: Connect per mode (Wifi/4G (/cellular)): When at home, the network runs via a VPN anyway, so a VPN is not needed although one can be used. When on 4G there is absolutely a need to use VPN. Can we have an option so that the VPN auto connects when using mobile data, at the moment it's quite a pain to manage it manually. So something like:

if(user turns on 4g)
if(VPN is not active/connected)
connectVPN()

A per SSID config would be great too, but at least ensuring that when 4G is connected the VPN is active (and if block mode is not set in system settings, the VPN lock is auto enabled as a best effort to avoid leaks).


Thanks!

Share this post


Link to post

deed e removal and a reinstall, from Saturday I was having no problem in disconnecting and reconnecting but today after all day with no problem, in the evening again not reconnecting,..
log in the client area
it seems that some servers are not giving problems but others have sometimes problem for reconnecting

Share this post


Link to post

Hello!

@airvpnforumuser

Thank you for your suggestions. In the current beta testing, main features are frozen and only bug fixes are implemented, in general, but for the next future release feedback will be taken into due consideration as usual.

@harold.lewis

Thank you for your tests again. We have some progress on the malfunction reported by various users. We have realized that it has been reported not infrequently on the Internet for WireGuard and only in Android 13, so it does not seem related to Eddie, but to the WireGuard library called by Eddie. We suspect that the problem should occur with WireGuard only, and only in Android 12 and 13. Investigation goes on.

Kind regards
 

Share this post


Link to post

Interesting! I am seeing this with wireguard and Android 13 so I switched to OpenVPN and will observe if that makes a difference.

Share this post


Link to post

Hello!

We're very glad to inform you that Eddie Android edition 3.0 Beta 4 is now available. The original post has been updated accordingly.
 

New in Beta 4:

  • Improved management of WireGuard in Android 13 to resolve a WireGuard issue related to system network changes

The mentioned issue has been found out by community testers and other persons using the official WireGuard client with any VPN service only in some Android 13 kernel releases. The implemented modification aims at resolving the problem at its root by having WireGuard re-connect every time the device records a network change, provided that "Always on VPN" and "Block connections without VPN" Android settings, as well as "VPN reconnection" Eddie option, are all enabled.

Find full description, download link and SHA256 signature in the first post of this very thread.

Thank you very much for your tests and please report and describe any bug you find!

Kind regards

Share this post


Link to post

not sure what happened but play protect prevented me from installing this and Avast mobile detects this as a trojan. virustotal also confirms this as a Trojan

Share this post


Link to post
2 hours ago, mamegoma said:

not sure what happened but play protect prevented me from installing this and Avast mobile detects this as a trojan. virustotal also confirms this as a Trojan


Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 

Share this post


Link to post
6 hours ago, Staff said:

Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 
 Yup i have verified and it is indeed the correct hash. Also by the way, the application on the play store is misspelt. i believe its missing "N" for the beta version.

Share this post


Link to post
16 hours ago, mamegoma said:
22 hours ago, Staff said:

Hello!

Please check the APK SHA based signature (published in this thread 1st message) carefully to confirm that it's a false positive.

Kind regards
 
 Yup i have verified and it is indeed the correct hash. Also by the way, the application on the play store is misspelt. i believe its missing "N" for the beta version.

Hello!

Eddie 3 beta versions are not available on the play store, can you please elaborate?

Kind regards
 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...