Jump to content
Not connected, Your IP: 3.237.2.4
airsupportusertempforum

Bluetit/Goldcrest: automatically restoring connection

Recommended Posts

Posted ... (edited)

Hi.

I have been working with AirVPN support to try and understand how to best manage a somewhat common scenario. Any additional thoughts/comments will be appreciated.

Problem: Sometimes the connection established by Bluetit dies - this can be for any number of reasons. When this happens, I encounter a similar problem reported here

The issue I am facing is that when the tunnel dies (I simulate by removing ethernet cable from device) the connection is not re-established. I need to manually log in to my device, run a few commands and the connection is restored.

I understand I could probably make a script to try and detect the problem (for example, attempt to make a http request) and then run a .sh file with some commands...

But why can't bluetit/goldcrest recover in such a situation? And what is the best way to handle this situation without manual input? If I need to make a script, how can I handle any possible edge cases? I am wondering if others in this community have had such issues and how they are resolved...

Thanks.

Edited ... by airsupportusertempforum

Share this post


Link to post

I'm assuming you've tried

# goldcrest --recover-network
and that does not work.

Where does your symlink resolv.conf.airvpnbackup point in /etc/airvpn?

I had a similar issue and had to remap it from ../run/systemd/resolve/stub-resolv.conf to /run/systemd/resolve/stub-resolv.conf

Share this post


Link to post
@airsupportusertempforum
@cannac

Hello!

Those problems you mention should be different and unrelated. When Bluetit gets stuck in a loop of re-connections caused by OpenVPN3-AirPVN inability to reconnect to the same server, no --recover-network should be necessary, provided that you stop Bluetit properly, or you just send a disconnect command. Then you can send an air-connect command or what you need. The OpenVPN3 inability to re-connect when you abruptly disconnect, and later re-connect, the Ethernet cable will be investigated. As far as we can see it may occur with OpenVPN 2 too and we suspect to know why. In such cases anyway a disconnection followed by a connection resolves the issue both with OpenVPN3-AirVPN and OpenVPN 2.

The problem mentioned by @cannac has not been reproduced unfortunately. and we have no clues or suggestions at the moment. Can you tell us your Linux distribution name and version and describe the problem which forced you to change the symlink?

Kind regards

 

Share this post


Link to post

Sure, I've had this issue consistently on ubuntu 20.04 (both amd64 and aarch64) running airvpn suite 1.1.0.
Without changing the symlink, --recover-network does not work.

Maybe this should be moved to different topic, since my post was unrelated?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...