Jump to content
Not connected, Your IP: 3.236.214.224
Stack of computer parts

AirvpnSuite triggering power save mode on wwan(USB) modem

Recommended Posts

I am using Debian 11(testing) and a wwan modem that is treated like a usb device. It seems when running bluetit.service after a minute or so Debian puts the modem to sleep, causing disconnections and network lock.

I believe this is being caused by the system thinking I am only using the TUN interface created by bluetit and thinks I no longer need the usb modem.

Does anyone know how to disable usb power saving for the modem(or specific usb bus)? I don't see any setting besides a global setting for all hibernation features. I still would like suspend and hibernate functionality but it is rather annoying it wont stay awake the way it runs now.

This doesn't happen with the wifi card or ethernet connection but those are on the pci bus and might be managed differently/better.

Share this post


Link to post
I will link to the Arch Linux Wiki for this because Debian Wiki is useless in its current state and Debian uses udev for device management, too.
 
1 hour ago, Stack of computer parts said:

This doesn't happen with the wifi card or ethernet connection but those are on the pci bus and might be managed differently/better.


Or they simply support autosuspend while your modem treats that feature as a hard power down. :)

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

I did see this earlier and try configuring the sleep/powerdown function and it did not have an effect.
The problem turned out to be the modem was in QMI mode and not MBIM(usbif) mode.
One has to log into the modem with putty or some other serial data link and use the AT! commands to ensure the setting is right.

This actually did not happen on other *Nix systems, just debian and bluetit, so maybe there's some interesting thing going on there.

Share this post


Link to post
3 hours ago, Stack of computer parts said:

This actually did not happen on other *Nix systems


Really, which ones did you test?

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Sorry to reply late on my own post but i rarely log in here.

In qubes and freebsd this worked in their debian and fedora templates. Until recently.

I think something happened in both(3, counting qubes) recently because qubes templates became suddenly unworkable with the modem.

Debian and fedora as native installs require configuring to mbim now as well.

Not really sure what the issue is. I need the modem to work more then I can diag what happened.

Ill keep poking at it when i have the time.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...