Jump to content
Not connected, Your IP: 3.236.50.173
3tigerlillies

Irritating Timeout On Entering Password

Recommended Posts

Hi, I have a question.........or two.

When I boot my machines, Windows/Linux with AirVPN 2.20.0 set as a start programme, I get the prompt to enter my system password to connect to a server. That's all fair and well, but, I've noticed that after a few seconds vaguely (10-30), that the input area/box greys out and states it has timed out. I then have to exit the programme and restart the process and give it my undivided attention when logging in once more.

This never happened on earlier versions (that I am aware of) and it is sort of irritating to find that such a "feature" as "timing out" cannot be bypassed in Eddie - Settings. Understandably this maybe some sort of security measure for the software, but I don't have any use for auto timed out settings on a non public machine/s

Is there any way to disable the time out for Windows/Linux? Or have I overlooked something in the GUI?

Many thanks.

(Still a satisfied AirVPN user).
🙂

 

Share this post


Link to post

Now it depends on what you're seeing exactly. Can you make a screenshot of the prompt that times out?


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

The prompt that times out, not the resulting error message… but anyway, on Linux it could be the sudo prompt timeout in /etc/sudoers. Could you please run visudo and see if either passwd_timeout or timestamp_timeout are set anywhere?
Can't help with Windows, I'm afraid.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Apologies for the wrong screenshot.
However, here is the output from visudo in terminal

  GNU nano 2.9.3                   /etc/sudoers.tmp                             

#
# This file MUST be edited with the 'visudo' command as root.
#
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
#
# See the man page for details on how to write a sudoers file.
#
Defaults        env_reset
Defaults        mail_badpass
Defaults        secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:$

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification

^G Get Help  ^O Write Out ^W Where Is  ^K Cut Text  ^J Justify   ^C Cur Pos
^X Exit      ^R Read File ^\ Replace   ^U Uncut Text^T To Spell  ^_ Go To Line


There is no mention of either of the above comments. None too bothered with Windows either, as I hardly use it.

Thanks.

Share this post


Link to post

Not set here. Any files in /etc/sudoers.d/?

Can you make a screenshot of the prompt timing out? And is it really 10-30 seconds? Because the default should actually be 5 minutes.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

1712575951_Screenshotfrom2021-06-0610-39-06.png.bfec210ae5f9ed87d61bd9cd9d19eba7.png

Hello again.......

Here is a further screen shot of the Eddie start up process.
The "Authenticate" prompt (that prompt?) is greying out; is timing out at around 30 seconds mark and definately not five minutes.

Regarding the /etc/sudoers.d/
There are five files within it, but there does not appear to be anything regarding passwd_timeout or timestamp_timeout.

Thanks

Share this post


Link to post

What desktop is this? Is this Budgie? Can you run neofetch or inxi -Fz?


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Its a customised Linux Mint.....nothing too special.
Here's the inixi -Fz                                                        

$ inxi -Fz
System:
  Host: emj-K54C Kernel: 4.15.0-144-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Laptop System: ASUSTeK product: K54C v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: K54C v: 1.0 serial: <filter>
  BIOS: American Megatrends v: K54C.202 date: 11/03/2011
Battery:
  ID-1: BAT0 charge: 26.5 Wh condition: 27.4/37.8 Wh (73%)
CPU:
  Topology: Dual Core model: Intel Pentium B960 bits: 64 type: MCP
  L2 cache: 2048 KiB
  Speed: 1183 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 968 2: 895
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1)
  v: 3.3 Mesa 20.0.8
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-144-generic
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
  IF: enp4s0 state: down mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:
  Local Storage: total: 465.76 GiB used: 231.51 GiB (49.7%)
  ID-1: /dev/sda vendor: Seagate model: ST500LM030-2E717D size: 465.76 GiB
Partition:
  ID-1: / size: 451.64 GiB used: 231.51 GiB (51.3%) fs: ext4 dev: /dev/sda6
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2400
Info:
  Processes: 207 Uptime: 6m Memory: 5.73 GiB used: 1.33 GiB (23.2%)
  Shell: bash inxi: 3.0.32
I should have mentioned this earlier.

Further information for the record; running browser "firejailed" also, in "user & groups" checked boxes for nopasswdlogin and nm-openvpn.

The prompt itself does not show itself timing out even when "Details" is activated. It just does it silently.

Cheers!


 

Share this post


Link to post

This matter is still rearing its head. No matter what I do, it is still timing out under a minute. I can cope with this but it is still irksome.

So........

I've deactivated Firejail and now have nopasswd login disabled in Users, I've also unchecked Network Lock on Startup in Eddie settings.

I have even activated the Eddie logging to see if there was a hint as to what may be going on, but it seems that the log does not give a report until the programme has actually started. Anything prior to that is ignored.

So I'm still in the dark here, without any way of altering this behaviour. Hopefully, someone out there has an idea or two as I am truly stumped.

Cheers.

Share this post


Link to post
4 hours ago, 3tigerlillies said:

nopasswd login disabled in Users


This setting will do nothing as you're not trying to login but authenticate as another user via sudo. You should revert that.
The problem could be the configuration of the graphical sudo frontend application, the one that is freezing. But I don't know where you can view and edit that config. Try looking for gksudo in the Cinnamon documentation.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...