Jump to content
Not connected, Your IP: 3.236.214.224
bulbous_blues

Bluetit can't access addresses with ports

Recommended Posts

Hi

I have airvpn/bluetit suite running on my server but when I do I can't access any addresses on my local network that need a port. For example I can access the server itself at the address 192.XXX.XXX.10 but I cant access emby on 192.XXX.XXX.10:8962. Is this something to do with DNS is there a way round this?

Many Thanks

Share this post


Link to post

Upload or paste the contents of bluetit.rc, please. Do not forget to delete the password from it!
 

16 minutes ago, bulbous_blues said:

Is this something to do with DNS is there a way round this?


There are no DNS requests if you connect via IP.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Hi I have pasted below. I tried with ignorednspush on but didnt work. Thanks!


airconnectonboot            quick
airusername                bulbous_blues
airpassword                ************
# airkey                    <airvpn_user_key>
# airserver                    <airvpn_server_name>
# aircountry                <airvpn_country_name>
# airproto                    <udp|tcp>
airport                    37845, 8002
# manifestupdateinterval    <minutes>
# airwhiteserverlist        <server list>
# airblackserverlist        <server list>
# airwhitecountrylist        <server list>
# airblackcountrylist        <server list>
# country                    <ISO code>
# remote                    <ip|url list>
# proto                        <udp|tcp>
# port                        <port>
# tunpersist                <yes|no>
# cipher                    <cipher name>
# tcpqueuelimit                <value>
# ncpdisable                <yes|no>
# networklock                <on|iptables|nftables|pf|off>
# ignorednspush                yes
# timeout                    <seconds>
# compress                    <yes|no|asym>
# tlsversionmin                <disabled|default|tls_1_x>
# proxyhost                    <ip|url>
# proxyport                    <port>
# proxyusername                <username>
# proxypassword                <password>
# proxybasic                <yes|no>

Share this post


Link to post

Any other ideas why running vpn would not allow me to connect to internal addresses with ports.Oh btw all these services are dockers, if that makes a difference.

Share this post


Link to post
@bulbous_blues

Hello!

Bluetit can't interfere and should not be responsible of the issue you report.

In bluetit.rc file, the following line is wrong:
airport                    37845, 8002

because only one port must be provided and because none of those ports are valid. Our OpenVPN processes listen to ports 53, 80, 443, 1194, 2018.

In this case you might not notice the error because "airport" directive is ignored when connection mode is set to "quick" (NOTE: this feature changes in Suite 1.1.0). Anyway feel free to send us Bluetit log:
sudo journalctl | grep bluetit


Kind regards

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...