Jump to content
Not connected, Your IP: 18.204.2.146
OWild

"Don't ask elevation every run" missing

Recommended Posts

Hi there,

 

 

I have two systems with last debian and last eddie version (2.20.0). With the first one i have the « Don't ask elevation every run » option in my preferences  but not with the second one.

 

I have read the « Read before posting » topic but the link to the FAQ is broken and the link to the manual have no manual, so I post here. I have also read https://eddie.website/#support

 

Is anyone have an idea to activate the option « Don't ask elevation every run » in my preferences ?

Share this post


Link to post

Are the two systems identical, as in, installed from the very same image, for example?


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
Quote
Are the two systems identical, as in, installed from the very same image, for example?
No they are not. I have installed them with an interval of 2 years. The most fresh install is the one with the "don't ask elevation" option.

Share this post


Link to post
21 hours ago, OWild said:
Quote
Are the two systems identical, as in, installed from the very same image, for example?
No they are not. I have installed them with an interval of 2 years. The most fresh install is the one with the "don't ask elevation" option.
Nevertheless, eddie should be automatically installed with all dependencies that it needs to have the "don't ask elevation" option, I assume

Share this post


Link to post
8 hours ago, OWild said:

Nevertheless, eddie should be automatically installed with all dependencies that it needs to have the "don't ask elevation" option, I assume


I'm not sure if it's a dependency issue because it's not exclusive to Debian. Here's a possible workaround, if not solution:

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Thanks for your help my dear !


Expert mode option activated in advanced tab of preferences.

Installation of eddie-elevated.service returned :

Quote

tee: /usr/lib/systemd/system/eddie-elevated.service: Aucun fichier ou dossier de ce type
[Unit]
Description=Eddie Elevated Service
Requires=network.target
After=network.target

[Service]
Type=simple
ExecStart=/usr/lib/eddie-ui/eddie-cli-elevated service
Restart=always
RestartSec=1s
TimeoutStopSec=5s

[Install]
WantedBy=multi-user.target


Since i don't have a "system" folder under /usr/lib/systemd/ but :
boot  catalog  logind.conf.d  scripts  system-environment-generators  user  user-environment-generators  user-generators  user-preset

May have I to mkdir "system" folder or to install  eddie-elevated.service under "user" folder ?

 

Share this post


Link to post
3 hours ago, OWild said:

May have I to mkdir "system" folder or to install  eddie-elevated.service under "user" folder ?


Depends on the systemd config of your distribution. Generally, I'd say it might do the trick, but it's better to check the manual page of systemd.unit beforehand to see if there are special paths for unit files.
Does /etc/systemd/system/ exist? If yes, you could use that.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
22 minutes ago, OpenSourcerer said:

Depends on the systemd config of your distribution. Generally, I'd say it might do the trick, but it's better to check the manual page of systemd.unit beforehand to see if there are special paths for unit files.
Does /etc/systemd/system/ exist? If yes, you could use that. 

And you win !!!

I have created the /usr/lib/systemd/system/ and put the file eddie-elevated.service inside it and it works !

So the command for debian 10 is :
sudo mkdir
/usr/lib/systemd/system/
curl -sSfL https://eddie.website/temp/eddie-elevated.service | sudo tee /usr/lib/systemd/system/eddie-elevated.service && sudo systemctl daemon-reload 

Thanks for the help M. OpenSourcerer !
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...