Jump to content
Not connected, Your IP: 3.238.130.97
IcaMaxi

Port forwarding not working for plex or transmission on synology NAS

Recommended Posts

Posted ... (edited)

I'm running transmission in a docker, and plex as a DSM package.  I've read through a myriad of posts.

I have opened a port on https://airvpn.org/ports/ for X remotely, and 32400 locally. I've confirmed the remote port is open. On my router, I've forwarded the external port X, for all hosts, to port 32400 on my NAS. On plex, the local port is fixed at 32400, and I've set the remote port to X. Same thing on my transmission docker, only with one more layer of ports to get inside the container.

I've confirmed that I can reach the internet with the VPN turned on, and that with the VPN off, all port forwarding works fine. I can access my plex server remotely, and the transmission peer listening port reports as open.

Edit: Like an idiot, I didn't also try this on my desktop until now. Running Ubuntu 20.04, the Eddie client, and transmission, same setup as previously (with different ports, so no conflicts), and I'm still having the same problem. So obviously I'm doing something wrong, or something is wrong with my router? My router model is sagemcom 3890v3 by the way. Modified to my specific ISP, and so imposed on me. Only ISP available where I live as well so there's unfortunately no getting around that.

Anyone have any ideas on what I could do to fix this?

Thanks.

Edited ... by IcaMaxi

Share this post


Link to post

So, which device connects to AirVPN, the Sagemcom router or the Synology?


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

If the NAS connects to AirVPN, setting anything on the router is superfluous. The only setting you need to take care of is to make Transmission listen on the tun0 interface. Since it's running in a container, then you probably need some option you can give to Docker to tell it to listen on tun0 instead, I don't know the details there. #readthedocs :)


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...