Jump to content
Not connected, Your IP: 3.230.119.106
Sasheca

ANSWERED Eddie 2.18.9 OpenVPN GUI not accessable on Debian 10

Recommended Posts

Hi there,

I've downloaded and installed Eddie 2.18.9 on Debian 10 (Buster).
I started Eddie OpenVPN GUI from the Applications menu.
Then I configure it through Eddie's graphical interface /similar like Windows UI/.
I've also include Eddie in the list of Start Up Programs.

When Debian loads it asks me for password to start Eddie, I enter it and AirVPN service starts.
I confirmed that with ipleak and everything is ok. The service is running.

But I can't see the Graphical Interface. :@

If I try to start Eddie OpenVPN GUI from the Applications menu - the OS says that there is already a running process /which is true checking it in System Monitor tool/.

So, why is that? Why can't I access the GUI anymore?

The only way to close the program is to kill the process which is not the point.
 

Share this post


Link to post
2 hours ago, Stefan Tanev said:

Then I configure it through Eddie's graphical interface /similar like Windows UI/.


Where do you do that? General > Connect at startup?

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Yes. Exactly. In General settings.

I've placed a check in the boxes for:
1. Connect at startup.
2. Start with system.

May be I can uncheck this through the terminal with a command.

Share this post


Link to post

Do you remember having also checked to start minimized to tray? there are some posts about it stopping to work.
You can try removing your default profile for a fresh start of eddie.
Kill eddie and run it from the command line. Find a line similar to "Profile path: /usr/lib/eddie-ui/default.profile".
Kill eddie again and delete or move that file to a save place (eddie will create a new one when started).

Try to run eddie and set everything up again.

Share this post


Link to post
On 6/26/2020 at 10:15 AM, Sasheca said:

2. Start with system.


Interestingly, I don't have this. 😮

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
On 6/28/2020 at 11:21 AM, eburom said:

Do you remember having also checked to start minimized to tray? there are some posts about it stopping to work.
You can try removing your default profile for a fresh start of eddie.
Kill eddie and run it from the command line. Find a line similar to "Profile path: /usr/lib/eddie-ui/default.profile".
Kill eddie again and delete or move that file to a save place (eddie will create a new one when started).

Try to run eddie and set everything up again.


Yes, @eburom. That worked for me. Fortunately I've found this topic  and the same suggestion made by you but for Ubuntu.

Once I've started Eddie GUI, I unchecked Connect at startup and Start with system.

Everything is ok now. Thank you for your help.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...