Jump to content
Not connected, Your IP: 18.234.255.5
Staff

Hummingbird 1.1.0 beta 1 released

Recommended Posts


Hello!

We're very glad to inform you that we have just released Hummingbird 1.1.0 beta 1, featuring:

  • SystemV-style init support for Linux
  • update to the latest OpenVPN3-AirVPN and asio libraries

Hummingbird is AirVPN's free and open source OpenVPN 3 client based on AirVPN's OpenVPN 3 library fork. Hummingbird is available for:
  • Linux x86-64
  • Linux ARM 32 (example: Raspbian for Raspberry Pi)
  • Linux ARM 64
  • macOS (Mojave or higher version required)

 

For a thorough Hummingbird overview please consult https://airvpn.org/hummingbird/readme/

Hummingbird 1.1.0 adds support to Linux systems based on SystemV-style init https://en.wikipedia.org/wiki/Init#SYSV, while the previous versions supported Linux systemd based systems only.

Therefore, we gladly achieve compatibility with 35 additional Linux distributions:
https://distrowatch.com/search.php?ostype=All&category=All&origin=All&basedon=All&notbasedon=None&desktop=All&architecture=All&package=All&rolling=All&isosize=All&netinstall=All&language=All&defaultinit=SysV&status=Active#simple

We think it's important to support Init Freedom:
https://devuan.org/os/init-freedom

because systemd is POSIX incompatible and because, as the UNIX Veteran Admin collective noticed in 2014 when they announced a Debian fork:
This situation prospects a lock in systemd dependencies which is de-facto 
threatening freedom of development and has serious consequences for Debian, 
its upstream and its downstream.

Download URLs follow.

Linux x86-64:
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-x86_64-1.1.0-beta-1.tar.gz
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-x86_64-1.1.0-beta-1.tar.gz.sha512

Linux armv7l (ARM 32 bit):
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-armv7l-1.0.3.tar.gz.sha512
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-armv7l-1.1.0-beta-1.tar.gz

Linux aarch64 (ARM 64 bit):
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-aarch64-1.1.0-beta-1.tar.gz
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-linux-aarch64-1.1.0-beta-1.tar.gz.sha512

macOS (please note: beta version is not notarized):
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-macos-1.1.0-beta-1.tar.gz
https://gitlab.com/AirVPN/hummingbird/-/blob/master/binary/hummingbird-macos-1.1.0-beta-1.tar.gz.sha512

Kind regards & datalove
AirVPN Staff
 

Share this post


Link to post
24 minutes ago, Staff said:

SystemV-style init support for Linux

Nice!

I can see that only the binaries have been deployed.. Is that because of this version being in beta stage yet?
 

Share this post


Link to post

Lets hope this version finally corrects the handshake error.

Share this post


Link to post

Thanks for your work. Is it possible to use this version with Eddie (saw an option in Advanced Settings) to take advantage of the latest OpenVPN3-AirVPN?

Share this post


Link to post
@Maggie144+

Hello and thank you!

Yes, of course:
  • from Eddie's main window select "Preferences" > "Advanced"
  • tick "Use Hummingbird if available"
  • click "Save"
  • copy Hummingbird binary file in a directory included in the commands path (you will need root privileges to do so)
Re-start Eddie to apply the changes and use Hummingbird via Eddie.

Kind regards
 

Share this post


Link to post

So I copied Hummingbird (1.1.0 beta 1) to /usr/local/bin 
I can use it via command line - no problem.
Activated using Hummingbird in Eddie (2.19.2) and restarted, but it's using Hummingbird 1.0.2 (which is located in the Eddie packet)
Tried to replace said version with the current beta, but then Eddie won't start up at all with the following error:
 

Unable to obtain elevated privileges (required): Object reference not set to an instance of an object


It's only able to start again when using the original version which shipped with Eddie 2.19.2

Share this post


Link to post
2 hours ago, Maggie144 said:

So I copied Hummingbird (1.1.0 beta 1) to /usr/local/bin 
I can use it via command line - no problem.
Activated using Hummingbird in Eddie (2.19.2) and restarted, but it's using Hummingbird 1.0.2 (which is located in the Eddie packet)
Tried to replace said version with the current beta, but then Eddie won't start up at all with the following error:
 


Unable to obtain elevated privileges (required): Object reference not set to an instance of an object


It's only able to start again when using the original version which shipped with Eddie 2.19.2

First i have Hummingbird copied to /usr/lib/eddie-ui/
I use openSUSE leap 15.1
Hummingbird must have root rights in that directory!
Hope this helps you something

Share this post


Link to post

Sorry forgot to mention - I'm on macOS Catalina 10.15.5 (which should be named Vista - a complete shit-show this version)
I did use root to copy to /usr/local/bin - so terminal works.
I also used root to replace the "old" version with the new in /Applications/Eddie.app/Contents/MacOS folder - but still said Error message shows up..
Looks like I'll have to wait till Eddie 2.19.3 - which hopefully ships with a newer Hummingbird version

Share this post


Link to post

We hope to release 2.19.3 probably tomorrow, it fixes the "Unable to obtain elevated privileges (required): Object reference not set to an instance of an object" issue. Of course with Hummingbird updated. Please be patient, thx.

Share this post


Link to post

@Maggie144 has a specific macOS bug that will be fixed soon.

@colorman, Linux,
If you tick
Preferences -> Advanced -> Use Hummingbird, Eddie will search for Hummingbird executable in environment paths. Otherwise a path can be set with option "--tools.hummingbird.path=/path/to/...". Sorry, no UI right now, it will be available in 2.19.3.
But remember:
you need to ensure "chmod +x /path/to/hummingbird" 
AND
"
chown root /path/to/hummingbird". An Eddie security protection requires root ownership.
 

Share this post


Link to post

I still have the sporadic ongoing handshake error, I have tried changing the ovpn file to initiate the handshake instead of server with a  reneg-sec 1200  entry but results are variable certainly not consistent. I have tried individual servers but sometimes just use the the country (UK) opvn file. This morning the connection seems slow so I did a speed test with VPN connected to Naos 15Mbps disconnected 63Mbps, disappointing.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...