Jump to content
Not connected, Your IP: 100.24.113.182
Thrace

AsusWRT - OpenVPN Port Forwarding

Recommended Posts

Hi,
I have Asus Router with stock AsusWRT.
I installed ovpn and everything is fine. My router shares VPN to all my netwotk.

Also i am hosting a monero node at my local pc.
I forwarded 3 ports and set monero to listen on those 3 ports.
A website to check ports says my ports are closed. Also Port forwarding page of AirVPN shows dark grey about my ports. Also my monero node doesnt have incoming connections.

So definitely something is wrong.
i suspected that:
My router is connected AirVPN and those ports supposed to be open at my router. So i tried to forward those 3 ports to my local pc. But no luck.
I am sure if connect to AirVPN with my pc with Eddie it will work. But I need to do this with my router.

So any suggestions?

Cheers

Share this post


Link to post
12 hours ago, Yanik39 said:

So i tried to forward those 3 ports to my local pc.


Did you also forward them explicitly from the tun interface?

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
1 hour ago, giganerd said:

Did you also forward them explicitly from the tun interface?

tun interface?
There is OpenVPN settings and Port Forwardin at AsusWRT.

Port forwarding doesnt forwards ports from vpn connections.
So not sure how to forward open ports from AirVPN to my pc.

Share this post


Link to post


You'll probably need to SSH into the router to paste the proper iptables according to the above guide.

With stock asus you'll have to do this every reboot of the router.  If you got merlin asus you may be able to automate this using scripts saved in jffs .

Share this post


Link to post
Posted ... (edited)

Thanks for your time.
I have added iptables rules and all good now :D

I had entware at my stock asus router system for deluge torrent.
I guess i can run a script at router boot with entware to add those iptables.

Cheers

Edit: I accomplished to add those iptables rules automatically after boot at stock AsusWRT.
So now my router forwards my AirVPN opened ports to my PC.

I had a 2 day trial to test it out.
And few mins ago i purchased for 3 years :D

Thanks again.

Edited ... by Yanik39
update

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...