Jump to content
Not connected, Your IP: 34.200.252.156
Staff

Eddie Desktop 2.19beta released

Recommended Posts

For those of us on Windows 10 who installed OpenVPN v2.5.0 in order to use the Wintun Adapter can we just upgrade to Eddie v2.19.5 direct or should we uninstall openvpn and go for a clean install of Eddie?.

Share this post


Link to post

installed Eddiie 2.19.5 on Arch but when I launch it is complaining that SSL is Not Available but OpenSSL is installed, than is connecting

 

. 2020.11.08 14:29:30 - Profile path: /home/computer/.config/eddie/default.profile
. 2020.11.08 14:29:30 - Reading options from /home/computer/.config/eddie/default.profile
. 2020.11.08 14:29:31 - Tun Driver - /dev/net/tun
. 2020.11.08 14:29:31 - OpenVPN - Version: 2.5.0 - OpenSSL 1.1.1h  22 Sep 2020, LZO 2.10 (/usr/bin/openvpn)
. 2020.11.08 14:29:31 - SSH - Version: OpenSSH_8.4p1, OpenSSL 1.1.1h  22 Sep 2020 (/usr/bin/ssh)
W 2020.11.08 14:29:31 - SSL - Not available
. 2020.11.08 14:29:31 - curl - Version: 7.73.0 (/usr/bin/curl)
I 2020.11.08 14:29:31 - Ready
. 2020.11.08 14:29:32 - Collect information about AirVPN completed

 

Share this post


Link to post

Im running Eddie 2.18.5 because all other versions up to 2.19.5 are always resetting the right " Don't ask elevation every run" anyone a idea how to fix this?

Share this post


Link to post

Ill have to do some more testing later when I can remove Little Snitch but whatever Apple did to DNS tunneling in Big Sur still causes Eddie to kernel panic in the MacOS when Little Snitch is running with it. Think it may be something to do with the daemon and Apple's new policies but gotta look into it.. The OS is more than likely going to drop on Tuesday after the Apple event. 

Share this post


Link to post

Hey, anyone seen this error before?  It's my first time seeing it and I don't understand.

Unable to initialize native library.  Maybe a CPU architecture issue.
Eddie UI won't even open.  Privileges/permissions don't matter, I just get that message
 

My 2.18.9 x64 portable works just fine with OpenVPN 2.5_git version.  It happens only with Eddie 2.19.5 x64 portable.  I'm on Windows 10 Pro x64 (2004 -- not H2), on Ryzen 3700X

Share this post


Link to post

Hmmm it gives me this error when i follow all stepsfrom here:

W 2020.11.08 20:25:38 - OpenVPN > Options error: Unrecognized option or missing or extra parameter(s) in C:\Users\Colt\AppData\Local\Eddie\a77f2c3e5bb08a9a95af35ef33888646cd5033799e10e967503b9b4f5d215b0b.tmp.ovpn:14: data-ciphers (2.5_git)
 

Share this post


Link to post
@mazeman23

Hello!

OpenVPN 2.5_git you're running seems to not support data-ciphers, or the directive argument(s) is/are missing or illegal. Changing basic options on the run between beta , RC and stable versions seems not infrequent in OpenVPN development. Can you please re-check the OpenVPN version you're running? If it's really OpenVPN 2.5 stable, check the configuration file that Eddie generates (in "Stats" window double click the item pertaining to the generated OpenVPN profile), and examine the "data-ciphers" line (send the config to us as well if in doubt, cut certificates and keys).

@harold.lewis

"SSL not available" is what Eddie prints when it can't find stunnel (yes, it's a weird way to say it :) ).

Kind regards
 

Share this post


Link to post

I got the same error message as Cambell (who posted above) on a Win10 2004 machine and had to roll back to latest stable version of Eddie.  No problems with 2.19.5 on a Win 10 1909 or Win7 32 bit machine.

 

Share this post


Link to post
Posted ... (edited)

Hey guys,

I've been trying to run eddie-cli 2.19.4/2.19.5 on on a 64 bit version of Ubuntu designed for the raspberry pi devices which support the aarch64 architecture. Every time eddie attempts to raise system privileges, there appears to be an issue which causes eddie to use nearly all of the available memory (2GB model) and crash with 'Unable to obtain elevated privileges (required): Unable to start (std::bad_alloc)'. It will loop infinitely until I force cancel the program. 
 

Nov 11 22:58:23 torrentpi eddie-ui[2443]: . 2020.11.11 22:58:23 - Raise system privileges
Nov 11 22:58:23 torrentpi eddie-ui[2458]: Listening on port 22334
Nov 11 22:58:57 torrentpi eddie-ui[2443]: F 2020.11.11 22:58:57 - Unable to obtain elevated privileges (required): Unable to start (std::bad_alloc)
Nov 11 22:58:57 torrentpi eddie-ui[2443]: . 2020.11.11 22:58:57 - Shutdown in progress
Nov 11 22:58:57 torrentpi eddie-ui[2443]: . 2020.11.11 22:58:57 - Shutdown complete


Does anyone know as to if there is anything I'm doing which could be causing this issue or is this simply because 2.19.5 is still in the experimental branch?
 

Edited ... by kid_kyrie
Added command line logs

Share this post


Link to post
On 11/8/2020 at 2:39 PM, harold.lewis said:

installed Eddiie 2.19.5 on Arch but when I launch it is complaining that SSL is Not Available but OpenSSL is installed, than is connecting


On Arch launch
sudo pacman -S stunnel

Share this post


Link to post

Version 2.19.6 (Thu, 12 Nov 2020 13:01:54 +0000)

  • [change] Windows 7/8: OpenVPN 2.5.0 in bundle
  • [change] Absence of SSH or SSL log level from Warning to Info
  • [bugfix] Fixed an elevation issue with sudo in CLI mode
  • [bugfix] Windows: Error VCRUNTIME140_1.dll in some environment.

Share this post


Link to post
15 hours ago, kid_kyrie said:

Hey guys,

I've been trying to run eddie-cli 2.19.4/2.19.5 on on a 64 bit version of Ubuntu designed for the raspberry pi devices which support the aarch64 architecture. Every time eddie attempts to raise system privileges, there appears to be an issue which causes eddie to use nearly all of the available memory (2GB model) and crash with 'Unable to obtain elevated privileges (required): Unable to start (std::bad_alloc)'. It will loop infinitely until I force cancel the program. 
 


Hi, we compile Eddie with Raspberry OS 64 beta (based on Debian). I don't have currently an Ubuntu rPI for testing.
Anyway in the latest release we fix a bug related to elevation in CLI mode under Linux, please recheck.

Please note also that aarch64 edition of Eddie include OpenVPN 2.4.8 (armv7 and other platform include the latest 2.5.0). This because OpenVPN build process is not still updated to support aarch64, it's a pending issue.

Share this post


Link to post
On 11/11/2020 at 2:37 AM, debu said:

I got the same error message as Cambell (who posted above) on a Win10 2004 machine and had to roll back to latest stable version of Eddie.  No problems with 2.19.5 on a Win 10 1909 or Win7 32 bit machine.

 

On 11/9/2020 at 7:34 AM, Mizu said:

Hey, anyone seen this error before?  It's my first time seeing it and I don't understand.

Unable to initialize native library.  Maybe a CPU architecture issue.
Eddie UI won't even open.  Privileges/permissions don't matter, I just get that message
 

My 2.18.9 x64 portable works just fine with OpenVPN 2.5_git version.  It happens only with Eddie 2.19.5 x64 portable.  I'm on Windows 10 Pro x64 (2004 -- not H2), on Ryzen 3700X

 

On 11/5/2020 at 11:16 AM, cambell said:

updating to new beta gave me an elevated prompted. After that the progam could not open, so i can not post any logs.

Schermafbeelding 2020-11-05 111050.png


All of your: please retry the latest beta version, contain the fix. Thanks.

Share this post


Link to post
On 11/8/2020 at 6:46 PM, Monotremata said:

Ill have to do some more testing later when I can remove Little Snitch but whatever Apple did to DNS tunneling in Big Sur still causes Eddie to kernel panic in the MacOS when Little Snitch is running with it. Think it may be something to do with the daemon and Apple's new policies but gotta look into it.. The OS is more than likely going to drop on Tuesday after the Apple event. 


I don't understand well, we tested BigSur and don't encounter any particular issue, but i honestly don't know what Little Snitch is.

Share this post


Link to post

@mazeman23

Please download the latest 2.19.6.
Revert to blank the option Preferences -> Advanced -> OpenVPN custom path
Revert to blank any Preferences -> OpenVPN directive

Restart Eddie 2.19.6 and retry.

 

Share this post


Link to post
Posted ... (edited)

Clodo, thanks. 2.19.6. is working great, stay safe🤗
Just 1 thing. Should in settings networking layer inside tunnel ipv4 if issue is deteced be ticked. It isn't by default!
ipv6 is. Thanks

Edited ... by cambell
forget something to ask

Share this post


Link to post
On 11/12/2020 at 3:04 PM, Clodo said:

I don't understand well, we tested BigSur and don't encounter any particular issue, but i honestly don't know what Little Snitch is.
Hey, just to chip in, I use Little Snitch on all my Macs and was thinking about updating to Big Sur, found this thread checking if Eddie had any issues. I think Little Snitch users will overlap with those using Eddie on a Mac quite a lot. I hope there is a solution to this, both are quite important services to me.

Share this post


Link to post

@Clodo 2.19.6 portable no go with " Unable to initialize native library.  Maybe a CPU architecture issue." error, W7 pro x64 fully patched with esu updates.

Share this post


Link to post
8 hours ago, coreoftheapple said:
Hey, just to chip in, I use Little Snitch on all my Macs and was thinking about updating to Big Sur, found this thread checking if Eddie had any issues. I think Little Snitch users will overlap with those using Eddie on a Mac quite a lot. I hope there is a solution to this, both are quite important services to me.

I use Little Snitch, and just updated to Big Sur.  Eddie seems to just hang for me.  I updated to the latest beta, and still no luck.   Seems to loose all internet connectivity until I restart, even if I force quit Eddie (because it hangs when you quit).

Anyone else having issues with Eddie / Little Snitch / Big Sur?

Share this post


Link to post
5 hours ago, pwolverine said:

I use Little Snitch, and just updated to Big Sur.  Eddie seems to just hang for me.  I updated to the latest beta, and still no luck.   Seems to loose all internet connectivity until I restart, even if I force quit Eddie (because it hangs when you quit).

Anyone else having issues with Eddie / Little Snitch / Big Sur?

Yeah same here. Eddie, last time I was able to use it seems to work fine without Little Snitch, and Little Snitch works great on its own but something about the two and Eddie locks up and kernel panics my Mac here. Tried the latest one last night, wiped my preferences, got signed in and tried to connect to a server. Eddie just sat there 'authorizing' and eventually gave up and the minute it stopped the machine froze and rebooted. I dont know if its the daemon or not either, I cant get Eddie open long enough to change the prefs before it freezes or reboots heh. When Little Snitch was still in beta testing a few weeks back, the dev had something on the known issues page about a bug in Big Sur with DNS tunneling that he was hoping Apple would fix by release. Sounds like they maybe didn't fix it? The known issues page is gone now that its been released and he never had much more info than that.

FWIW - Viscosity and Tunnelblick work fine, but they dont have anywhere near Eddie's features obviously. So at least you can still use the VPN if you need to.

Share this post


Link to post
17 hours ago, Monotremata said:

Yeah same here. Eddie, last time I was able to use it seems to work fine without Little Snitch, and Little Snitch works great on its own but something about the two and Eddie locks up and kernel panics my Mac here. Tried the latest one last night, wiped my preferences, got signed in and tried to connect to a server. Eddie just sat there 'authorizing' and eventually gave up and the minute it stopped the machine froze and rebooted. I dont know if its the daemon or not either, I cant get Eddie open long enough to change the prefs before it freezes or reboots heh. When Little Snitch was still in beta testing a few weeks back, the dev had something on the known issues page about a bug in Big Sur with DNS tunneling that he was hoping Apple would fix by release. Sounds like they maybe didn't fix it? The known issues page is gone now that its been released and he never had much more info than that.

FWIW - Viscosity and Tunnelblick work fine, but they dont have anywhere near Eddie's features obviously. So at least you can still use the VPN if you need to.

Thanks, it is great to have some confirmation that it is not just me.   I will try one of the two, Viscosity or Tunnelblick (any recommendations for the moment as I haven't used either?)  I don't know much about Hummingbird from AirVPN, but was thinking I could try that too for the moment to see if things work.  But if Tunnelblock and Viscosity works I wonder if its just an Open VPN part that needs updating or something along those lines.

I E-Mailed support but was told "According to our tests, Eddie 2.19.6 beta runs fine in Big Sur, but Little Snitch is not installed on our system." .. which is a bummer.  I'd assume there would be a high percentage of MacOS users running both Eddie and Little Snitch, that are upgrading or have upgraded to Big Sur.

Share this post


Link to post


 

3 hours ago, pwolverine said:

Thanks, it is great to have some confirmation that it is not just me.   I will try one of the two, Viscosity or Tunnelblick (any recommendations for the moment as I haven't used either?)  I don't know much about Hummingbird from AirVPN, but was thinking I could try that too for the moment to see if things work.  But if Tunnelblock and Viscosity works I wonder if its just an Open VPN part that needs updating or something along those lines.

I E-Mailed support but was told "According to our tests, Eddie 2.19.6 beta runs fine in Big Sur, but Little Snitch is not installed on our system." .. which is a bummer.  I'd assume there would be a high percentage of MacOS users running both Eddie and Little Snitch, that are upgrading or have upgraded to Big Sur.
 

Also having a problem with all the Eddie versions I tried, with Big Sur. Even uninstalled little snitch and still getting the behavior described above, either it can't elevate privilege, Hangs on authorizing, looking for DNS servers, etc. and then crashes. It seems to be a little bit more stable after I removed a little snitch but I'm not sure. This is a real problem for use of air VPN .

I tried the following:  Reverted to an eddie from April.

At first attempt, successfully connected with network lock and chose a server.

Changed network lock to automatically be set at launch, and let eddie choose the server.

This  is what happened:

Hangs on waiting for latency tests
hangs on deactivation of lock

reports: Unexpected crash of elevated helper
 
Then macOS Big Sur froze and crashed.

Little Snitch is not installed. I have never had so many crashes in almost a decade of using macOS with these programs Or any other programs. I am not on the Beta channel, using latest Big Sur release big sur release
 

Share this post


Link to post

^ That pretty much describes exactly what's happening to me, but I had it working with 2.19.5 if I removed Little Snitch. No telling what Apple did after that though. 
Ill give it a try in a bit here and see if I can get .6 to stay up without it. Little Snitch is easy enough to remove for testing. When you delete it from the Applications folder, it pops up a message and tells you its shutting down and removing its extensions too. Little Snitch 3/4 needed a reboot to install and uninstall, 5 just keeps going.

Share this post


Link to post

Same for me. i‘m on big sur without Little snitch now and Eddie (stable and Beta) crashes and freezes  when i try to connect to most of the servers. Some servers work for me (german and swiss servers), but its not possible to connect to netherlands f.ex.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...