Jump to content
Not connected, Your IP: 18.207.254.88
Staff

Eddie Desktop 2.19beta released

Recommended Posts

At present on my Windows 10 PC I am running the 2.18.9 version of AirVPN with the OpenVPN 2.5 git 1607 version and the Wintun TAP Windows 9.24.2 adapter and all is well in fact better than well as the Wintun adapter has more than doubled my download speed. Ever since beginning with AirVPN around 5-6 yrs ago I like to keep up to date and have always installed the experimental versions after checking that they worked fine for other players. I see that there is a v 2.19.2 version of AirVPN available and also an Open VPN gui update to v11.15.0.0  Previously when updating AirVPN I just downloaded it from the experimental option here and did a clean install and the TAP adapter usually installed after a restart of my OS, but as I had to install the OpenVPN v 2.5 in order to use the Wintun adapter for v2.18.9 do I need to follow a different procedure or should I just instal v2.19.2 as I have previously done as I don't want to risk losing my upgraded download speed?.

Share this post


Link to post
@bluesjunior

According to your report you can safely stay with Eddie 2.18.9. Since  you are just fine with 2.18.9 you have no real incentive to start beta testing
as there is no performance improvement with 2.19.2.

Check anyway the bug fixes on the changelog. Should one of those bugs become a problem for you at any time, then you should consider to upgrade.

Kind regards
 

Share this post


Link to post

I have an odd problem running 2.19.2 with Wintun on Windows 10.  When I cold boot my PC the Eddie Elevation Service doesn't start, so the client hangs at the splash screen with the message about connecting to the service.  If I try to start the service manually from services.msc then the Windows error message pops up about the service "...started and then stopped.  Some services stop automatically if they are not in use by other services or programs".  Everything else works ok, and there are no suspicious event log messages.

The weird part is that if I restart rather than cold boot, everything is fine.  Any ideas before I revert back to 2.18?

Share this post


Link to post
2 hours ago, X7iGmXYQBrnz said:

Any ideas before I revert back to 2.18?


Someone, somewhere on the forums suggested to disable Fast Startup.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

I updated to 2.18.9 from the latest stable version with which i never had a problem. I'm on Win 10.
As soon as i started the new version it stuck on Ipv6 check, so i switched on WAN Ipv6 on the Access Data/Internet Connection on my router which i assume helps with Ipv6 stuff (never had to worry about this setting before). That surprisingly solved the problem.
Then i switched off the pc and i switched it on again today. Oddly i found myself connected to a vpn server without actually starting Eddie. (i realized that looking up at my ip)
I noticed there was Eddie-Service-Elevated.exe in execution in Activity Manager, which i don't know what is for, i also noticed OpenVpn Daemon was in execution; so i ran Eddie Ui from the desktop link and the splash screen stucked, i terminated the application and tried again, and this time it showed the Unable to obtain elevated privileges, Unable to start warning window.
So i disabled Fast StartUp and deleted the AppData\Local\Eddie\default.profile file as suggested, downloaded the latest version 2.19.2 because i saw in the changelog this [bugfix] - Special condition elevation checks (may resolve "Unable to start (no-socket)" issues). , i ran it and it seems to work fine for now.
Any idea what happened?

Share this post


Link to post
@Staff

A feature suggestion, it would be nice to be able to see what datacenter/provider a server is hosted in on the server list.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...