In your qBittorrent settings "Enabled prtotcol" should be only "TCP" and not "TCP and µTP", because using µTP could slow your speeds down. You should also bind qBittorrent to your VPN interface in the "Advanced settings". Then it shouldn't leak your real IP: Provided that you have Eddies' Network Lock enabled, there should be no IP leak. Before starting your torrent client, check your connection with Regards BB P.S.: Have you enabled IPv6 in Eddie? You seem to