Jump to content
Not connected, Your IP: 35.172.195.49

Recommended Posts

I'm not sure if I should be posting here and or on the Calibre forum. Please inform me if the latter.

I have a server (A regular computer tower, Windows 10 Pro Version 1903 Build 18362.418) I've been setting up at home and most services have been rather easy to setup (Plex (Local/External), FileZilla (Local Only)). Eddie is always running on this server and many computers and cell phones in my house. The Server is actively running and can be reached via http://127.0.0.1:8080 locally.

First I have Calibre 4.2.0 installed and am running a "Content Server" on 192.168.1.21 TCP Port 8080.
On AirVPN.org I went to "Client Area">"Forwarded Ports"

On "Forwarded Ports", I left the top field blank, select "TCP" port, for Local Port "8080", and left DDNS blank. I've read somewhere that we have to wait an hour for DNS servers throughout AirVPN to propagate the Port Forwarding changes. As far as I understand, no changes are needed to be made on my modem.

I then used the IP address that I found via CMD>ipconfig -all>Looked for TAP>IPv4 Address.

I then tried to reach the site externally via the TAP IPv4 **.*.***.**:8080 and I get "this site cannot be reached". I am testing with devices outside of the network with Windows 10, chrome, edge, and Vivaldi browser and with my iPhone via Safari.

Can anyone see where I messed up, suggestions for reading material? Thank you for your time in advance. Admittedly I've never set up port forwarding.

Share this post


Link to post

As a side note.
I added a DDNS name. 
So the URL should be "DDNSname.airdns.org:8080"

I'm guessing I have to wait an hour before changes take effect on the DNS servers!

Share this post


Link to post
52 minutes ago, mdoverl said:

I've read somewhere that we have to wait an hour for DNS servers throughout AirVPN to propagate the Port Forwarding changes.


More like a few minutes. It may take an hour for the slowest, most remote DNS servers to get wind of this change, but the majority will know within minutes. And it also only applies to DDNS names.
 
52 minutes ago, mdoverl said:

I then tried to reach the site externally via the TAP IPv4 **.*.***.**:8080 and I get "this site cannot be reached".


And it's right. To reach your server from the outside, you need to use either theddnsnameyouentered.airdns.org:12345 (12345 being the random port the system forwarded, since you left the top field blank) or the exit IP of the AirVPN server that Calibre server is connected to (more difficult to remember and keep track of).
NOT the local port you entered! This is the one connections are being routed to in the tunnel's network!

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Alright. Still having problems.

So I tried theddnsnameyouentered.airdns.org:12345 and I replaced 12345 with the port that was generated that was 5 characters long.
I tried using the DHCP IP **.*.***.*:12345 and that didn't connect either.

Quick questions, How would I figure out the VPN exit IP address? I'm assuming it's the DHCP Server in ipconfig -all, is this correct?

Share this post


Link to post

So I installed TCPView and am able to verify that Calibre is listening to port 8080.
Calibre is also allowed via Windows Firewall.

I've noticed that on the AirVPN Forwarded Ports page that "TCP Check" circle is grey. If I click on "test", it says "Checking port 65017 for internal IP 10.4.206.51, please wait",  then it says "Checking port 65017 for internal IP 10.4.206.51 completed." and "Warning: DDNS doesn't work correctly with two o more connections."

I do have Eddie running on two devices at home a the moment, and as far as I'm aware, port 8080 is not in use on the other machine. I will double check.

Share this post


Link to post

I went to add some new ports to test Ubooquity, and noticed that the "TCP Test" was green for port 8080.
Tried http://MyDNS.airdns.org:65017 and it didn't go through.

Share this post


Link to post
1 hour ago, mdoverl said:

How would I figure out the VPN exit IP address?


In a command prompt/PowerShell window:
nslookup servername_exit.airvpn.org
20 minutes ago, mdoverl said:

I've noticed that on the AirVPN Forwarded Ports page that "TCP Check" circle is grey.


If you hover over it, you can see the error code and a short explanation.
 
21 minutes ago, mdoverl said:

"Warning: DDNS doesn't work correctly with two o more connections."

I do have Eddie running on two devices at home a the moment, and as far as I'm aware, port 8080 is not in use on the other machine. I will double check.


It's not about the ports. All your ports are forwarded to all connected devices, so when you open somename.airdns.org:12345 it can try connecting to the first device although you wanted to reach the second. It's not ideal, and the workaround is to stay connected to AirVPN on the server you're running Calibre on, finding out its exit IP and always use that. This also means to not use any of the *.airdns.org addresses to connect to AirVPN servers to not make your life difficult. Pick one and stick to it, it's a server, anyway.
 
1 minute ago, mdoverl said:

I went to add some new ports to test Ubooquity, and noticed that the "TCP Test" was green for port 8080.
Tried http://MyDNS.airdns.org:65017 and it didn't go through.


Please stop testing port 8080 from the outside, you'll never reach it. It's the local port forwarded to the internal 10.x.x.x address of your OpenVPN tunnel and therefore "invisible" to all connecting to the Calibre server.
If it doesn't go through, check on which interface/address Calibre is listening.
Maybe even disable all firewalls. If you use antivirus, disable all functionality of it temporarily as well.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
20 minutes ago, giganerd said:

In a command prompt/PowerShell window:


nslookup servername_exit.airvpn.org

 


What do you know, this worked. I was able to connect to my Calibre server. I'll just have to set Eddie to connect to the same server every time.
What do you think the issue was?
I'm wondering if I should play with No-IP and see if I can get that to work so I don't have to memorize the IP address of the exit server.

Thank you very for much for your patience! I appreciate it. I believe this is the second time you've helped me out.

Share this post


Link to post
19 hours ago, mdoverl said:

What do you think the issue was?


DDNS of AirVPN likely pointing to the connection on which Calibre was not running the whole time.
 
19 hours ago, mdoverl said:

I'm wondering if I should play with No-IP and see if I can get that to work so I don't have to memorize the IP address of the exit server.


It's a good idea, although I'd prefer something like nslookup.info because it's minimalistic but covers all features of a DDNS service. Also, it's open source.
 
19 hours ago, mdoverl said:

Thank you very for much for your patience! I appreciate it. I believe this is the second time you've helped me out.


You're very welcome. :)

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
On 10/24/2019 at 1:04 PM, giganerd said:
On 10/23/2019 at 5:08 PM, mdoverl said:

I'm wondering if I should play with No-IP and see if I can get that to work so I don't have to memorize the IP address of the exit server.


It's a good idea, although I'd prefer something like nslookup.info because it's minimalistic but covers all features of a DDNS service. Also, it's open source.

I'll look into that, thank you. I'm experimenting with a few this being that this is my first server I'm building. It's pretty fun and exciting.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...