Jump to content
Not connected, Your IP: 3.231.229.89
bluvisnu

VPN with config generator showing my real address on Linux

Recommended Posts

Hi, i am on Manjaro Linux using the Eddie Openvpn software and it works flawlessly but what i want is to use the Config generator importing a saved VPN configuration to get a better OS integration without using Eddie.
So i used the config generator for some time until i noticed that my IP wasn't hidden anymore or wasn't ever hidden, for example when i type 'my IP' on the Duckduckgo search i get the VPN IP address somewhere else in the world which is what i want but if i go on an IP testing website they show my real address. i changed my browser settings to fix the leaks and stuff but nothing does it until i just use Eddie, I am forgetting something in the settings ? what can i do ?
i'd like to understand what is wrong thank you for your help

Share this post


Link to post

Which client are you trying to use?


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Just with the Linux network settings i can import a saved VPN configuration file just like the Openvpn ones or the ones generated on Airvpn. (see the screenshot)

Screenshot_20191002_200824.png

Share this post


Link to post

I tried that as well with KDE's network manager. It's neat because you can automatically connect to a VPN once you enable a network profile which saves time and does also work as DNS leak protection when you configure a static DNS server. However, it's not always clear when that connection has a problem and the logs are more or less "hidden". The import does not work very well and it doesn't support some of the directives AirVPN sets and I also couldn't make it work properly with IPv6 back then. Maybe things changed now. I should probably test myself :D

Which sites are you testing your OpenVPN connection against and what exactly do they report? It could very well be that you simply didn't configure it to use AirDNS, as the network manager doesn't change what the profile on which you connect with the OpenVPN profile dictates.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Yes that's what i used to do, i just make it connect with my wifi automatically so i never have to think about it, but it doesn't work anymore.
So i just type 'my ip' on duckduckdo which shows the ip address from the VPN (screenshot), then i try some websites from the first duckduckgo page and some shows my real ip address and ISP without allowing them to know my location from the browser (other screenshot same connection with KDE network manager), for exemple myip.com, whatismyip.com, whatismyip.network, whatismyipaddress.com... with Eddie my IP address is hidden in every website but with KDE network manager some websites can see my IP address but duckduckgo shows the VPN address.
if i am not mad it used to work and i used Airvpn for 6 months this way, do i forget a setting using KDE network manager because i just add the VPN file and don't add any other setting to it.

Screenshot_20191003_074946.png

Screenshot_20191003_080237.png

Share this post


Link to post

Do you have the same problem if you use OpenVPN from command line?


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

For information i had this problem on Manjaro KDE and i installed Arch budgie instead ( which uses Gnome network manager) and i don't have this problem anymore so the problem was with either KDE or Manjaro.
My location can now be well hidden both with and without using Eddie.
same problem after rebooting...

Share this post


Link to post

You are installing Arch over a distribution whose package repositories are the same as Arch's. :)
Try another "world", like Debian or CentOS. They have other kernel and software versions, maybe it's a distribution configuration thing
?
Also try it in another network.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Same thing happends with a ubuntu based distro, maybe it is the network as you said because it used to work with all my pc whatever the distro and now it doesn't work on any pc (if I remember correctly they have activated the ipv6 not long ago...). I didn't change distro for that reason because it isn't really a problem, I just wanted to understand more.
 

Share this post


Link to post
24 minutes ago, bluvisnu said:

if I remember correctly they have activated the ipv6 not long ago...


Oooh, I should've seen this earlier. :( It's the solution, I guess.
When you generate your config on the respective client area page, do you tick Advanced mode and then IPv4 & IPv6? IPv4 only is the default!
Because in the post with two of your screenshots I see the AirVPN server's IPv4 on DDG, then Air's v4 on Whatsmyipaddress and a v6 from Orange, it seems. You are connected successfully the whole time but apparently you don't route v6.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

i really hoped it was it but it didn't work, i get the same problem... by the way I have found another way to connect successfully with Qomui a VPN software similar to Eddie.

Share this post


Link to post

So i'm playing around with this VPN software called Qomui checking and unchecking boxes and options and testing my IP on the web and i have found something.
When, within Qomui i activate the firewall my IP is Well hidden but when i deactivate it, it leaks like usual, so there may be something there...something is leaking so i will try without other software but the network manager and a firewall.

Screenshot from 2019-10-22 11-49-42.png

Share this post


Link to post

Why don't you now start posting your logfiles here? I'm ashamed of myself to not have asked that earlier. :)


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

to Giganerd: which logfiles, how to get them ?
to Flx: i am not using OpenDNS because when i do the VPN doesn't work anymore, so i am using the default DNS from AirVPN.

Share this post


Link to post
34 minutes ago, bluvisnu said:

to Flx: i am not using OpenDNS because when i do the VPN doesn't work anymore, so i am using the default DNS from AirVPN.

I can see the DNS servers in the Qomui App aka Corrado's project.
34 minutes ago, bluvisnu said:

i am not using OpenDNS because when i do the VPN doesn't work anymore

WOW. I am speechless.
Change your DNS to Uncensored DNS for example. Let's see how that goes.



 

Share this post


Link to post
On 10/2/2019 at 6:39 PM, giganerd said:

It's neat because you can automatically connect to a VPN once you enable a network profile which saves time and does also work as DNS leak protection when you configure a static DNS server

@bluvisnu
Suggestion:
If you have a router just gathering dust around. Flash it with DD-WRT/Tomato and use that as your static DNS server.

Share this post


Link to post

sorry, i wrote the opposite of what i wanted to write, when i use OpenDNS it doesn't work anymore when i turn the VPN on, so i removed it.
when i go to the OpenDNS test page without the VPN it says that i am using OpenDNS but when i connect the VPN the same page says that i am not usig OpenDNS.

Share this post


Link to post
42 minutes ago, bluvisnu said:

sorry, i wrote the opposite of what i wanted to write, when i use OpenDNS it doesn't work anymore when i turn the VPN on, so i removed it.

What did you remove?
42 minutes ago, bluvisnu said:

when i go to the OpenDNS test page without the VPN it says that i am using OpenDNS but when i connect the VPN the same page says that i am not usig OpenDNS.

The moment you connect to an AirVPN server. AirVPN DNS takes over.
Who configured your Linux OS with OpenDNS as your DNS provider?



 

Share this post


Link to post

i removed the OpenVPN adresses from my network manager, because i never use internet without VPN so i don't need to use OpenVPN
yes that is why i removed OpenVPN.
i did configured my Os and trust me i don't know much but i did my best !

Share this post


Link to post
1 hour ago, bluvisnu said:

i removed the OpenVPN adresses from my network manager, because i never use internet without VPN so i don't need to use OpenVPN
yes that is why i removed OpenVPN.
i did configured my Os and trust me i don't know much but i did my best !

You can't be serious. I hope your joking!

Share this post


Link to post

lol we can say i am joking,  i don't know why i am writing VPN instead of DNS today but it makes no sense at all.
so i removed OPENDNS because i never connect without VPN and with the VPN on, OPENDNS doesn't work, because as you know AIRVPN DNS takes over, now it makes sense, sorry.
so it is OPENDNS that i removed not OPENVPN lol

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...