Jump to content
Not connected, Your IP: 3.214.184.124

Recommended Posts

Hello,

I am having technical problems with my current IPv6 setup. Specifically, when I try to access websites that report my IP (such as whatismyipaddress.com), they report only detecting an IPv4 address (specifically 185.9.19.107, which is an AirVPN server I believe) from my browser's request when I'm connected with my airvpn configuration, no IPv6 address visible to them. This is strange, specifically because my airvpn configuration is setup to use both IPv6 as the outbound address as well as the inbound one.

So my question is, why is this happening? I'm assuming this is a configuration issue on my side.

Further context below:
1) All the devices in my house are connected in a LAN that has a single gateway to the public internet: a wireless router with OpenWrt 18.06.2
2) The OpenWrt router is the one maintaining an open connection to the AirVPN server. Basically, the devices in my LAN should have all their network traffic routed through AirVPN servers before reaching their intended destinations.
3) OpenVPN has the airvpn.conf file generated using this website's config generator after selecting the "Linux" category (maybe "Router" would have been a better choice for the configuration file?). The conf file is attached to this thread (the same conf file also contains the certificates, openvpn static key and my private key but I omitted them since I don't believe they are relevant here). airvpn.conf 
4) Here are other configurations from my OpenWRT setup: networkfirewall
5) I should probably point out that my internet didn't work at all when using the VPN with the initial airvpn config file (not even pinging the remote server by its Ipv6 address). After digging a lot through the internet I eventually came up with a script called remote_host_route6.sh which I reference in my airvpn config file and which gets executed every time openvpn tries to start the said configuration (it's referenced in the "route-up" directive in the airvpn.conf file attached). It was only after I added this script to the configuration that I began having internet at all when the VPN connection was up, albeit with the problem I'm describing in this post. The contents of this remote_host_route6 script are the following: remote_host_route6.sh
6) OpenVPN version is OpenVPN 2.4.5
7) Finally, although I am unsure how relevant this is, my "gateway" router that all my LAN devices connect to and which connects to the VPN server is itself behind an OTN device from my ISP which converts all traffic to fiber optic signal. This device is set into bridge mode and should be transparent to the network though, I believe (hence why my OpenVPN router handles the pppoe configuration).

Sorry for the long post :(

Share this post


Link to post

I sense a slight XY problem. You can't reach the internet after connection (X), so you write a script and have only half the solution (Y). Then you come here with the question of how to make problem Y whole while the actual problem is X.

Soo, let's go back one step and provide everything you can for the situation where you don't use that script and let's troubleshoot that first. :) You already provided many things, but the logs are missing.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
Posted ... (edited)

OK. Yes, I think that would be the best approach, especially since I'm not a fan of adhoc scripts to begin with.

I'm not entirely sure though where to find the opnwrt logs. Maybe this system log is helpful?
log.txt

Edit: oh, forgot to mention. This log was after I commented out the "route-up" directive from my openvpn.conf file and did a clean reboot afterwards). So this is how the log would look like with that remote_host_route6 script disabled

Edited ... by I am nobody
Forgot to mention me disabling that script

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...