Jump to content
Not connected, Your IP: 3.214.184.196
Staff

Eddie Desktop 2.18beta released

Recommended Posts

With 2.18.4 I have again problem with elevated privileges.
It works if I start it from terminal, but doesn't if script is running in the background. In version 2.18.3 it worked fine.

Just a simple sample, this doesn't work:

[Desktop Entry]

Name=Eddie - OpenVPN GUI

Comment=OpenVPN GUI with additional user-friendly features

Exec=sudo /usr/bin/eddie-ui

Icon=/usr/share/pixmaps/eddie-ui.png

Terminal=false

Type=Application

Categories=GNOME;Network


 
and if I switch Terminal to true it works.

Share this post


Link to post

I am using Eddie 2.18.4beta on Arch Linux.
Someone seems to have forgotten to either change '/usr/bin/eddie-ui' or rename '/usr/lib/eddie-ui/Eddie-UI.exe'.
As it stands, '/usr/bin/eddie-ui' has mono call '/usr/lib/eddie-ui/eddie-ui.exe', which does not exist.
I fixed this minor problem in seconds, no biggie. Nevertheless, I thought you should know about this.
 

Share this post


Link to post
9 hours ago, radolkin said:

I am using Eddie 2.18.4beta on Arch Linux.
Someone seems to have forgotten to either change '/usr/bin/eddie-ui' or rename '/usr/lib/eddie-ui/Eddie-UI.exe'.
As it stands, '/usr/bin/eddie-ui' has mono call '/usr/lib/eddie-ui/eddie-ui.exe', which does not exist.
I fixed this minor problem in seconds, no biggie. Nevertheless, I thought you should know about this.
 


Many many thanks for this feedback.

Share this post


Link to post
16 hours ago, amilino said:

With 2.18.4 I have again problem with elevated privileges.
It works if I start it from terminal, but doesn't if script is running in the background. In version 2.18.3 it worked fine.

Just a simple sample, this doesn't work:


[Desktop Entry]

Name=Eddie - OpenVPN GUI

Comment=OpenVPN GUI with additional user-friendly features

Exec=sudo /usr/bin/eddie-ui

Icon=/usr/share/pixmaps/eddie-ui.png

Terminal=false

Type=Application

Categories=GNOME;Network

 


 
and if I switch Terminal to true it works.

Sorry i'm missing your situation.
The default .desktop have
Exec=/usr/bin/eddie-ui
Exec=/usr/bin/eddie-ui
why you added "sudo" ? It's normally that don't work with sudo, root probably don't have the display.
What package you use here? Raspbian edition? .deb edition?

Share this post


Link to post
For betatester /devs
The following commands enable Eddie as systemd service (also at boot level).
If executed, the root password when Eddie starts is not asked anymore.
Please experiment and report if it works in your OS, thx.
It doesn't work in systems without systemd (Devuan, for example). If anyone wants to implement an alternative (old init.d script?), I give a gift 😀
Works only on installed Eddie (.deb, .rpm, Arch), doesn't work yet on portable (.tar.gz or AppImage).

Install:
sudo curl -o /usr/lib/systemd/system/eddie-elevated.service "http://eddie.website/temp/eddie-elevated.service"
sudo systemctl enable eddie-elevated.service
sudo systemctl start eddie-elevated.service
Uninstall:
sudo systemctl stop eddie-elevated.service
sudo systemctl disable eddie-elevated.service
sudo rm /usr/lib/systemd/system/eddie-elevated.service

Share this post


Link to post
1 hour ago, Clodo said:

The following commands enable Eddie as systemd service (also at boot level).
If executed, the root password when Eddie start it's not asked anymore.
Please experiment and report if works in your OS, thx.
Don't work in system without systemd (Devuan, for example). If anyone want to implement an alternative (old init.d script?), i give a gift 😀
Work only on installed Eddie (.deb, .rpm, Arch), don't work yet on portable (.tar.gz or AppImage).


This works as advertised on Ubuntu 19.04.
 
1 hour ago, Clodo said:

Install:


sudo curl -o /usr/lib/systemd/system/eddie-elevated.service "http://eddie.website/temp/eddie-elevated.service"
sudo systemctl enable eddie-elevated.service
sudo systemctl start eddie-elevated.service

 


However, the third instruction line doesn't accept "sudo."  If "sudo" is omitted, the command works and asks for the sudo password in a window.  After that, it all works.

Share this post


Link to post

2.18.4 seems to be working fine for me, except for one small issue: the "start with system" option doesnt work at all - at least on the latest Windows 10.

Share this post


Link to post
22 hours ago, Clodo said:

Sorry i'm missing your situation.
The default .desktop have
Exec=/usr/bin/eddie-ui

Exec=/usr/bin/eddie-ui
why you added "sudo" ? It's normally that don't work with sudo, root probably don't have the display.
What package you use here? Raspbian edition? .deb edition?
I tried so many combinations and always stuck in a elevated permissions error or crash.

Now I tried portable cli version without sudo, and get this error
Unexpected crash of elevated helper:Elevated communication closed

Share this post


Link to post

2.18.4 on windows 10 doesn't let me connect to any server.  It just immediately shows "restarting in 3 seconds" as soon as I hit connect, and tries to rotate through a bunch of servers.

Share this post


Link to post

When I restart Eddie I often get this popup...
If I say "No" ... Eddie closes.
If I say yes, My user ID is again blank (I'm not sure what else reverts as I am using the portable Win x86 app without any preference changes.

What causes this? What OS keyring? Because I pasted in my password?

20191006_mstsc_6WVIHpTNUo.png

EDIT1: I found the setting which triggers this and changed it to None, I'd like to understand "Windows Credentials" vs. Password vs. None. I couldn't find details on this. All else is good here.

Share this post


Link to post

I installed v2.18.4 on my Windows 10 PC as from the reports here it was OK with Win10. I did a clean install from v2.17.2 and it works ok but my download speed using qBittorrent has decreased from an average of 7-10MiB/s to max 3.0MiB/s?. I haven't changed anything in my settings at all. Also the servers list doesn't seem to work anymore. The main list is now listed alphabetically by server name and all stars are white. The only stars showing yellow are the 6-7 dutch servers I have in my Whitelist and the latency on them has risen from a previous 26-28secs to 30-38secs.

Share this post


Link to post
On 10/5/2019 at 3:08 PM, hipnihilist said:

2.18.4 on windows 10 doesn't let me connect to any server.  It just immediately shows "restarting in 3 seconds" as soon as I hit connect, and tries to rotate through a bunch of servers.

You can post some lines from Log tab? Thx

Share this post


Link to post
4 hours ago, Clodo said:
On 10/5/2019 at 4:08 PM, hipnihilist said:

2.18.4 on windows 10 doesn't let me connect to any server.  It just immediately shows "restarting in 3 seconds" as soon as I hit connect, and tries to rotate through a bunch of servers.

You can post some lines from Log tab? Thx
Had this issue randomly once that was solved with a pc restart. The error message I got was  OpenVPN > Exiting due to fatal error and it kept going through servers and failing. Restarting eddie didn't change the outcome but a restart solved it. 
Remember I have been using beta 3 for a while now without issue until today. Sadly i didn't collect further logs before  restarting but if I can help in any other way let me know. 

Share this post


Link to post
Posted ... (edited)
On 10/7/2019 at 12:45 PM, Clodo said:
On 10/5/2019 at 3:08 PM, hipnihilist said:

2.18.4 on windows 10 doesn't let me connect to any server.  It just immediately shows "restarting in 3 seconds" as soon as I hit connect, and tries to rotate through a bunch of servers.

You can post some lines from Log tab? Thx

I am having the same problems. Can't get passed IPv6 when network lock is enabled. Logfile included. However, when enabling network lock on reboot and rebooting Windows it works fine.

Eddie_20191007_172653.txt

Edited ... by Rruud
Extra information added (reboot)

Share this post


Link to post
Posted ... (edited)

In Windows 10 (Pro), the default option "Profile Data Protection: Windows Credentials (no password asked) does not work after a reboot. Maybe change the default value for Windows. Using the latest beta.

453574546_AirVPNklein.jpg.c26bd8cab27937c5f027271fd4569026.jpg
 

Edited ... by Rruud

Share this post


Link to post
Posted ... (edited)

Running MACOS Mojave 10.14.6, using custom menubar icons breaks beta 2.18.4. I’ve modified these icons so the colors are much more visible (in the originals the colors are virtually impossible to see). This worked fine on Eddie 2.17.2, also running Mojave, but the new beta does something to permissions so that if the icons are changed from the original it throws the ‘elevated permissions version mismatch’ error and won’t start. I’ve tried this both with the elevated permissions daemon installed and uninstalled and startup is blocked either way. It may have something to do with code signing but I’m not sure. Any way around this? Visible menubar icons are important to me and I’d rather not have to revert to the 2.17.2 version of Eddie to get them back.

Edited ... by dedo299
To clarify that I'm talking about menubar colors

Share this post


Link to post

I'm running 2.18.4 beta on Win7.  The service to elevate privileges doesn't install, so I get a UAC prompt every time I log in (when Eddie loads).  I'm also getting a UAC prompt when I tick the "Don't ask elevation every run" checkbox, but as far as I can see no service is being installed or run.  Running "Eddie-CLI-Elevated.exe service-install" from an elevated command prompt returns no message, but also does not install a service.

Also, if I shut down or log out of Windows without manually closing Eddie, I receive the following error.  Manually closing Eddie works fine.

Other than these side issues (and once I'd changed the profile data protection to Plain), everything is fine - cheers

eddie1.gif

Share this post


Link to post

After decompressing the Linux Portable of Eddie I've found two .exe of eddie-ui, one in the main folder and another inside a 'bundle' folder

which to use?  I'm using the one inside the main folder right now

Share this post


Link to post
Posted ... (edited)

Unable to connect using Win10, attempting to use SSL / 443.

"UTF-8 byte order mark detected"


. 2019.10.09 14:12:31 - Eddie version: 2.18.4beta / windows_x64, System: Windows, Name: Windows 10 Pro, Version: Microsoft Windows NT 10.0.18362.0, Mono/.Net: v4.0.30319
. 2019.10.09 14:12:31 - Command line arguments (1): path="home"
. 2019.10.09 14:12:32 - Profile path: C:\Users\<user>\AppData\Local\Eddie\default.profile
. 2019.10.09 14:12:32 - Reading options from C:\Users\<user>\AppData\Local\Eddie\default.profile
. 2019.10.09 14:12:35 - OpenVPN Driver - TAP-Windows Adapter V9, version 9.23.3
. 2019.10.09 14:12:35 - OpenVPN - Version: 2.4.7 - OpenSSL 1.1.0j  20 Nov 2018, LZO 2.10 (C:\Program Files\AirVPN\openvpn.exe)
. 2019.10.09 14:12:35 - SSH - Version: plink 0.67 (C:\Program Files\AirVPN\plink.exe)
. 2019.10.09 14:12:35 - SSL - Version: stunnel 5.40 (C:\Program Files\AirVPN\stunnel.exe)
. 2019.10.09 14:12:35 - curl - Version: 7.54.1 (C:\Program Files\AirVPN\curl.exe)
. 2019.10.09 14:12:35 - Certification Authorities: C:\Program Files\AirVPN\res\cacert.pem
I 2019.10.09 14:12:37 - Ready
. 2019.10.09 14:12:37 - Collect information about AirVPN completed
I 2019.10.09 14:12:50 - Session starting.
I 2019.10.09 14:12:51 - Checking authorization ...
! 2019.10.09 14:12:52 - Connecting to Miram (Netherlands, Alblasserdam)
. 2019.10.09 14:12:52 - Routes, added a new route, 213.152.162.92 for gateway <gateway>
. 2019.10.09 14:12:52 - SSL > [ ] Running on Windows 6.2
. 2019.10.09 14:12:52 - SSL > [ ] No limit detected for the number of clients
. 2019.10.09 14:12:52 - SSL > [.] stunnel 5.40 on x86-pc-mingw32-gnu platform
. 2019.10.09 14:12:52 - SSL > [.] Compiled/running with OpenSSL 1.0.2k  26 Jan 2017
. 2019.10.09 14:12:52 - SSL > [.] Threading:WIN32 Sockets:SELECT,IPv6 TLS:ENGINE,OCSP,PSK,SNI
. 2019.10.09 14:12:52 - SSL > [ ] errno: (*_errno())
. 2019.10.09 14:12:52 - SSL > [ ] Running on Windows 6.2
. 2019.10.09 14:12:52 - SSL > [.] Reading configuration from file C:\Users\<user>\AppData\Local\Eddie\689f4e7f0575590331b4f6f92b582b4248b7f830eb3f9839740b936b8e35da33.tmp.ssl
. 2019.10.09 14:12:52 - SSL > [.] UTF-8 byte order mark detected
. 2019.10.09 14:12:52 - SSL > [!] C:\Users\<user>\AppData\Local\Eddie\689f4e7f0575590331b4f6f92b582b4248b7f830eb3f9839740b936b8e35da33.tmp.ssl:3: "pid = C:\Users\<user>\AppData\Local\Eddie\stunnel.pid": Specified option name is not valid here
! 2019.10.09 14:12:52 - Disconnecting
. 2019.10.09 14:12:52 - Routes, removed a route previously added, 213.152.162.92 for gateway <gateway>
. 2019.10.09 14:12:52 - Connection terminated.

Edited ... by Pigpen

Share this post


Link to post
On 10/8/2019 at 1:34 AM, dedo299 said:

Running MACOS Mojave 10.14.6, using custom menubar icons breaks beta 2.18.4. I’ve modified these icons so the colors are much more visible (in the originals the colors are virtually impossible to see). This worked fine on Eddie 2.17.2, also running Mojave, but the new beta does something to permissions so that if the icons are changed from the original it throws the ‘elevated permissions version mismatch’ error and won’t start. I’ve tried this both with the elevated permissions daemon installed and uninstalled and startup is blocked either way. It may have something to do with code signing but I’m not sure. Any way around this? Visible menubar icons are important to me and I’d rather not have to revert to the 2.17.2 version of Eddie to get them back.


I think "Custom icons" and "elevated permissions version mismatch" are totally different problems.
Focus first on "version mismatch": Please confirm that you still have the error "elevated permissions version mismatch" even after a REBOOT. If so, what version you install? .dmg?  Do you launch eddie from /Applications? Thanks.

Share this post


Link to post
18 hours ago, harold.lewis said:

After decompressing the Linux Portable of Eddie I've found two .exe of eddie-ui, one in the main folder and another inside a 'bundle' folder

which to use?  I'm using the one inside the main folder right now


The .tar.gz contains a script "eddie-ui" (the right launcher) and a directory "bundle" with other files.  So the one in the main folder is the right executable.

Share this post


Link to post
2 hours ago, Pigpen said:

Unable to connect using Win10, attempting to use SSL / 443.
 


Yes, confirmed, will be fixed in the next release, thx.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...