Jump to content
Not connected, Your IP: 3.93.75.30
lasiyo

New user - setting up qBittorrent with AirVPN, is this good enough?

Recommended Posts

Posted ... (edited)

Hey guys, been looking through the guides and found really useful information. I'm not super technically savvy when it comes to VPN's, but I heard great things about AirVPN so I figured I'd take the dive and learn. 

I'm mostly going to use AirVPN to download movies and shows. I'm using qBittorrent and looked at how to set up this correctly, one of the guides mentioned to look into Network Locking but that it might not be necessary. So far I have connected to a server on AirVPN and gone my qBittorrent options in

Preferences > Advanced and set up the following:
    Network Interface: utun0
    Optional IP address to bind to: [ip address from dropdown menu]

EDIT: I found some more settings that I applied, and I'm still not able to download anything. Here are the extra settings:
 

Quote

 

qBittorrent > tools > options > connections

listening port - plug in the same port you forwarded on Air

uncheck UPnP

uncheck use different port on each start

 

qBittorrent > tools > options > connections > connection limits

global max = 100

connections per torrent = 50

(settings above suggested by Air staff)

 

qBittorrent > tools > options > bittorrent > privacy

enable DHT

enable PeX

 

qBittorrent > tools > options > advanced

network interface = tun0 (on Linux anyway) - you may have to be connected to the VPN before the tun0 option is available

 



Unfortunately, I'm not able to download anything. The bottom status bar in qBittorrent has no direct connections and no active nodes. 

I have also gone to https://airvpn.org/ports/ and followed the guide here:

and added a local port to generate a port and added it to my qBittorrent preferences and port to listen to. Any advice would be appreciated! 


**EDIT:** I printed the execution logs from qBittorrent and got the following error:
     > 9/10/19 1:41 PM - qBittorrent didn't find an IPv4 local address to listen on

Edited ... by lasiyo
Add more information

Share this post


Link to post
2 hours ago, lasiyo said:

Optional IP address to bind to: [ip address from dropdown menu]


Leave blank. This is superfluous if it binds to tun0, anyway.
 
2 hours ago, lasiyo said:

and added a local port to generate a port and added it to my qBittorrent preferences and port to listen to. Any advice would be appreciated! 


Do not set a different local port to forward connections to if using BitTorrent. The port you configured in the client is being sent to DHT nodes and to trackers. If you have a different remote port set up, no peers will ever reach your client and you get 0 nodes. :)

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Thanks for the reply! It seems like the issue was in the network interface? Maybe this will help someone else if they run into a similar issue.

I printed out the exectuions logs from qBittorrent and this was the error:
   > qBittorrent didn't find an IPv4 local address to listen on

After googling, I ran the command: ifconfig and looked up which network interface had the ip of 10.xx.x.xxx, turns out it was utun2. After updating that in my qBittorrent settings, I was able to download and connect to different nodes. 

I tested if this worked by disconnecting AirVPN and seeing if the torrent stopped downloading, and the dl speed slowed down until it reached 0. After connecting again, the dl speed went back up to normal.

Do you guys this is the right configuration?

 

Share this post


Link to post
21 hours ago, lasiyo said:

After googling, I ran the command: ifconfig and looked up which network interface had the ip of 10.xx.x.xxx, turns out it was utun2. After updating that in my qBittorrent settings, I was able to download and connect to different nodes. 


As I wrote, if you connect to another server or with a different protocol, that address will change again, prompting you to do that again. Leave this blank and only set the tun interface to bind to. This will automagically use the IP assigned to it.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...