Jump to content
Not connected, Your IP: 3.235.101.141
dadigi

Does Eddie for Android support other providers?

Recommended Posts

I have tried to use an ovpn-config from my pfsense with the Eddie-app.
I have tried several client export formats on the pfsense, but Eddie does not accept the opvn-files.
So I assume mulit-provider-suppurt is not available in the android app right now?

Share this post


Link to post

Hello!

Eddie Android edition supports any OpenVPN server provider as it accepts totally generic OpenVPN profiles. Note, however, that not all OpenVPN 2 directives are implemented in OpenVPN 3 library: unknown directives will be ignored and not cause an error though.

Also please note that pfSense is a FreeBSD distribution, Android has nothing to do with it.

Kind regards

Share this post


Link to post

Hello Stuff!

Thank you for your quick answer, but let me rephrase my question and give some more detail:

I use pfsense 2.4.4-RELEASE-p3, based on FreeBSD 11.2-RELEASE-p10 (which is not Android, that's right) with OpenVPN 2.4.6 as an OpenVPN-Server.
I try to use following ovpn-file:

dev tun
persist-tun
persist-key
cipher AES-256-CBC
ncp-ciphers AES-256-GCM:AES-128-GCM
auth SHA512
tls-client
client
resolv-retry infinite
remote ...myserver... 1194 udp
verify-x509-name "...myserver..." name
remote-cert-tls server
comp-lzo adaptive

<ca>
-----BEGIN CERTIFICATE-----
...snip...
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
...snip...
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
...snip...
-----END PRIVATE KEY-----
</key>
key-direction 1
<tls-auth>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
...snip...
-----END OpenVPN Static key V1-----
</tls-auth>
Eddie-Android-app add does not except that profile and shows only "Select a valid OpenVPN-profile".
E.g. the "OpenVPN Connect"-Android-app works fine with this profile. 
So if you say other profiles should work, why does the upper one not (the strings between the three dots are replacements, not the actual config-entries)?


 

Share this post


Link to post

Hello!

Understood. Maybe you run OpenVPN for Android on OpenVPN 2.5, while Eddie is based on OpenVPN 3 library: can you please check?

Kind regards
 

Share this post


Link to post

Log says:
OpenVPN core 3.git::728733ae:Release android arm64 64-bit PT_PROXY built on Aug 14 2019

Share this post


Link to post

Thank you, we will investigate! Maybe we will need your complete profile to make tests (you might create a specific profile for us, with a specific client key/certificate, that you will later delete), can you open a ticket at your convenience?

Kind regards
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...