Jump to content
Not connected, Your IP: 35.175.191.150
Anonymousvpnuser1

Urgent help needed. Recently can't connect.

Recommended Posts

On Mac (and probably Linux) one can workaround the expired cert by adding the file ~/.curlrc with a single line: --insecure

Works for me, and seems a little less kludgy than setting the system clock backwards.  It's not a good idea to leave that in place though for long.  Hopefully they fix the issue correctly soon.

-k
 

Share this post


Link to post
1 hour ago, kwolf said:

On Mac (and probably Linux) one can workaround the expired cert by adding the file ~/.curlrc with a single line: --insecure

Works for me, and seems a little less kludgy than setting the system clock backwards.  It's not a good idea to leave that in place though for long.  Hopefully they fix the issue correctly soon.

-k
 


Good call, kwolf.  and for Windows users, I found a way to do this as well... 

So for Windows, the default config file is named:
_curlrc
and it can be in a number of places (see https://ec.haxx.se/cmdline-configfile.html)

But a quick and easy way to correct this without needing to do anything with admin rights is to open a command prompt and execute this command:
echo --insecure> %APPDATA%\_curlrc
Please note that you cannot have (based on my testing) a space before the '>' symbol.  just copy and paste that into a command prompt (windows key, release windows key, type 'cmd', hit enter) and it will create a default config file for curl.  If you want to see exactly where it created the file, you can use this command:
dir %APPDATA%\_curlrc

If/When someone tries this, please let me know how it works.
 -p
ps - And if/when you want to delete the file (as kwolf points out, it might not be the best idea to leave it there) you can open a command prompt and type:
del %APPDATA%\_curlrc

Share this post


Link to post

Setting the date back a week on my Mac worked for me. Everything is fine now, until AirVPN corrects it on their end.

Thanks ps73!
 

Share this post


Link to post

Having the same problem here MacOS.. I put the clock back a week to the 11th August.  Can connect now with no problems.  
Hopefully this is a simple work around until it is fixed.

I have to say though I have been with AirVPN for years now and never a hiccup, its unfortunate but these things do happen,
we are lucky this is a very rare thing and hopefully it will be fixed quickly.  I still have total faith in AirVPN and their services.

Share this post


Link to post

From the other thread Slackjawed Cletus posted:
 

Quote

Under the "DNS" settings tab, deselect "Check AirVPN DNS", then go to the "Advanced" tab and deselect "Check if the Tunnel Works".  Worked for me on v2.17.2.  Just a very temporary fix.


This worked for me, so I put my clock back to normal.  

Share this post


Link to post
Just now, pwolverine said:

From the other thread Slackjawed Cletus posted:
 


This worked for me, so I put my clock back to normal.  
Wouldn't that mean that our local DNS would be open to be seen? I am not all that educated on this subject.

I'm not really enjoying the setting the clock back fix either. Some things are not working with my clock set back. Tradingview isnt working, google isnt working etc.

Share this post


Link to post

Add me to the list of those unable to connect.  Every time I try to connect to a server I get "flushing DNS," then "Connecting to Server," then "Disconnecting."  Then it tries another server with same result.  Rinse and repeat over and over. 🙁

BTW, using Windows 7 PC, 64 bit

Share this post


Link to post
10 minutes ago, mecdeva said:

Add me to the list of those unable to connect.  Every time I try to connect to a server I get "flushing DNS," then "Connecting to Server," then "Disconnecting."  Then it tries another server with same result.  Rinse and repeat over and over. 🙁


I''ve got same problem

Share this post


Link to post
29 minutes ago, Anonymousvpnuser1 said:
Wouldn't that mean that our local DNS would be open to be seen? I am not all that educated on this subject.

I'm not really enjoying the setting the clock back fix either. Some things are not working with my clock set back. Tradingview isnt working, google isnt working etc.
I don't think that is what it means.  It sounds to me like it is just trying to check to see if the tunnel is working before it starts using it.  But the server that they are connecting to for testing has a bad (expired) cert.  That means that the check is failing, even though the tunnel is up.  This is probably the best work around so far as it is done completely in the application settings.  

Share this post


Link to post
56 minutes ago, pwolverine said:

From the other thread Slackjawed Cletus posted:
 


This worked for me, so I put my clock back to normal.  
I didn't see Slackjawed Cletus's post... but thanks for copying his solution here.  It worked for me without changing any clock settings or anything.  And it will be easy to reverse once AIRVPN fixes the issue. 🙂

Share this post


Link to post

Same problem in my Linux Mint. However I can bypass using network manager - openvpn directly.

Regards.

Share this post


Link to post
Quote

From the other thread Slackjawed Cletus posted:
 

Quote

Under the "DNS" settings tab, deselect "Check AirVPN DNS", then go to the "Advanced" tab and deselect "Check if the Tunnel Works".  Worked for me on v2.17.2.  Just a very temporary fix.

This has worked for me as well with the most current version.

Share this post


Link to post

Here are 2 temporary solutions which work for me:

1. Set your system clock back. The cert expired less than 24 hours ago, so set it back at least a couple of days before that (hopefully Support can get this fixed in the meantime).

2. Generate a config file for Curl.exe and use the --insecure option to bypass the SSL warning. If you are running Windows, the Curl config file is named _curlrc and it is placed in your HOME directory or your <USER PROFILE>\Application Data directory. You can also put it in the same location with Curl.exe. This will be your Eddie program directory. Admin rights will be needed. I did this.

Use your text editor to save a text file with "insecure" (without the "") on the first line and save it with the name _curlrc and put it in any one of the above mentioned locations.

That's all it takes. YMMV.

Update: It's been reported that unchecking "Check if the tunnel works" under Eddie Preferences > Advanced does the trick as well.



 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...