Jump to content
Not connected, Your IP: 18.215.161.19
dbear55

Router Port Forwarding Problem

Recommended Posts

I think I have setup port forwarding correctly , following the articles for DDWRT & Merlin, but am not getting the expected result.

 

I am running a media server accessible via http on port xxxx and  if I connect locally, 127.0.0.1:xxxx it is fine

 

Without a VPN and with port forwarding setup on the router (via WAN/Port Forwarding) I can connect via WAN-IP:xxxx or ddns.asuscomm.com:xxxx

 

AirVPN is running on an Asus RT-AC87U, with a tunnel (tun11) pointing at just one PC (10.0.0.116) which is hosting the server. All other devices is running on the WAN interface. I have removed the Port Forward from WAN/Port forwarding and used the command line setup mentioned above. The System Log shows that the port is being forwarded and I can also see this from canyouseeme.org.

 

However if I try to connect on the port either via VPN-IP:xxxx or via ddns.airdns.org:xxxx I cannot connect to the server. If relevant, the PC is running Windows 10 (64 bit).

 

What am can I try next?

Share this post


Link to post

iptables -I FORWARD -i tun11 -p udp -d 10.0.0.116 --dport 18080 -j ACCEPT
iptables -I FORWARD -i tun11 -p tcp -d 10.0.0.116 --dport 18080 -j ACCEPT
iptables -t nat -I PREROUTING -i tun11 -p tcp --dport 18080 -j DNAT --to-destination 10.0.0.116
iptables -t nat -I PREROUTING -i tun11 -p udp --dport 18080 -j DNAT --to-destination 10.0.0.116

Share this post


Link to post

I have a similar problem - I'm using an ubuntu server as a router with the iptables configured as above. I'm trying to access my router via ssh e.g.

 

~$ ssh -p 47144 myaccount@ddnsname.airdns.org

 

but I keep getting 'resource temporarily unavailable' when testing from a machine on a separate LAN without a VPN connection. I connect to the airvpn server through an ssh tunnel (stunnel) - not sure if that's relevant. I get a yellow light on the port's TCP test.

Share this post


Link to post

I have a similar problem - I'm using an ubuntu server as a router with the iptables configured as above. I'm trying to access my router via ssh e.g.

 

Mea culpa. In addition to the PREROUTING and FORWARD, I forgot to add the INPUT:

-A INPUT -i tun0 -p tcp --dport 22 -j ACCEPT

Now all working fine.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...