Jump to content
Not connected, Your IP: 100.24.113.182
Sign in to follow this  

Recommended Posts

Hello,

 

we can't reproduce the issue for the web sites in Italy you report. The route check seems fine as well. Please make sure that your system queries VPN DNS (it happens by default with Eddie anyway) because some of the web sites you mention are under geo-routing. If the problem persists, can you please list the VPN server(s) you experience this problem on at your convenience?

 

About amazon.com, on the contrary, we confirm some problems which seem related to our routing to make Amazon Prime Video accessible. We are investigating.

 

Kind regards

Share this post


Link to post

OK, I found out where the issue is.

I used Eddie on my Android device and I could reach all of those websites from the same servers and while connected to the same access point as the Windows system. However I noticed that the Android device only uses IPv4, while Eddie for Windows uses IPv4 and IPv6 by default. 

So I opened Eddie for Windows and went to Settings > Networking and set Layer IPv6 to "Block". This did the trick for me: all the websites now load successfully, even Amazon Storywriter. I +had+ left Internet Protocol used for connection to "IPv4, IPv6" because I found from testing that the previous setting is enough to prevent leaks, but I may switch +switched+ to "IPV4 only" +anyway+ just to be 100% sure. +It still works fine.+

I ignore whether the DNS error happens because these websites do not support IPv6 or because I ran IPv6 on a non-IPv6 network, but I hope that now you will be able to look into it. Thanks for your help.
 

Share this post


Link to post

Hello!

We can reproduce the issue on Windows. On some Windows machines, but not all of them, when IPv6 over IPv4 is active, micro-routing is no more possible. Interestingly, any other system (Mac, GNU/Linux, Android, iOS), does NOT suffer this problem, even when IPv6 over IPv4 is active of course.

 

Considering the above, we think that micro-routing is just fine and we suspect that something goes wrong when Windows prefers DNS6 over DNS4. We are moving this thread to the "Troubleshooting" forum because this issue has been already reported in the past by another user, but at that time we failed to reproduce it. Eddie for Windows developers will be informed too.

 

Thank you very much for your thorough report.

 

Kind regards

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...