Jump to content
Not connected, Your IP: 3.236.145.153
gtestprep

ANSWERED Unable to connect to internet when Eddie is not working

Recommended Posts

I'm encountering a strange issue for the past few days where I'm unable to connect to the internet when eddie isn't running.

 

Info about my system/software:

Mac OSX 10.12.6

Eddie v 2.15.2

 

Eddie is setup to run with the network lock enabled by default.

 

I have, in the past, faced these issues where the machine would refuse to connect to the internet when eddie wasn't running, and restarting the machine would restore connectivity [sic] 

 

Restarting the machine doesn't seem to be doing the trick for me anymore, and I'm stuck with the need to use the machine without the airVPN connectivity (because I need to use my employer's VPN instead)

 

Attaching logs, and screenshots of my Eddie settings. Please let me know if there's more info I can provide.

Eddie_20180809_114535.txt

Share this post


Link to post

Sounds like something isn't getting reversed upon disconnect with network lock. Maybe your eddie log may have useful\detailed information about what might be failing.
Have you tried perhaps setting network lock from automatic to disabled, connecting to air, and then disconnecting, and closing airvpn app; or supposedly when networklock is enabled there is a button to deactive it (https://airvpn.org/topic/14829-can-only-connect-to-the-internet-browser-through-airvpn/page-3?do=findComment&comment=67802), and exit.  Might clear things up, you can always re-enable it later.

 

I'm not familiar with how eddie operates on osx much, but just throwing it out there till someone more informed on that platform perhaps responds.
 
 

Share this post


Link to post

Same problem here, also since yesterday. VPN works fine, but after disconnect & deactivate network lock the outside world remains blocked, also after restart, reinstall Eddie and 'safe boot'. Local addresses (192.168.etc) can be reached. I have the impression that activating network lock takes more time than before and deactivating less (< 1 sec), but I may be wrong.

Share this post


Link to post

Did some more testing. It's DNS-related. After deactivating the network lock ping or telnet to a domain-name does not work, the same to an ip-address works. But still looking for a solution...

Share this post


Link to post

And found the solution, at least for me. During VPN your Mac uses AirVPNs DNS servers to resolve internet names to IP-adresses. When disconnecting you should get your original server-settings back. If that for some reason doesn't happen internet names like www.apple.com are not recognised and it looks like the network lock is still active, but the cause is different.

So, with Eddie not running, go to SystemPreferences > Network > Wifi (or Ethernet) > Advanced > DNS and put 8.8.8.8 as first item in the list. 8.8.8.8 is Googles DNS system, you can also use your providers DNS.

Maybe renewing the DHCP-lease fixes the problem too.

No idea if the problem recurs, will post here if I know more.

Share this post


Link to post

A while ago I had the same problem. Support gave me an answer that solved it. It might work for you:


 


Hello and thank you for your choice!


 

Can you please check the DNS settings of your system while Eddie is not running? If the VPN DNS has remained set, your system will not able to resolve names when not connected to the VPN (that should never happen, but maybe Eddie has some issue or crash?).

 

How to change DNS in Mac:


 

You can set any public DNS you prefer. We recommend OpenNIC for their commitment to privacy and neutrality, please see here:


 

We look forward to hearing from you.

 

Kind regards

AirVPN Support Team

Share this post


Link to post

FYI I had this same issue, and I think I know why if it brings anyone else perspective. 

I recently switched my server Mac from an Intel to an M1, and installed the M1 native version of Eddie with my initial setup.

I made sure the M1 Eddie app was in the dock and launchctl items were M1 but neglected to delete the Intel x86 versions. 

Months later my spouse manually ran the Intel app so that both apps were running simultaneously. The Intel app hung and I had to force quit it.

It wasn't until a few weeks later that I realized DNS wasn't working with Eddie inactive. I don't use Network lock, but the VPN is on 90% of the time -- I generally only turn it off when a website blocks AirVPN endpoints (which seems to be happening more frequently, though that's another conversation.)  

Thanks to this thread I realized that x86 Eddie had locked in the AirVPN DNS IP values in the Network settings –– even after toggling Network Lock and clearing DNS settings in the M1 ARM Eddie. I had to do this for both Ethernet and Wifi sockets individually (I use both.)

This may be a permission issue with the swap — that level of debugging is beyond my time scope today — but manually clearing the DNS in the Network Prefs panel solved the issue.

Public service message: remember to trash your x86 Eddie app when you change to M1. 



 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...