Jump to content
Not connected, Your IP: 18.206.194.83

Recommended Posts

I'm using KDE PCLinuxOS and running Eddit 2.15.2 (eddie-ui_2.15.2_linux_x64_portable)

Eddie takes about 7 to 10 minutes to Flush DNS, going into VPN and comming ot of VPN.

Any reason why so it takes so very long?
 

Thank you to all who take the time to review this question.

Share this post


Link to post

Hey, NickAtNight;

 

I'm also running PCLinuxOS kde plasma 5 (fully updated) using eddie 2.16.1 portable (experimental). This issue has existed in varying degrees of severity, since the 2.12.x versions of eddie. The only solution I've been able to find to this issue is to NOT USE the NETWORK LOCK. Then it connects in just seconds. However, I feel that the Network Lock feature is so important, I use it anyway and just endure the horribly long connection time while the DNS continues to FLUSH!

 

I can't seem to find any problems in the logs, so the solution beats me. I've recently wondered if the fact that PCLOS doesn't use systemd could be part of the problem.

 

I'm known as oldschool in the PCLOS forum.

 

 

 

cse

Share this post


Link to post

I have the same problem. I am running the latest Eddie (2.16.2) on Ubuntu 18.04. (Bionic). After disconnecting, DNS is starting to flush and literally grinding my harddrive. The whole process takes approx. 20 - 30 seconds.

 

Don't know what's going on...

Share this post


Link to post

cse,  Thanks for the reply. 

 

It looks like foxmulder has better time than I have, my flush runs as long as 7 minutes.

 

On occasions 10 to 11 minutes.

 

So it seems that unless a AirVPN programmer jumps into this thread we are just going to put up with waiting or do the network switch you mention.

 

Thank both of you for taking the time to read and answer.  Have a great day.

Share this post


Link to post

On my Ubuntu 18.04 with eddie 2.15.2 dns flush takes a long time (maybe 2-3 minutes) on connect and disconnect.

Had this issue on earlier releases on eddie and on ubuntu 16.04 as well.

 

would be good if an eddie developer could have a look at this issue.

Share this post


Link to post

There are lots of flushing-dns methods, unfortunately Linux doesn't have a generic solution for this.

Eddie tries to detect environment (nscd, dnsmasq, named, bind9) to flush DNS.

 

So, to those who have this long wait time: please activate Preferences -> Logging -> Log Debug, reproduce the problem, and paste there the lines after the "Flushing DNS" line. Thanks.

Share this post


Link to post

There are lots of flushing-dns methods, unfortunately Linux doesn't have a generic solution for this.

Eddie tries to detect environment (nscd, dnsmasq, named, bind9) to flush DNS.

 

So, to those who have this long wait time: please activate Preferences -> Logging -> Log Debug, reproduce the problem, and paste there the lines after the "Flushing DNS" line. Thanks.

 

I log on and logged off here the zip file it wouldn't allow me to load the log file.  But it would allow me to load the whole file zipped.

eddie_2018-08-08.zip

Share this post


Link to post

Maybe a checkbox "Disable DNS Flushing" would be the way to go....?

 

I don't know what's the purpose of flushing the DNS anyway. But i am not deep enough into this tech stuff, so sorry for not having a clue.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...