Jump to content
Not connected, Your IP:

Recommended Posts

Hi and good morning to all, I am here because,like so many others i am at the end of my tether and need help and assistance from those of you in the know.


I need to open ports for my Gameserver bypassing the VPN.


I will keep my first description as short as possible of my current setup and anybody whom wishes to help may ask for further details,


I have 2X instances of Pfsense running on a windows 2012 R2 server machine in Hyper-V, one is configured using this tut https://airvpn.org/topic/17444-how-to-set-up-pfsense-23-for-airvpn/ and the other handles the DHCP and Squid, my reasoning for this is, Squid does not play nice with Vpn's, i have tried everything to get them to work together but pfsense wants to use the default WAN when squid is installed so this was my workaround, i have tried others like pfBlockerNG but it does not have the level of control that Squid offers.


Now to the complicated bit, for the purpose of this i will refer to Pfsense 1 VPN as "Firewall" and Pfsense 2 DHCP & Squid as "Proxy",


The proxy

has 2X LAN subnets which is the local LAN network and is hooked to Squid,

and which is an isolated Lan i wish to use for a gameserver which has an Ip of 3.5 


Then i have 2X wans static which is bridged to 2.1 on the firewall,

and Vlan-Id=10 which connects to 4.1 Vlan-Id=10 on the Firewall, my is routed out this interface in order for it to be passed to the firewall and onto the WAN 


The Firewall

is set up as described in the tut above and works as intended with the exception that the default LAN has changed to is now a Virtual LAN interface and is bridged with the Virtual WAN interface of the proxy which is 2.2,


It also has a another LAN interface VLAN of Id =10 which is hooked up to the 4.2 of the proxy, this interface is to bypass the VPN and is routed out the WAN.


Up until this point everything works as intended normal LAN clients can access the internet through the VPN, and my isolated Subnet can access the web through the WAN, i can also access any game servers i have running locally, and this is where the fun ends, for the life of me i cant get ports open to the outside world, it is strange to me that my Gameserver can access the web and servers can contact steam but beyond that, there seems to be no ports open, i have tried many things such  as forwarding ports using nat out the various gateways.

According to the various port checking sites i have visited all my ports are closed, even port 80 and i know this can not be because i can access the web just fine. 


I appreciate that i may have many extra steps to take with my currant configuration in order to get this to work, and i am very much looking forward to any help than can be given.


Thanks in Advance.




Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...