Jump to content
Not connected, Your IP: 35.172.100.232
free_refil

"You'll need internet for this" Microsoft Services when using SSL Tunnel

Recommended Posts

So, I've been using AirVPN for over a year now and really love the service. But I've had one issue since using the VPN that I was recently able to resolve, so I wanted to pass the information along.

 

At my job where I use the VPN the most, I am forced to use an SSL tunnel over port 443 as all the other protocols are blocked or do not work. However, when connecting the VPN, any service that connects to Microsoft such as Windows Store updates on Windows 10, and Office 365 Apps such as OneNote, would ask you to sign in to your MS account and then would give an error saying "You'll need internet for this."

I dealt with the issue for a while and was able to finally figure out what was making it occur. If you go to Control Panel>Network and Sharing Center>Change Adapter Settings, find the TAP-Windows adapter for the VPN, Right Click>Properties, then uncheck/disable IPv6, and VOILA! It will work just fine!

 

I also found that you can disable IPv6 in Eddie by going to AirVPN>Preferences>Advanced>Microsoft Windows Only Section>Disable IPv6 at OS level if requested.  This by default is NOT checked, so I believe checking this will also resolve the issue.

 

Wish I had tried to fix this quicker than I did because it only took a few seconds.  I hope this helps others who may run into this issue.

Share this post


Link to post

Didn't help me, I still have this problem. It is not just Microsoft services, a number of websites do the same when payment processing.

Share this post


Link to post

I found some information here that helped me, though the screenshot there looks to be from an earlier Microsoft Windows version (I am on Windows 10 with the latest updates per posting date). After tinkering a bit, I found that if I went to the Advanced settings for the Internet Protocol Version 4 (TCP/IPv4) Properties, I could add a Default gateway and uncheck its automatic metric - I set Metric value to 3 (seemed like a good value since it's what's on the previous screen). Afterwards, my Office installation was able to connect and verify the subscription was up-to-date.

 

Please let us users know if this works for you, and I'd encourage that anyone who is knowledgable about Metric values to share their expertise here.

 

Verifying your anonymity at ipleak.com and elsewhere is probably a good idea: http://ipleak.com/full-report/

Share this post


Link to post

I've tried disabling IPv6 on both the NIC and the TAP Windows Adapter the VPN creates for it's connection, as well as disabling IPv6 in Eddie, and still cannot get Microsoft services to connect.  

Share this post


Link to post

I found some information here that helped me, though the screenshot there looks to be from an earlier Microsoft Windows version (I am on Windows 10 with the latest updates per posting date). After tinkering a bit, I found that if I went to the Advanced settings for the Internet Protocol Version 4 (TCP/IPv4) Properties, I could add a Default gateway and uncheck its automatic metric - I set Metric value to 3 (seemed like a good value since it's what's on the previous screen). Afterwards, my Office installation was able to connect and verify the subscription was up-to-date.

 

Please let us users know if this works for you, and I'd encourage that anyone who is knowledgable about Metric values to share their expertise here.

 

Verifying your anonymity at ipleak.com and elsewhere is probably a good idea: http://ipleak.com/full-report/

 

What do I need to set the default gateway to?

Share this post


Link to post

I have this exact problem with all Microsoft Office / Outlook programs where I get the "You'll need internet for this" and force a sign-in that doesn't work.

 

I looked for the disable IPv6 option in Eddie but it does not seem to be there in the Advanced -> Microsoft Windows Only section anymore in version 2.16.3 of the Eddie client.

 

What can I do to get Microsoft Office syncing again?

Share this post


Link to post

Greeting everyone. I tried few different solutions like disabling IPv6 which cause Eddie to freak out and restart the connect since it will try to reattempt to connect IPv6.

 

After looking around and found a right solution for this issue. It is something to do with the gateway that OpenVPN don't have the support for. Office 365 and Microsoft product relies on gateway for detecting network activity. The way Eddie/OpenVPN are designed to keep the gateway blank is the cause of the issue. The I found the solution from this forum, Here is the link to the actual solution of the problem. I can confirm it finally working with Eddie running.

 

https://www.macwheeler.com/windows-10-office-365-cannot-connect-over-openvpn-fixed/

 

It like what JimDandy posted. The guide recommend putting 192.168.0.1 in TAP's gateway in IPv4 Advanced option. The link have the guide step by step how to do it. I can confirm it works for me. And I haven't got any complaints from OneDrive and Office 365 with this guide.

Share this post


Link to post

Hello!

 

Yes, that's totally correct. Please note that it's not OpenVPN fault, but Office's. There's really no logic in the world to declare that there's no Internet connection and refuse to proceed sending/receiving data when any virtual network interface does not include a gateway which is superfluous. On top of that, it's a system task, not an application job, and actually the system exchanges data to/from the VPN with no issues. It can be considered an Office 365 critical bug.

 

Kind regards

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...