Jump to content
Not connected, Your IP: 3.227.233.6
Sign in to follow this  
beefcake

Getting error when starting Eddie from a shell script

Recommended Posts

Hello,

 

I can successfully run the Eddie CLI and connect by issuing 

 

sudo ~/airvpn -cli -connect
 
However, I want to put this line into a shell script "vpn.sh" so that I con't have to type all this every time I connect, but instead just issue "vpn.sh". When I do this, the program doesn't connect but instead I get a small graphical window with the title "Eddie" and the content "Lib.Platform.Linux.Native.so".
 
This also happens when I set an alias for the long command in my .bashrc.
 
Does anyone know why that happens, and how to avoid it? If there's another, better solution to my problem, I'm also happy to hear about it.
 
Thanks in advance.
 
 
/Edit:
 
Okay, this is mighty weird:
*Sometimes*, this command throws the same error:
 
 sudo /home/beefcake/files/Software/eddie-ui_2.13.6_linux_x64_portable/airvpn -cli -connect
 
I've had two bash windows open where it worked in one, and failed in the other.
 
If I issue these commands, it works:
 
 cd /home/beefcake/files/Software/eddie-ui_2.13.6_linux_x64_portable/
 sudo ./airvpn -cli -connect

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...