Jump to content
Not connected, Your IP:

ANSWERED Eddie 2.13.6 beta, DNSCrypt 1.0.14 and Mac OS 10.12.5

Recommended Posts

I've been using Eddie 2.13.16 beta for several months now on Mac OS 10.12.5.


When I launch Eddie 2.13.6, it seems to launch noticeably faster than Eddie 2.13.3, and also does not seem to get stuck on "checking route" as Eddie 2.13.3 often did on launch.


Also, when I disconnect from a server and then switch to another server, Eddie 2.13.6 switches with no problems whereas Eddie 2.13.3 would often get stuck on "checking route" and I'd have to quit Eddie 2.13.3 and relaunch it.


Also, Eddie 2.13.6 has been rock solid when it connects and I don't think it has dropped a connection since I've been using it. It will stay connected until I disconnect from a server.


My question has to do with using Eddie (both 2.13.3 and 2.13.6) and DNSCrypt.


When I boot up my MacBook, DNSCrypt will automatically launch and the regular DNSCrypt icon will show up on my menubar.


On the DNS tab in the Eddie preferences, I have checked the "Check AirVPN DNS" box and the DNS server IP shows as in the DNS Servers field.


However, after I launch Eddie, the DNSCrypt icon turns into a square with an exclamation point inside the square.


Does this mean that DNSCrypt is no longer encrypting my DNS requests?


If yes, is there a solution to this?

Share this post

Link to post

Stop then restart DNSCrypt AFTER you connect to the VPN. You cannot use the AirVPN DNS and the one provided by DNSCrypt at the same time. Just choose one. Either option is a good one. AirVPN has a stable and secure DNS server already setup for you, but if you use it, you may as well uninstall DNSCrypt. And if you really want to use DNSCrypt, uncheck the "Check AirVPN DNS" option and set the DNS mode in Eddie to disabled. You may still have to restart DNSCrypt every time you connect to the VPN because you cannot be certain the DNS server has been set properly otherwise.


Sorry if there is an easier way I am oblivious to. I have never used a Mac, so I can only tell you what works on Windows and Linux. Good luck. Have a nice day.

Debugging is at least twice as hard as writing the program in the first place.

So if you write your code as clever as you can possibly make it, then by definition you are not smart enough to debug it.

Share this post

Link to post

Thanks for the reply OmniNegro.


I tried your first suggestion of stopping and then restarting DNSCrypt after connecting to an AirVPN server but that did not work, I was not able to connect to the internet.


I also tried your suggestion of unchecking the "Check AirVPN DNS" option and setting the DNS mode in Eddie to "disabled" but that also did not allow me to connect to internet.


I will keep DNSCrypt on my computer but will not use it unless for some reason Eddie doesn't work and I have to connect to the internet without using AirVPN.


I'm now just using Eddie with the "Check AirVPN DNS" option checked and setting the DNS mode in Eddie to "Automatic" as I originally had when I was also trying to use DNSCrypt.


Thanks again!

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...