Jump to content
Not connected, Your IP: 44.200.27.215
Bocean

ANSWERED Lubuntu - apt and apt-get timeout when connecting to Repos via AirVPN

Recommended Posts

I have Eddie installed on a server running Lubuntu 17.10 (and prior to that Lubuntu 17.04).   I have Eddie configured to utilise AirVPN Servers located in the USA.    I'm very happy with the performance of AirVPN - excellent speed, and great reliability.

 

However - I have one issue that is causing problems.  When I run apt-get (or apt), I get timeouts on all of the Ubuntu Repo Servers.   I have manually selected Ubuntu Repo Servers located in the USA, in the same city as the AirVPN Server in use when possible, and still encounter these timeouts. 

 

I have tried using the Ubuntu utility to identify the fastest Ubuntu Repo Server, and that Utility gives strange results when run via AirVPN.  When run through AirVPN, the utility seems to get confused and reports Ubuntu Repo Servers in the strangest places (i.e. Iceland, Peru, Columbia, Bangladesh, etc ...) as being the fastest servers - but these recommended servers also timeout when you run apt update.  When this Ubuntu utility is run with Eddie shutdown, the utility correctly identifies the fastest Ubuntu Repo Server as being one in my country, hosted by the ISP that I use .... so the utility is working correctly, provided it is not used via AirVPN.

 

If I completely exit from Eddie, apt-get and apt all work very fast, at roughly the same speed as my other Ubuntu, Linux Mint, Debian and Armbian systems.

 

An inquiry to Ubuntu Technical Support regarding this problem resulted in their answering that "it must be a problem with the VPN software".   A classic case of buck-passing !

 

My workaround at the moment is to disable Eddie whenever I need to run apt or apt-get - not really a satisfactory permanent solution.

 

So - has anyone got any ideas what might be causing this problem, or how to fix it ?

 

Thanks

 

RoyG

Share this post


Link to post

Did you try connecting via terminal or another connection method?

 

Sent via Tapatalk. Means, I don't have a computer available now.


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

PROBLEM SOLVED

 

It seems that this problem is related to apt and apt-get trying to use IPv6 over the VPN.

 

Using this command forces apt-get to use IPv4, and the time-outs and/or very very slow updates go away.

 

sudo apt-get -o Acquire::ForceIPv4=true update

 

sudo apt-get -o Acquire::ForceIPv4=true upgrade

 

Once I realised that the problem was caused by a lack of IPv6 on AirVPN, I was able to find this post on the Forum that discussed IPv6.

 

https://airvpn.org/topic/23903-ipv6-cannot-be-safely-disabled-on-linux/?hl=ipv6

 

Many thanks,

 

RoyG

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...