Jump to content
Not connected, Your IP: 34.230.84.215
Sign in to follow this  
ntropia

Ubuntu: impossible to connect *without* AirVPN

Recommended Posts

I'm having constant problems with the Eddie GUI on Ubuntu 17.04.

 

When the VPN connection with the network lock is up and running, everything works fine.

 

 

The issues start when the VPN (and the network lock) is disabled, the original non-VPN connection is not restored.

My tests show that when disabling the VPN, the routing rules are empty and none of the original, non-VPN rules are restored.

 

I've seen this behavior for about a year, now, and I believe it is a very annoying bug of the Eddie interface.

By looking at the forum, it seems it is a problem shared across different systems (or at least it affects Windows, too).

 

The only workaround I found so far is to reboot the system preventing the auto-start of the GUI.

 

Any chances it can be fixed?

 

Thanks,

 

S

Share this post


Link to post

The issues start when the VPN (and the network lock) is disabled, the original non-VPN connection is not restored.

My tests show that when disabling the VPN, the routing rules are empty and none of the original, non-VPN rules are restored.

 

I've seen this behavior for about a year, now, and I believe it is a very annoying bug of the Eddie interface.

 

Not reproducible, we're sorry. Anyway, nothing to fix on our side, because it's OpenVPN that modifies and restores routes, not Eddie.

 

With our service default directives, the only way we can imagine to prevent OpenVPN to do that is killing it without grace (kill -9). Since you claim you have detected this bug a year ago, you might like to contact OpenVPN community and also use the bug track system (explain an exact way to systematically reproduce the issue). We can't do that because we can't reproduce the issue in any way.

 

Kind regards

Share this post


Link to post

 

By looking at the forum, it seems it is a problem shared across different systems (or at least it affects Windows, too).

 

 

I realize that YOU are having a problem.  I quoted what you said above but if "many" were having the same issue this forum would be lit up like a Christmas tree.  I have never seen that issue with linux on my Debian or Ubuntu systems.  I do make sure that Eddie shuts itself down properly.  If there was/is a computer crash (loss of electricity, etc...) the linux system reboot takes care of everything on my end.  You shouldn't have to reboot the computer to gain non-VPN traffic capabilities.  That said; I have firewalls written so my machines cannot access the open internet outside of various VPN tunnels.

Share this post


Link to post

Hay,i have had same problem beafore. u just go to your network card, then you right click and press prefrenses i belive... im norwegian sorry.
There you should see a list of stuff. press IPv4 or Ipv6, and press the little box wich says "recive IP-adress automatic
Just tell me if you didnt understand  

Share this post


Link to post

Apologies for reporting the issue, and prematurely pointing at the wrong program.

 

I had some extra time to investigate and I found that the routing issue was a secondary problem.

The problem has been apparently triggered after I disabled the dnsmasq in the Network-Manager to fix the DNS leak

 

For some reason, I had dnsmasq installed, so I removed it and I commented out the corresponding line in the /etc/NetworkManager.conf

After that, the systemd DNS was set as default, because I found this to be the content of my /etc/resolv.conf

 Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.53

...which I didn't configure nor enabled (I guess it's a default system setting, now?).

The NetworkManager does not seem to be getting the DHCP settings from the router when negotiating the WiFi connection, so the content of this file was not properly populated with the current connection DNS.

 

When the VPN is activated, this file gets replaced by the one generated by Eddie, everything works fine, so the problem seems to be specific for Ubuntu, and mostly due to the systemd plague (in other words, Eddie was fixing an Ubuntu problem).

 

I apologize again for pointing at Eddie as the culprit, I had indeed seen people mentioning the problem several times, but I should have spend more time debugging the issue.

 

Sorry, iwih2gk, I use regularly Debian and Ubuntu myself for a very long time, now, but I still have to get used to the extra layer of systemd and the chaos that follows that.

 

Thanks to the developers for the prompt answer, very much appreciated.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...