Jump to content
Not connected, Your IP: 3.87.147.184
user0

ANSWERED Minecraft Authentication Failure

Recommended Posts

Attempting to log in to your Mojang account (which you must do to play Minecraft) fails from some AirVPN servers, for instance Celaeno, Netherlands. Unhelpfully, you just get the error message "Login failed. Invalid username or password." which can lead you on the wild goose chase of changing your password etc.

 

Everything works fine from other servers, such as Mebsuta, Belgium. 

Share this post


Link to post

Same here with Switzerland. Login isn't possible at all, it will always plainly reject the login. Had to use VPN to get correct VAT while travelling in another country, so I had to disable VPN for login and could reenable for purchasing.

Share this post


Link to post

Can confirm on Canadian servers as well. 3rd and 1st party minecraft clients and Mojang's websites simply state you have the wrong password no matter course of action, e.g. password reset. I find it hard to believe it is a normal VPN issue since AirVPN seems to be the only isolated incident I have experienced while using a VPN to access minecraft.

Share this post


Link to post

Minecraft/Mojang has banned VPN's from accessing the logon servers.

 

There has been some speculation as to why, whether its to stop Chinese players from accessing a restricted version or whether it's simply to stop users trying to bypass server IP bans.

 

It's pretty much anyone's guess at the moment. If you contact support they will simply vaguely say that "some VPN's are not supported and turning them off will solve the problem"

 

It's bullshit, if it doesn't work it's because they blocked the IP plain and simple. Only question is why.

Share this post


Link to post

Whitelist the authserver at authserver.mojang.com & their VPN checker at mcoapi.minecraft.net and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

NB: Do not nslookup either hostname and use the IP you find as you will notice when (if) you switch servers, the IP will change. This is because they employ a geographic load balancer on their APIs.

Edited ... by jsand

Share this post


Link to post

Darn, never thought it would be the VPN. I bought my son a new account because I couldn't believe he was really typing in the correct password lol...

Share this post


Link to post

Whitelist the authserver at authserver.mojang.com (54.230.147.107) & their VPN checker at mcoapi.minecraft.net (34.195.179.245) and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

This should be best answer.

 

Applied, tested, confirmed to work.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Update: They have a geographic system for detecting best location, therefore the IPs I gave in my previous post are not valid for every case (the domains are fine, if you just use those!); I am editing those IPs out, the post still stands correct as of now.

Share this post


Link to post

Whitelist the authserver at authserver.mojang.com & their VPN checker at mcoapi.minecraft.net and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

NB: Do not nslookup either hostname and use the IP you find as you will notice when (if) you switch servers, the IP will change. This is because they employ a geographic load balancer on their APIs.

How do you do this? I can't find a guide online

Share this post


Link to post

 

Whitelist the authserver at authserver.mojang.com & their VPN checker at mcoapi.minecraft.net and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

NB: Do not nslookup either hostname and use the IP you find as you will notice when (if) you switch servers, the IP will change. This is because they employ a geographic load balancer on their APIs.

How do you do this? I can't find a guide online

 

Hello!

 

Welcome to AirVPN!

 

Here's one potential solution. This is assuming you're using the Air Eddie client with Network Lock ON:

  1. Please go to Eddie's Menu>Preferences>Network Lock>Tick "Allow detected DNS". Then hit Save.
  2. Please then go to Routes, further up in the same sidebar. Click the green + icon and write mcoapi.minecraft.net. Then click once in the "Notes" field to see an IP address appear for that domain. Hit Save.
  3. Do number 2 again, but with other domains: authserver.mojang.com and potentially also minecraft.net. Please ensure all are set to "Outside" the tunnel.
  4. When all are added, hit the Save button for the Routes window itself and re-connect to the same or a different country location. If you don't, the changes won't take effect and is an easy thing to miss.
  5. Then refresh the website in question and/or try to login. If there's still issues, do remember to try different servers too.

That might do it. It certainly did for me, after a substantial amount of fiddling around.

I only created an account specifically for this purpose, so I assume if it works for a new entrant, it'll work for someone who already has an account.

Like the OP, I was getting much the same errors about "Invalid" this or that. Most of all, I got an error saying "Oops! We couldn't process your request" or something.

 

Only do this for sites you trust, as this will expose your real IP.

 

Best of luck

 

Note: He was saying you shouldn't use nslookup in the terminal. Such as "nslookup mcoapi.minecraft.net" because you would get a specific IP address and that's no use, when that address changes all the time. Therefore, in the routes window, it's best to just specify the domain name itself, to account for any changes. Not to mention, some domains, like minecraft.net, use many different IP addresses and therefore it's impractical/impossible to write them all. Further, we enabled "Allow detected DNS", as you would otherwise get a warning.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

 

 

How do you do this? I can't find a guide online

Whitelist the authserver at authserver.mojang.com & their VPN checker at mcoapi.minecraft.net and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

NB: Do not nslookup either hostname and use the IP you find as you will notice when (if) you switch servers, the IP will change. This is because they employ a geographic load balancer on their APIs.

Hello!

 

Welcome to AirVPN!

 

Here's one potential solution. This is assuming you're using the Air Eddie client with Network Lock ON:

  1. Please go to Eddie's Menu>Preferences>Network Lock>Tick "Allow detected DNS". Then hit Save.
  2. Please then go to Routes, further up in the same sidebar. Click the green + icon and write mcoapi.minecraft.net. Then click once in the "Notes" field to see an IP address appear for that domain. Hit Save.
  3. Do number 2 again, but with other domains: authserver.mojang.com and potentially also minecraft.net. Please ensure all are set to "Outside" the tunnel.
  4. When all are added, hit the Save button for the Routes window itself and re-connect to the same or a different country location. If you don't, the changes won't take effect and is an easy thing to miss.
  5. Then refresh the website in question and/or try to login. If there's still issues, do remember to try different servers too.

That might do it. It certainly did for me, after a substantial amount of fiddling around.

I only created an account specifically for this purpose, so I assume if it works for a new entrant, it'll work for someone who already has an account.

Like the OP, I was getting much the same errors about "Invalid" this or that. Most of all, I got an error saying "Oops! We couldn't process your request" or something.

 

Only do this for sites you trust, as this will expose your real IP.

 

Best of luck

 

Note: He was saying you shouldn't use nslookup in the terminal. Such as "nslookup mcoapi.minecraft.net" because you would get a specific IP address and that's no use, when that address changes all the time. Therefore, in the routes window, it's best to just specify the domain name itself, to account for any changes. Not to mention, some domains, like minecraft.net, use many different IP addresses and therefore it's impractical/impossible to write them all. Further, we enabled "Allow detected DNS", as you would otherwise get a warning.

This doesnt seems to work anymore anyone else has luck with this ?

Share this post


Link to post

Still working here. Make sure you do a nslookup when you're not connected to AirVPN to get the IPs you would get querying those two domains. Then edit your .ovpn file or add the IPs in the Routes tab of Eddie.

 

How do you do this? I can't find a guide online

Whitelist the authserver at authserver.mojang.com & their VPN checker at mcoapi.minecraft.net and you can login. The rest of the game traffic will be through VPN. Enjoy!

 

NB: Do not nslookup either hostname and use the IP you find as you will notice when (if) you switch servers, the IP will change. This is because they employ a geographic load balancer on their APIs.

Hello!

 

Welcome to AirVPN!

 

Here's one potential solution. This is assuming you're using the Air Eddie client with Network Lock ON:

  • Please go to Eddie's Menu>Preferences>Network Lock>Tick "Allow detected DNS". Then hit Save.
  • Please then go to Routes, further up in the same sidebar. Click the green + icon and write mcoapi.minecraft.net. Then click once in the "Notes" field to see an IP address appear for that domain. Hit Save.
  • Do number 2 again, but with other domains: authserver.mojang.com and potentially also minecraft.net. Please ensure all are set to "Outside" the tunnel.
  • When all are added, hit the Save button for the Routes window itself and re-connect to the same or a different country location. If you don't, the changes won't take effect and is an easy thing to miss.
  • Then refresh the website in question and/or try to login. If there's still issues, do remember to try different servers too.
That might do it. It certainly did for me, after a substantial amount of fiddling around.

I only created an account specifically for this purpose, so I assume if it works for a new entrant, it'll work for someone who already has an account.

Like the OP, I was getting much the same errors about "Invalid" this or that. Most of all, I got an error saying "Oops! We couldn't process your request" or something.

 

Only do this for sites you trust, as this will expose your real IP.

 

Best of luck

 

Note: He was saying you shouldn't use nslookup in the terminal. Such as "nslookup mcoapi.minecraft.net" because you would get a specific IP address and that's no use, when that address changes all the time. Therefore, in the routes window, it's best to just specify the domain name itself, to account for any changes. Not to mention, some domains, like minecraft.net, use many different IP addresses and therefore it's impractical/impossible to write them all. Further, we enabled "Allow detected DNS", as you would otherwise get a warning.

This doesnt seems to work anymore anyone else has luck with this ?

Sent via Tapatalk. Means, I don't have a computer available now.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

 

Still working here. Make sure you do a nslookup when you're not connected to AirVPN to get the IPs you would get querying those two domains. Then edit your .ovpn file or add the IPs in the Routes tab of Eddie.

Sent via Tapatalk. Means, I don't have a computer available now.

Maybe its because im trying to connect with servers in the netherlands because for me it just isnt working

Share this post


Link to post

Hi,
I'm having difficulty following the earlier guide; there isn't a checkbox for "Allow detected DNS" in the Network Lock tab, and when I type in the addresses in the Routes dialogue, nothing happens in the "notes" field. Maybe I'm using an outdated version of the Eddie client?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...