Jump to content
Not connected, Your IP: 18.208.126.54
icedearth1776

ANSWERED My isp is 300+ mbps but on AirVPN it's 10 mbps

Recommended Posts

Thanks for the tip!

 

So I used Eddie on my laptop and I get close to 200 mbps connecting to a server in the NL.  This bypasses pfsense. I'm only getting 10-20 mpbs in pfsense via openvpn when connected to the same server.  

 

I'm not sure what to look at to try to fix this.

Share this post


Link to post

Greetings.

 

I have an intel processor so I have all the hardware crypto settings set for Intel / rd-rand.  Is this where the action is at or should I be looking elsewhere?

 

Thanks.

 

so, actually, an AES-NI CPU is used by openvpn/openssl automatically.  In fact, many people find better performance completely disabling hardware crypto support in the advanced settings of pfsense.  Sounds crazy, but I tested it on my AMD CPU and performance is increased.

 

again, try selecting "none" in system>advanced>miscellaneous>cryptographic hardware.  Also select "none" for hardware crypto in the openvpn client setup.  Then reboot.

 

However, your speeds are so diminished as compared to Eddie that I suspect something else needs to be fixed first.

Share this post


Link to post

Look there, you'll probably get more information.

What is the CPU of your pfsense box?

 

It's an Intel Core i7 4785T.  Yes, that was the awesome guide I followed.

 

When I get home I'll try it without the hardware crypto and see what happens.  Does Eddie use hardware crypto by default?

Share this post


Link to post

 

Greetings.

 

I have an intel processor so I have all the hardware crypto settings set for Intel / rd-rand.  Is this where the action is at or should I be looking elsewhere?

 

Thanks.

 

so, actually, an AES-NI CPU is used by openvpn/openssl automatically.  In fact, many people find better performance completely disabling hardware crypto support in the advanced settings of pfsense.  Sounds crazy, but I tested it on my AMD CPU and performance is increased.

 

again, try selecting "none" in system>advanced>miscellaneous>cryptographic hardware.  Also select "none" for hardware crypto in the openvpn client setup.  Then reboot.

 

However, your speeds are so diminished as compared to Eddie that I suspect something else needs to be fixed first.

 

I will try turning hardware crypto off tonight but yes, I wonder what could possibly need fixing... I'll have a look at the switch tonight.. maybe something is up with auto-negotiation or who knows what else...

Share this post


Link to post

Update: I disabled crypto in both places and now my downloads are hovering around 50-60.  It's an improvement! But I am under the impression I would take about a 10-50% hit, so I was expecting speeds around 150 at least.

 

Hmm.. I'm at a loss, not sure what to look at.

 

EDIT: I completely ignored the recommendation to try to find local servers.  I just tried this and yes, there is even a larger improvement.  But I'm in a habit of not choosing local servers, and with Eddie I'm getting 110, with pfsense/openvpn, I'm getting 60.

Share this post


Link to post

Update: I disabled crypto in both places and now my downloads are hovering around 50-60.  It's an improvement! But I am under the impression I would take about a 10-50% hit, so I was expecting speeds around 150 at least.

 

Hmm.. I'm at a loss, not sure what to look at.

 

EDIT: I completely ignored the recommendation to try to find local servers.  I just tried this and yes, there is even a larger improvement.  But I'm in a habit of not choosing local servers, and with Eddie I'm getting 110, with pfsense/openvpn, I'm getting 60.

 

Are pfsense and eddie using the exact same port and protocol?  Have you tried messing with mssfix settings, receive and send buffer in pfsense?

Share this post


Link to post

 

Update: I disabled crypto in both places and now my downloads are hovering around 50-60. It's an improvement! But I am under the impression I would take about a 10-50% hit, so I was expecting speeds around 150 at least.

 

Hmm.. I'm at a loss, not sure what to look at.

 

EDIT: I completely ignored the recommendation to try to find local servers. I just tried this and yes, there is even a larger improvement. But I'm in a habit of not choosing local servers, and with Eddie I'm getting 110, with pfsense/openvpn, I'm getting 60.

Are pfsense and eddie using the exact same port and protocol? Have you tried messing with mssfix settings, receive and send buffer in pfsense?

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post

Ok, not sure what happened here but I added a few other settings such as 

 

tun-mtu 1500;
keepalive 5 15;

 

and then speeds went back down to 10mbps.  I reverted to what I had before with simpy mssfix 1450, and now I'm unable to replicate the 150 mbps speeds as it's now stuck again in the 10-20 mpbs range.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...