Jump to content
Not connected, Your IP: 18.234.51.17
raoulduke

ANSWERED Windows 10 creator update Airvpn DNS slow ?

Recommended Posts

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go

 

Eddie is btw the name of the AirVPN client .

 

 

Has anybody else tried this??  Does it work?

Share this post


Link to post

@ U&^TUB&NI

thanks for your efforts! i really don't know where to search for the solution, because i didn't change anything in my setup - - just made the creators update/upgrade ...

 

@ kbps

i have been running eddie portable before and after the upgrade, so this will not work for me.

Share this post


Link to post

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

Share this post


Link to post

 

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go

 

Eddie is btw the name of the AirVPN client .

 

Has anybody else tried this??  Does it work?

I tried this, but it didn't fix the problem.

Share this post


Link to post

Hi, as all of you since the upgrade of Windows 10 creator update, I too have very slow DNS lookup, and since many websites do lookup many domains at a single page like trackers or ads, loading takes significant time until the DNS cache on a local machine fills with DNS grabbed already.

 

But I know what causes this. The assumption is that it is Airvpn Client Eddie or Airvpn DNS doing this, however you can change your DNS even with Networklock Enabled into anything you like, and that is why I explain what is happening.

 

Almost all VPN providers rely on OpenVPN TAP Adapter, so does Eddie, but Airvpn does not create OpenVPN TAP Adapter Driver, currently TAP-Windows Provider V9, dated 21-4-2016, version 9.0.0.21 made and maintained for many Operating System platforms by OpenVPN Technologies, Inc.

 

You should therefore search at google for OpenVPN DNS slow after Windows 10 creator update, you will find unfortunately only a few topics but for me I place my findings here. The problem is, Microsoft on Windows has to Digital Sign and allow OpenVPN Technologies, Inc. to release a new OpenVPN TAP Adapter Driver that knows and is bug fixed (caused by Microsoft in my opinion) about how to handle Windows 10 Creator Update released in April 2017. 

 

So Airvpn can try whatever, but Eddie Client is just fine, the error is not in there. Nor in Airvpn DNS servers or any other DNS server you can configure.

 

It's Microsoft or OpenVPN Technologies, Inc. and I don't think Microsoft is in a hurry to not push their own VPN build into Windows 10.

 

It will be resolved, but now you know the cause, this is my first post, and I hope I answered your questions. So many people rely on OpenVPN TAP Adapter Driver, and latest driver signed by Microsoft is dated as I explained long ago in terms of computer science 21-4-2016.

 

But I hope all providers using OpenVPN will push the right buttons somewhere in rainbow computerland.

Share this post


Link to post

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

 

 

And that worked for me ! Thank you @kadett

Share this post


Link to post

thank you, kadett!

unfortunately it doesn't work for me. still slow dns resolution.

i get the best results with 'my dns-workaround'.

 

by the way:

just did a clean install of the creators iso.

when starting eddie i get a 'checking route don't match loop'.

Share this post


Link to post

 

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go

 

Eddie is btw the name of the AirVPN client .

 

 

Has anybody else tried this??  Does it work?

 

 

Update.  I tried this and it didn't work for me.  

Share this post


Link to post

Hello!

 

EDIT: Eddie 2.13.2beta automatically lowers the tun/tap interface metric to fix the problems caused by the wrong DNS implementation by Microsoft. If you run Windows Creator please upgrade to Eddie 2.13. to solve the problem.

 

https://airvpn.org/topic/13002-experimentalbeta-release/

 

===

 

 

EDIT: After a deeper investigation the workaround published in this post might be not proper. If it does not work successfully for you, please consider to lower the metric of the tap adapter:

https://airvpn.org/topic/22650-windows-10-creator-update-airvpn-dns-slow/page-3?do=findComment&comment=61332

 

 

Temporary workaround, until we release an update of Eddie

 

1. Disable IPv6
Control Panel\Network and Internet\Network Connections, Properties of your real (not TAP) network interface, uncheck Ipv6.

 

2. Disable SmartNameResolution
Run this .reg file: https://airvpn.org/repository/DisableSmartNameResolution.zip


Explanation

The same issue occurs also on plain OpenVPN 2.4 with directive block-outside-dns

From https://sourceforge.net/p/openvpn/mailman/message/35789733/

 

 

Windows 10 Anniversary Update changed the way DNS works. It used to resolve qualified names using all available adapters and IP addresses in parallel, now it still resolves addresses using all available adapters but in sequence, beginning with random adapter.
This interferes with how --block-outside-dns currently works. Sometimes OS chooses VPN TAP adapter and things work as intended, sometimes the other adapter and user have to wait until DNS request times out and name resolution goes via VPN DNS.

This behavior introduces significant lag for web browsing.

 

Eddie uses the same approach than ValdikSS "block-outside-dns" directive of OpenVPN: it blocks DNS query with WFP filters. With Windows 10 Creator build (1703) DNS resolution waits for the timeout of IPv6 resolutions (blocked by Eddie) and non-tunneled resolutions (also blocked by Eddie to prevent DNS leaks).

 

This issue will be addressed shortly by a new Eddie release.

 

Kind regards

Share this post


Link to post

Changing the metric (kadett's post) fixed the problem for me.

 

And in reference to an earlier post, I have assumed all along that this was a problem caused by Microsoft, not by AirVPN software.

 

AirVPN has listed a workaround and I'm sure will have a permanent fix in a future software release.

 

Thanks.

Share this post


Link to post

didn't work for me either.

you can make it undone by the following:

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient]
"DisableSmartNameResolution"=dword:00000000

 

ps: don't forget to reboot

Share this post


Link to post

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

Success! After an initial fail due to my inability to type, it's now working. Thank you so much.


Asus RT-AC88U [Hardware:A2] Mode: Wireless Router

Firmware by @RMerlin

Share this post


Link to post

kadett, on 15 Apr 2017 - 11:13, said:

snapback.png

 

Hi
 
I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.
Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to
25 everything works fine again. It might be a working solution for you as well.
 

We together now found multiple workarounds working together, although I follow instructions only, I want to deduce why and how it actually works, so people like I or you know what is actually going on and why the workaround works. I for example say without manually setting the Metric Costs, all traffic is affected and not only DNS. I noticed since the Creator Update traffic at least became half, not in speed but in connection setup times, which mostly was obfuscated by slow DNS since that was simply hiding my (personal) findings about connection speed. 

 

Here is a technical description from a Microsoft website. I will not do citation from Microsoft but will summarize it as best as I can.

 

https://support.microsoft.com/nl-nl/help/299540/an-explanation-of-the-automatic-metric-feature-for-ipv4-routes

 

Now let me explain what metric cost is, imagine you have 2 the same products. But they do not cost the same. Would you pay 25 thousand for a car that is identical to a 15 thousand car? Probably not. Now imagine both cars cost the same. That is as soon as you want to buy the car the other car becomes a little cheaper so you suddenly want the other car, but when you then want to buy the suddenly cheaper car, the first car that was cheaper becomes a little cheaper and so on and on. It means you as a customer wanting to have the car waiting for the cars offered to become cheaper, well I would. And this is what Automatic Metric at IP4 from a network adapter does in Automatic Metric mode when another network adapter is present with Automatic Metric Mode too. And this is in computer land called 'race condition', and the objective is simply at the lowest costs to traffic IP4 packets like TCP or UDP over a (virtual) link like a network adapter.

 

That is why setting the Metric Costs at 15 by hand for the virtual network TAP Adapter at the IP4 advanced section makes IP4 packets preferring the lower costs as soon as you set your regular hardware network adapter Metric Costs at 25. Since you can imagine it just like the example of buying the cheapest car. Which is much easier if you know the price tag by forehand and not have to randomly choose or gamble or hope for it to become cheaper.

 

Member of this forum: Kadett was the first person who obviously knew something to do, and I can only try to describe why it works what Kadett in my personal experience and others experience works. This might have been dormant but Microsoft claims Automatic Metric Costs is a new feature, but I only know this since Kadett posted how to change it.

 

The costs of the virtual TAP OpenVPN Adapter are set lower, more attractive, yes, the software will use that Adapter it costs 15 while the Real Network Adapter costs even 25 isn't that a bargain if it were like car salesmen? 

 

The Virtual TAP OpenVPN network Adapter is out of my knowledge didn't read about it, but it always has to have a physical network card and has no other choice then to buy the higher Metric Cost, as car sales man I would say, by buying the cheapest car it is best since the cars are identical. 

 

I hope I am technically explaining what happened, how it works, and how this workaround fixes it until Microsoft changes something in their OS again maybe.

 

Share this post


Link to post

great explanation! thank you.

now it works for me too.

made the mistake to change only one adapter.

perfect ..... so far.

Share this post


Link to post

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

This solved it for me as well! Great and thanks !

 

Skickat från min SM-G935F via Tapatalk

Share this post


Link to post

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

 

And this did the trick for now, cheers for solving this puzzle!

Share this post


Link to post

I just recently wiped and reloaded windows 10 and did the manual creators update. Prior to reload of windows web page loading was fine. After the reload of windows with creators update pages were sitting on a white screen with the loading sign in the title bar for a good 10-15 seconds before anything would show up on the actual page. I assume this is what everyone is talking about here. I applied the 15/25 as kadett mentioned above and it seems to be back to normal for now anyway. It was getting very annoying and feeling like I was back on dialup internet instead of 200meg/20meg.

Share this post


Link to post

I am on the Windows 10 Creators Update on my gaming desktop and this suggestion on Reddit fixed the issue for me. I am on wired on the desktop so I am not sure if Windows prioritizes this differently with wireless NICs. It is also similar to what Kadett posted earlier.

 

To resolve this, go to the Cortana search bar, search for Network and Sharing Center, and open it up. From there, go to Change Adapter Settings. You’ll see connection listed for all network adapters on your system, including the OpenVPN TAP adapter that our service uses. In it’s description, it should read “TAP-Windows Adapter V9”. Right-click on that connection, and go to Properties. From there, select “Internet Protocol Version 4 (IPv4), and go to Properties. Click the Advanced button, uncheck the option at the bottom “Automatic Metric”, and set the metric as 1. Apply all the changes, and you should now see DNS resolution operating normally after connecting to the service with DNS Leak Protection enabled.

 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...