Jump to content
Not connected, Your IP: 3.238.4.24
Sign in to follow this  
pandapandachan

Using AirVPN on Seedbox breaks my ability to connect to Seedbox

Recommended Posts

I am running a seedbox (Ubuntu server running Transmission) on a hetzner server and, since I'd like to use it for public as well as private trackers and the host is not friendly with users who receive DMCAs, I'd like the seedbox to use AIRVPN for its connections. The problem is that as soon as I tell AIRVPN to connect, I lost the ability to connect to the server/seebox via SSH or S/FTP- or via remote transmission. The connection simply times out and I have to send a hardware reset signal through my host's control panel to get back into my server/seedbox (fortunately, I did not set AIRVPN to automatically start/connect, since I wanted to confirm that it worked first)

 

 

. How can I configure AIRVPN to still allow these inbound connections (which will originate from a mobile device and a home, both with dynamic IP addresses)? The server has a static IP address for administrative purposes.

Share this post


Link to post

It's not about inbound connections, it's because your routing table has changed and after the connection your main gateway is the VPN gateway.

An easier solution would be configuring your administrative ports on high ports, and forward them in the https://airvpn.org/ports section.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

I am running a seedbox (Ubuntu server running Transmission) on a hetzner server and, since I'd like to use it for public as well as private trackers and the host is not friendly with users who receive DMCAs, I'd like the seedbox to use AIRVPN for its connections. The problem is that as soon as I tell AIRVPN to connect, I lost the ability to connect to the server/seebox via SSH or S/FTP- or via remote transmission. The connection simply times out and I have to send a hardware reset signal through my host's control panel to get back into my server/seedbox (fortunately, I did not set AIRVPN to automatically start/connect, since I wanted to confirm that it worked first)

 

 

. How can I configure AIRVPN to still allow these inbound connections (which will originate from a mobile device and a home, both with dynamic IP addresses)? The server has a static IP address for administrative purposes.

 

You can make some changes to routing and/or iptables rules so that you can still connect via the real IP interface and get responses via the real interface, even when the VPN IP interface is the default gateway. See this post:

 

https://airvpn.org/topic/12274-ubuntu-vm-cant-connect-through-openvpn/?p=44812

 

The option of having the VPN interface not be the default gateway is also discussed in those posts. To do this the programs that you want to use the VPN (e.g. rtorrent) must be bound to the VPN IP address. There is a bit more information about this here:

 

https://airvpn.org/topic/20479-setting-up-docker-containers-with-vpn-on-arch-linux/?do=findComment&comment=52243

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...