Jump to content
Not connected, Your IP: 34.225.194.144
planetm115

JDownloader can't connect through AirVPN

Recommended Posts

Hello,

 

I just installed AirVPN and I'm able to connect to the VPN in general but when I try to download something through JDownloader, it just hangs there as if it can't connect to my Premium Accounts server.

 

When I temporarily disable the Windows Firewall, the download goes through like it should, so that's telling me something in my Windows Firewall is blocking it.

 

Is there a way to configure my Firewall so this doesn't occur?

 

I've never done this before.  Thank you.

Share this post


Link to post

Hello!

 

If you use the Beta client, then WFP will be used instead of Windows Firewall, so that would be a good thing to try in my view

 

Welcome to AirVPN!


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

Hello!

 

If you use the Beta client, then WFP will be used instead of Windows Firewall, so that would be a good thing to try in my view

 

Welcome to AirVPN!

 

 

Well I'm using Eddie.  What is the Beta Client?  And what is WFP?

Share this post


Link to post

 

Hello!

 

If you use the Beta client, then WFP will be used instead of Windows Firewall, so that would be a good thing to try in my view

 

Welcome to AirVPN!

 

Well I'm using Eddie.  What is the Beta Client?  And what is WFP?

You can check the guide in my signature for more in-depth answers or otherwise find it in the How-to forum .


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

So it looks like what you're saying is I should download this Experimental beta 2.11 version of Eddie, overwrite 2.10 that's already installed and try and connect through that.  Yes?

 

And this 2.11 version bypasses Windows Firewall altogether?

 

Thanks

Share this post


Link to post

Yes. Download it, uninstall the current one and then install it.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

Hi, sorry to bother you again.  I did what you all say, but it's still hanging there, only now when I disable Windows Firewall, it still won't connect.  With 2.10 it would connect with the Windows Firewall disabled.  With 2.11 beta, now it won't even do that.

 

However now when I disable AirVPN, and re-enable the Firewall, it goes through.  It must be a setting somewhere.

Share this post


Link to post

Have you tried allowing it through your firewall then? Just go to your control panel>Security>Allow a program through the firewall. Though do note that if Network Lock is set to use Windows Firewall, it'll change the settings when you enable/disable.


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

Anybody figure out a solution to this problem. When I use EDDIE, EDDIE blocks Jdownloader connection for some odd reason. The behavior is even stranger when I access Commodo Firewall, Jdownloader appears in the Commod Firewall Rulset. When I log off, Jdownloader is still in Commodo so I remove it from the Rulset and Jdownloader connects to the internet. But when I again log on to Airvpn through EDDIE, again Jdownloader cannot connect to the internet and I find Jdownloader again in the Commodo Firewall rulset.

I couldn't find the earlier beta version, I'm currently on 2.16.3.  I went through Windows Firewall Platform and Jdownloader is not even in the rulsets. I can't figure this one out, any help would be appreciated.

Share this post


Link to post

I'm an avid user of JDownloader and I often use it with AirVPN (with Premium accounts) without issues. I am currently using 2.16.3. See if I can help you out.

@planetm115 & @tonyj  It is likely it is due to Connection Manager's ruleset in Jdownloader, I suspected it is to do with the gateway. JD is a bit weird when it come to gateway. It relies on gateway to access the network. I ran into this issue once before. Go to JDownloader>Settings>Connection Manager. In there, there is a ruleset list of connection for directing the network. There should be a line rule "No Proxy" in there. If there are other ruleset other than "No Proxy", disable them or remove them. You need to keep No Proxy rule. Restart JD and try again to see if it is working.

Share this post


Link to post

Okay, checked Connection Manager and verified one rule "No Proxy" with edit at B0. Went back to check the rulsets on WFP and nothing. Jdownloader connects fine when Network Lock is deactivated but when it's activated, no Jdownload connection and Jdownloader is on the Commodo Firewall ruleset again. I'm now thinking that either Windows 7 or Commodo blew a fuse somewhere and maybe I need reinstall one or both. But this one is just bizarre.

Share this post


Link to post
@tonyj When it come to third-party firewall, that is out of the realms the AirVPN Staff can help you because Eddie and third-party firewall, such as Commodo, don't always have a full capability. I am beginning to suspect it is likely to do with Commodo. Can you disable Commodo and try to run Eddie with Network Lock and see what happen?

The reason why I suspected Commodo is to do with Network Lock. I see that JDownloader is functioning just fine without Network Lock. And with Network Lock enabled, it have problems. That point the clue of what is going on. When Eddie's Network Lock is enabled, it routes all network traffic through Windows Firewall with strict rule policy. This forces Eddie to be tied to Windows Firewall, it a very advanced form of Kill Switch. If you have a third party firewall such as Commodo, it is likely Commodo is preventing the communication to the network because Commodo don't have the rules for this. It is like attempting to use two anti-viruses running at the same time which cause cascading effect on the computer and false positives. If you want to understand how Network Lock works, the documentation is here

If JD have issues even with Network Lock enabled and Commodo disabled, I have one more thing that I suspected as well. Possible it is the gateway setting in TAP Adapter since JD relies on gateway similar to what Microsoft Office relies on.

Share this post


Link to post
Posted ... (edited)

Removed Commodo. That didn't work. Then just installed a Windows 7 in a new drive, reinstalled Eddie, reinstalled Jdownloader. Again the same problem. So it's probably what you suspected, something to do the TAP Adapter. I just don't know where to from here.

Forgot to mention Utrorrent seems to work without an issue during the Eddie session.

Edited ... by tonyj
update

Share this post


Link to post
Then it seem it is likely the default gateway issue. Go to my comment of the post and it will lead you to the guide of how to put the default gateway in TAP, hopefully it should fix the issue with JDownloader.

If that didn't fix the issue, then it is likely the issue resides with JDownloader, I would strongly recommend you to go JDownloader support forum and seek for help if putting the default gateway in TAP didn't help. They have several posts regarding JDownloader with VPN.

Share this post


Link to post
Posted ... (edited)

That worked. I set the default gateway in the IPV4 properties on the TAP Adapter to 192.168.0.1. When I looked at my default gateway in ipconfig it was 10.0.0.1. So I don't know why one would work over another. I have a question though, when I looked at the Tap Adapter properties, the IPV6 box was checked. Is this okay?

Edited ... by tonyj

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...