Jump to content
Not connected, Your IP: 18.210.24.208

Recommended Posts

Hello,

 

     I run a small media server at home so I can listen to my music on the go.  I've decided to try running it though the VPN, but I'm not sure exactly how to do it.  These are the settings I currently have, and they don't seem to be working.   Any help at all would be appreciated.

 

The Emby server runs on two ports by default.  8096 for HTTP, and 8920 for HTTPS.

My settings on Emby show the following.

 

Local http port number: 8096

Local http port number: 8920

public http port number: 8098

public http port number: 8928

 

remote access http://my.airvpnserver.exitip :8098

local access 192.168.X.X:8096

There is also an option to specify the ip to bind to.  If I bind it to the 10.X.X.X from AirVPN, only the local access ip changes.

 

On my AirVPN settings, I have 8098 forwarded to local 8096. And 8928 forwarded to 8920. Neither of them have a green light.

My router is set to forward ports 8096 and 8920 to my computers normal address 192.168.X.X

 

Here are pictures in case they help any:

https://i.gyazo.com/e64f7e207204a9f1e8e4f16f457f177d.png

 

https://i.gyazo.com/9bc9c53feab3fe4f4324d99b8abc163c.png

 

https://i.gyazo.com/bc494db4a4a9982879505be793c40008.png

 

https://i.gyazo.com/27f6b3f63d3722f46b06df933295bcb6.png

 

https://i.gyazo.com/2f9559e99660781275cd3b52245e86b5.png

Share this post


Link to post

are you running the openvpn client on your router?  if not, no need to forward ports on the router.

I'm using the AirVPN client, so I removed the forwarding on my router. Still no change.

 

From my PC I can connect to the server using 10.4.72.46:8096, or 192.168.X.X:8096

Share this post


Link to post

 

are you running the openvpn client on your router?  if not, no need to forward ports on the router.

I'm using the AirVPN client, so I removed the forwarding on my router. Still no change.

 

From my PC I can connect to the server using 10.4.72.46:8096, or 192.168.X.X:8096

 

removing the port forwards on your router wasn't expected to fix the problem.  it's a security fix.

 

if the internal port you've assigned on your forwarded ports match what emby is looking for you should get a green light.  have you tried restarting emby?

Share this post


Link to post

 

 

I'm using the AirVPN client, so I removed the forwarding on my router. Still no change.

are you running the openvpn client on your router?  if not, no need to forward ports on the router.

 

From my PC I can connect to the server using 10.4.72.46:8096, or 192.168.X.X:8096

removing the port forwards on your router wasn't expected to fix the problem.  it's a security fix.

 

if the internal port you've assigned on your forwarded ports match what emby is looking for you should get a green light.  have you tried restarting emby?

I have been restarting Emby after every change to the network settings.  It seems like I just needed to disable the network lock on the client and now it is working and I have a green light.

However, if I try to use "http://104.254.X.X:8098/", I don't get a connection.  But if I go to that address from a different network, such as my phone on LTE, it works just fine.   Not an issue for me though.

 

I've also noticed that the ddns feature doesn't appear to be working, but this is probably an issue for another time.  If I try to ping myddnsname.airvpn.org I get "Ping request could not find host fallenemby.airvpn.org:8096. Please check the name and try again."

Changing networks/devices doesn't seem to fix the issue, so maybe this is a known problem.

Share this post


Link to post

I have been restarting Emby after every change to the network settings.  It seems like I just needed to disable the network lock on the client and now it is working and I have a green light.

However, if I try to use "http://104.254.X.X:8098/", I don't get a connection.  But if I go to that address from a different network, such as my phone on LTE, it works just fine.   Not an issue for me though.

 

 

Hello!

 

This happens because you can't access a service behind some Air VPN server from a machine connected to that same server.

 

 

I've also noticed that the ddns feature doesn't appear to be working, but this is probably an issue for another time.  If I try to ping myddnsname.airvpn.org I get "Ping request could not find host fallenemby.airvpn.org:8096. Please check the name and try again."

Changing networks/devices doesn't seem to fix the issue, so maybe this is a known problem.

 

That does not seem an issue. Simply, "your_name:8096" can't be a valid name. Maybe you mean with that ":8096" to specify some port? If so, you forget that ping uses ICMP requests (ICMP is not at transport layer, and is not at application layer): there is no concept (and no room in the datagram) of specific processes/applications end-points like ports.

 

Kind regards

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...