Jump to content
Not connected, Your IP:
Sign in to follow this  

Eddie is closed/disconnected: No internet connection AT ALL

Recommended Posts


I have this problem which is not going away since I installed Eddie.
It occurs with stable Eddie 2.10 and the new 2.11.3 beta.

Installed new windows 10 x64, no anti-virus software whatsoever, only windows firewall and windows defender (I somehow can't deactive windows defender)
I did not changed windows firewall settings. The mainboard got only 1 ethernet port. Router is working with no errors.
I did not configure the router - just installed and it worked 100%.

Cut to the chase:
Case 1:
- My internet connection is only working, when Eddie is running and I'm connected to an airvpn-server.
Whether Windows firewall is running or not, doesn't matter. Whether network lock is enabled/disabled doesn't matter.
With this, I can do everything: browse internet, listen to internet radio stream, play online games.

Case 2:
- Eddie is running but not connected to an airvpn server, network lock is deactivated; windows firewall enabled/disabled
The tap-windows-adapter V9, which was installed during the Eddie installation, is disconnected (windows diagnosis: Ethernet cable is not connected).
I can't browse website, listen to internet radio BUT I can play my online game unreal tournament 2004.
Peculiar: I can't browse or whatsoever, BUT whenever I try to load a website, the orange mainboard LED (ethernet port) begins to blink - this means it's up and working.
The green LED is always on, indicating that the hardware is working.


Case 3:
- Eddie is closed, windows firewall enabled/disabled.
Same result as in case 2, except again: UT2k4.


Eddie is starting with windows.
Even when I disable autostart and windows starts without eddie, I get same result as in case 2/3.

As I already mentioned, there is one strange exception: it's the online game I play, u2k4.
In case 2/3, I start the game, I go to the ingame tab "Servers" and the game is showing me the ut2004-servers, up and running, so I can connect to them and play online.
But the even strager thing is: case 2/3 with network locked disabled (ofc. I need to disable network lock when Eddie is up and running, or else every traffic would got blocked).
I start the game, go to "Join Game" and the "news feed" is showing me that the game can't connect to the "UT2k4  Master Server" -> "Querying Master Server: The UT2004 master server could not be reached. Please try again later."
This normally means that I'm offline and can't connect, but as already mentioned: In the other tab, servers are shown to me and I can play online.

So I thought that windows firewall/eddie set up some strange internet connection rules.
I checked the windows firewall setting and reseted them to the default settings, but nothing changed.
I checked HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Parameters\FirewallPolicy\FirewallRules, there are ~100 registry keys.
But as mentioned: I did not change anything.

I think this is not how this Eddie is supposed to work.

thanks in advance

Share this post

Link to post

Thanks for responding.
Well, I know what a dns is but I haven't changed any settings.

I found a solution: deinstalling the "TAP-Windows Adapter V9".
But without it, airvpn won't work.

An option in Eddie, to tell him that I want use the the dns-setting I got from my isp?

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...