Jump to content
Not connected, Your IP: 34.207.247.69
mandatoris

AirVPN client loose saved data after reboot

Recommended Posts

Hello there, I am running linux mint, and have installed AirVPN client from .deb package. Ive ticked whitelist servers, turn on network lock. After reboot, when I turn on  client, it loose whitelisted servers, however, preferences (network lock, run at startup) are still ticked like before. But since AirVPN is starting (I need to enter root pass to start it) I have inet connection with real IP, hence I know network lock doesnt work...

 

Is there anybody experiencing same problems? Thank You for help

Share this post


Link to post

Running fine here on a debian host. You will have to enter your root password, that is normal.  All other configs are holding fine between boots here.  Even the tunnel wrapper protocols are holding config between boots without issue.

 

How are you selecting your whitelisted servers?  I also blacklist (red X) the other servers under the country tab of Eddie.  I can change things in a few seconds but I like to have everything blacklisted EXCEPT the country or server(s) I want Eddie to use.   If memory serves me correctly, with blacklisted servers marked Eddie will pick the whitelisted ones just fine.  I select one country and let Eddie pick the best performer from that country at the time I connect.  Easy as can be.  I do switch it around by simply whitelisting a different server if I need to for a mission.

 

Network lock works fine with Eddie on linux.  I don't use it because I prefer to write my own firewall, but I know it works.  Check out the threads in the top of the forum for Eddie with linux and how to do the resolv thing.  Its not tough, but you have to do it to keep the config.

Share this post


Link to post

Hello, sorry for late reply. I still have not made this works... So, calling Eddie, You mean classic AirVPN client? Or is it standalone firewall?

I will try to explain detailed, so I have network lock on:

y8OAs.png

When disconnected, it turn inet down. But when I exit AirVPN, it is not blocking inet connection, so revealing my IP. Should I then configure firewall separately? Thanks

Share this post


Link to post

Hello, sorry for late reply. I still have not made this works... So, calling Eddie, You mean classic AirVPN client? Or is it standalone firewall?

I will try to explain detailed, so I have network lock on:

y8OAs.png

When disconnected, it turn inet down. But when I exit AirVPN, it is not blocking inet connection, so revealing my IP. Should I then configure firewall separately? Thanks

 

when you shut down the AirVPN client (Eddie) the network lock is also disabled.  It has to be or else people would be complaining that their internet "doesn't work" when the AirVPN client is shut down.

 

what you do with a firewall is up to you.  if you want the network lock always on then keep the AirVPN client running.

Share this post


Link to post

Yes I understand that, but how is it possible to have AirVPN open when I turn off pc...

The thing is when I turn on my pc, my network is ON, and until I type root pass for AirVPN my network is still exposed. So should I configure firewall to keep network disabled even when AirVPN is off?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...