Jump to content
Not connected, Your IP: 3.228.220.31
b666m

ANSWERED Ubuntu 16.04 AirVPN Client installation missing dependencies

Recommended Posts

Hi everyone,

 

I installed Ubuntu 16.04 and the installation of the 64bit AirVPN client fails.

 

That's how far I've got: install via dpkg -i then fix dependencies with apt-get -f install and then try dpkg -i again:

 

b666m@xvivox:~/Downloads$ sudo dpkg -i airvpn_linux_x64_debian.deb 
Selecting previously unselected package airvpn.
(Reading database ... 165469 files and directories currently installed.)
Preparing to unpack airvpn_linux_x64_debian.deb ...
Unpacking airvpn (2.10) ...
dpkg: dependency problems prevent configuration of airvpn:
 airvpn depends on gksu; however:
  Package gksu is not installed.
 airvpn depends on mono-utils; however:
  Package mono-utils is not installed.
 airvpn depends on libmono-system-runtime2.0-cil; however:
  Package libmono-system-runtime2.0-cil is not installed.
 airvpn depends on libmono-winforms2.0-cil; however:
  Package libmono-winforms2.0-cil is not installed.
 airvpn depends on libmono-corlib2.0-cil; however:
  Package libmono-corlib2.0-cil is not installed.
 airvpn depends on openvpn; however:
  Package openvpn is not installed.
 airvpn depends on stunnel4; however:
  Package stunnel4 is not installed.

dpkg: error processing package airvpn (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu4) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 airvpn
b666m@xvivox:~/Downloads$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gksu libgksu2-0 libpkcs11-helper1 openvpn stunnel4
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gksu libgksu2-0 libpkcs11-helper1 openvpn stunnel4
Suggested packages:
  easy-rsa logcheck-database
The following packages will be REMOVED:
  airvpn
The following NEW packages will be installed:
  gksu libgksu2-0 libpkcs11-helper1 openvpn stunnel4
0 upgraded, 5 newly installed, 1 to remove and 10 not upgraded.
1 not fully installed or removed.
Need to get 0 B/731 kB of archives.
After this operation, 5.917 kB disk space will be freed.
Do you want to continue? [Y/n]  
Preconfiguring packages ...
(Reading database ... 165481 files and directories currently installed.)
Removing airvpn (2.10) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu4) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Selecting previously unselected package stunnel4.
(Reading database ... 165469 files and directories currently installed.)
Preparing to unpack .../stunnel4_3%3a5.30-1_amd64.deb ...
Unpacking stunnel4 (3:5.30-1) ...
Selecting previously unselected package libgksu2-0.
Preparing to unpack .../libgksu2-0_2.0.13~pre1-6ubuntu8_amd64.deb ...
Unpacking libgksu2-0 (2.0.13~pre1-6ubuntu8) ...
Selecting previously unselected package gksu.
Preparing to unpack .../gksu_2.0.2-9ubuntu1_amd64.deb ...
Unpacking gksu (2.0.2-9ubuntu1) ...
Selecting previously unselected package libpkcs11-helper1:amd64.
Preparing to unpack .../libpkcs11-helper1_1.11-5_amd64.deb ...
Unpacking libpkcs11-helper1:amd64 (1.11-5) ...
Selecting previously unselected package openvpn.
Preparing to unpack .../openvpn_2.3.10-1ubuntu2_amd64.deb ...
Unpacking openvpn (2.3.10-1ubuntu2) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (229-3ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu2) ...
Processing triggers for gconf2 (3.2.6-3ubuntu6) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu4) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Setting up stunnel4 (3:5.30-1) ...
Setting up libgksu2-0 (2.0.13~pre1-6ubuntu8) ...
update-alternatives: using /usr/share/libgksu/debian/gconf-defaults.libgksu-sudo to provide /usr/share/gconf/defaults/10_libgksu (libgksu-gconf-defaults) in auto mode
Setting up libpkcs11-helper1:amd64 (1.11-5) ...
Setting up openvpn (2.3.10-1ubuntu2) ...
Processing triggers for gconf2 (3.2.6-3ubuntu6) ...
Setting up gksu (2.0.2-9ubuntu1) ...
Processing triggers for libc-bin (2.23-0ubuntu2) ...
b666m@xvivox:~/Downloads$ sudo dpkg -i airvpn_linux_x64_debian.deb 
Selecting previously unselected package airvpn.
(Reading database ... 165660 files and directories currently installed.)
Preparing to unpack airvpn_linux_x64_debian.deb ...
Unpacking airvpn (2.10) ...
dpkg: dependency problems prevent configuration of airvpn:
 airvpn depends on mono-utils; however:
  Package mono-utils is not installed.
 airvpn depends on libmono-system-runtime2.0-cil; however:
  Package libmono-system-runtime2.0-cil is not installed.
 airvpn depends on libmono-winforms2.0-cil; however:
  Package libmono-winforms2.0-cil is not installed.
 airvpn depends on libmono-corlib2.0-cil; however:
  Package libmono-corlib2.0-cil is not installed.

dpkg: error processing package airvpn (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu4) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 airvpn

It seems like some of the needed mono packages were deleted in 16.04 - here's just one of them for example:

http://launchpad.net/ubuntu/xenial/amd64/libmono-system-runtime2.0-cil

 

Please help! 

 

Best regards!

Share this post


Link to post
there is help for the problem:
 
Please install the following on the console:
 
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
sudo apt-get update

and then the following are running:

 

sudo apt-get install mono-complete

then can AirVPN completely install 

 

Share this post


Link to post

Some packages in Ubuntu are not ready until the official release.

You will have to wait until 16.04 is released.

 

http://packages.ubuntu.com/search?suite=default&section=all&arch=any&keywords=libmono-winforms2.0&searchon=names

 

You can try instead to manually install libmono-system4.0, 2.0 is being deprecated, but maybe

it will be backported after the official release.

Replace all *2.0 packages with *4.0 and try again.

 

http://packages.ubuntu.com/xenial/libmono-system-runtime4.0-cil


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

The package libmono-system-runtime4.0-cil is already installed on my system.

However the package requested as dependency is 2.0 - I'm afraid that's hardcoded.

 

I also installed MonoDevelop and VersionControl and checked out the AirVPN client Git.

But when I hit to "Debug x64" the referenced 2.0 mono packages are marked as not available.

 

Sadly I couldn't figure out how to swap the packages yesterday - maybe I will take another look today.

I don't have any problem in building and running my own version of your client as long as I have something working... :')

Share this post


Link to post

Magically I can right-click "UI.Linux" and select "Run Item".

The client starts as expected and everything seems to be fine for some minutes now.

 

But when I go to ./trunk/src/bin/x64/Debug and try to run the UI.Linux.exe via mono (like described on the mono homepage) the missing 2.0 mono dependencies are striking again.

The program won't start.

 

If someone can help on how to make these 2.0 dependencies errors go away that would be great!

Any hints?

 

If not I guess I have to stay with this ugly solution until 16.04 gets all the needed packages back or the AirVPN client gets an update to be compatible with 16.04 if the packages remain deleted.

Share this post


Link to post

You might want to try the highly experimental branch, not announced officially, here:

https://github.com/Clodo76/airvpn-client

 

This is the bleeding egde branch of the Eddie client.

There are some slight adaptations to new library versions in it.

But as a beta Ubuntu user you are probably aware of broken things


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

Is there any solution to this? I am also running Ubuntu 16 and cant get the client to work.

Share this post


Link to post

Glad I found this.  I was about to click "Upgrade" when I saw AirVPN would be removed.  I'll be hoping for official support for 16.04 soon!  Thanks, Ken.

Share this post


Link to post

Yup I just upgraded to Xubuntu 16.04 and sure enough I have the same problem. I read the package removal issue during upgrade and yet I still did it. I sure hope a fix is introduced soon.

Share this post


Link to post

Hello,

 

please run the portable version NOT requiring Mono.

 

Kind regards

I can confirm that the portable version without Mono runs on 16.04. You have to start from terminal and be sudo first. (sudo airvpn will not work, but sudo su and then ./airvpn does)

 

Is there going to be an update for the deb anytime soon?

Share this post


Link to post

I just tried the portable version on 16.04.  When I get to the terms and conditions page it locks up.  Sometimes it locks up my entire desktop and I must reboot.  So I would not say that the portable version works for me.

Share this post


Link to post

Maybe AIR will one day address this issue by releasing a new version of Eddie that is gonna work with Ubuntu 1604. But i fear that this is not on top of their agenda, as not many people are using Linux. The majority sticks with Windows, and very few VPN poviders offer a Linux client at all.

 

So AIR has quite an edge here.

 

Should you finally manage to get the portable version working, i can tell that it is just the same as the non-portable version. It should work on Ubuntu 1604, please check if you have installed all the necessary dependencies and system updates.

 

Regards

 

Fox

Share this post


Link to post

With the upcoming and long-awaited Mint 18 riding on 16.4 LTS's skeletal coattails I was hoping AirVPN would have had this covered already.

 

Stuff suggested earlier to just run the Portable version, but is that the long-term solution?

 

The Github repo for Eddie hasn't seen commits since July 31 last year.

Share this post


Link to post

I followed the blog post abdorabih linked and it works great with 16.04. I guess this is resolved!

Share this post


Link to post

After some experimenting, I found this the best set-up for hassle free use of Ubuntu 16.04, using only the GUI:

 

-install nautilus-admin (the new software center doesn't work well for me, so I use Synaptics to install this and other software)

-reboot or log out & in again. If you get a notification to restart the file manager; do so

-download the zip file with the PORTABLE AirVPN client for Linux WITHOUT Mono

-extract the files to a folder of your choice.

 

To run AirVPN:

-you right click on the folder containing the files and choose: Open as Administrator

-in the window that opens, you double click the AirVPN file. You can close the window after the AirVPN dialog box appears

 

This works for me without any crashes or freezes whatsoever.

Share this post


Link to post

Any ideas when this works on ubuntu 16.04? Always got broken packages etc problems and client dissappears on update/upgrade.

Share this post


Link to post

Any ideas when this works on ubuntu 16.04? Always got broken packages etc problems and client dissappears on update/upgrade.

Hello !

 

I've heard talk that a new edition of the Eddie client is currently in alpha, if that means anything


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post


Link to post

Any ideas when this works on ubuntu 16.04? Always got broken packages etc problems and client dissappears on update/upgrade.

Hi- Have you seen my earlier post?

 

 

Hello there,

If you have been struggling to install AirVPN client after upgrading to Ubuntu 16.04 LTS like me,  don't despair,  go to the site below and follow the instructions .  I have just tried it and it WORKS. 

 

https://www.bestvpnforyou.com/installing-airvpn-client-on-ubuntu-16-04-and-14-04/

 

I consider this issue fixed. (well , at least for me)

Cheers

Share this post


Link to post

I can confirm Abdorabih's solution works, although "mono" seems to hog quite a bit of resources (every 5 sec or so).

My preferred solution as of now is using the AirVPN router package, though this requires alot more work and a compatible router.

Share this post


Link to post

The portable version works just fine under Linux Mint 18 64 bit.

Share this post


Link to post

I find the portable version sluggish. Here is another workaround I find on the Internet.

 

https://github.com/AirVPN/airvpn-client/issues/31

 

 

Yes, that's the Eddie sources repository. :)

 

Alternatively you might like to upgrade to Eddie 2.11.3 beta which is compatible with Mono 4 and runs very swiftly, even on Ubuntu 16.04. It features tons of bug fixes on the UI and much more:

 

https://airvpn.org/topic/18625-eddie-211beta-available/

https://airvpn.org/services/changelog.php?software=client&format=html

 

Kind regards

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...