Jump to content
Not connected, Your IP: 3.236.145.153

Recommended Posts

I have installed and got AirVPN working great on Windows 10.  I have a Plex media server on the same pc but the Plex remote connection goes through the VPN.  I want it to go outside the VPN and all other traffic on the pc go through the VPN.  I have been able to get Plex to connect when the VPN is disconnected and I have also been able to get Plex to connect while VPN is connected but traffic goes through the VPN.  I want to be able to connect to the VPN but all Plex traffic to travel outside the VPN.  I need help!

Share this post


Link to post

Ok, you're going to have to let us know how you are connecting to Air (router, Eddie, etc..) and what OS you're using. What you're describing is splitting your connection so that some traffic is tunneled and some is not. There are already a few guides on here for doing this, depending on how you're connecting to Air's servers.

Share this post


Link to post

agent_mulder, you need to find an open port to forward on the airvpn.org website and set that port on the plex remote server settings.

 

airvpn.png

 

plex.png

Share this post


Link to post

For others looking for this fix... I found this application that does a great job.  You just install it click save configuration and install as a service.  Then setup your router to forward the port 32400 to your local IP address and it should work just fine.  

I finally got it working and now Plex is routed outside the VPN and using my local network as well when streaming inside my house.

 

https://thronic.com/products/VPN%20Bypass/

Share this post


Link to post
On 2/27/2016 at 2:08 PM, agent_mulder said:

I would really like to know how to solve this.  I have the same setup and problem.  However, I cannot get Plex remote access to work when VPN is connected.  How did you accomplish that?

ME TOO.

Share this post


Link to post
On 2/17/2020 at 8:24 PM, go558a83nk said:

For plex remote access you either need to forward the port through the VPN or you need to setup, in eddie, plex.tv to go outside the VPN tunnel.

Can you post documentation on how to do this - this sounds like something I need to do.

Share this post


Link to post
On 1/27/2021 at 2:44 AM, Umpa said:
On 2/17/2020 at 2:24 PM, go558a83nk said:

For plex remote access you either need to forward the port through the VPN or you need to setup, in eddie, plex.tv to go outside the VPN tunnel.

Can you post documentation on how to do this - this sounds like something I need to do.

in the settings of Eddie there should be a section for adding routes...in the VPN tunnel or outside the VPN tunnel.

Share this post


Link to post
On 1/29/2021 at 6:24 PM, go558a83nk said:

in the settings of Eddie there should be a section for adding routes...in the VPN tunnel or outside the VPN tunnel.
Yes I looked at that setting, but I don't know what to put in there ?
Do I put my real ip in there ? 
Thanks In Advance.

Share this post


Link to post

I have the same problem. Unable to access Plex remotely even after setting port forward via AirVPN. I have Plex (and ChannelsDVR -same problem) running on a Qnap NAS . My router is an Asus RT-AC68 so on the router I have set the Qnap on AirVPN , all other connected devices go through ISP. Whatever I've tried I cant connect and port forwartding doesnt work. I tried PFNetwork Utilities and that reports the ports are closed. If I turn off the VPN to the QNap everything works.
Is there any way I can route the Plex and Channels DVR servers to bypass the VPN?
Thanks

Share this post


Link to post
Posted ... (edited)

If you are using your routers internal VPN client to route specific clients through the VPN by using policy rules, you need to forward those ports also to your internal clients (e.g. the plex server).
In my case this cannot be done by using the GUI, i have to ssh into it.

Iptables on the router:

iptables -I FORWARD -i tunX -p udp --dport 11111 -j ACCEPT
iptables -I FORWARD -i tunX -p tcp  --dport 11111 -j ACCEPT
iptables -t nat -I PREROUTING -i tunX -p tcp --dport 11111 -j DNAT --to-destination 192.168.1.xxx:11111
iptables -t nat -I PREROUTING -i tunX -p udp --dport 11111 -j DNAT --to-destination 192.168.1.xxx:11111

-11111 is your AirVPN port
-192.168.1.xxx is your local client (e.g. plex server)
-tunX is the interface used by your router for the VPN connection.
-Please note that you cannot access your exposed service while being connected to the same VPN server! (If you want to access it from the same machine, use you internal IP).

You probably also want to add these iptable rules to your startup script (e.g. jffs) in case you need to reboot the router.

If you are using any kind VPN software locally (e.g. Eddie, OpenVPN Connect), there is no need to do port forwarding on the router.
Just make sure you are using 1) the correct Air port and 2) your are listening on the right IP, which is typically the internal IP of the VPN tunnel (10.xx.xx.xxx). You could also use 0.0.0.0, but this will expose the port to all of the routers clients as well (your lan network) if you do not prevent this by using VLANs, firewall rules or else.

In any case it is important to distinguish between Entry- and Exit-IP. Always use the Exit-IP for connecting to your service.

Edited ... by buy airvpn

Share this post


Link to post

Thanks for the instructions but I'm still having problems. I used the IP tables ammended for my setup ,added a startup scrip to Jffs and rebooted.
No change. Clearly still doinge something wrong but can't see what.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...