Jump to content
Not connected, Your IP: 34.237.51.159
Ant-N

Need to have port 8333 open, forward port don't work?

Recommended Posts

Hi,

 

I want to run a software that require port 8333 open. (bitcoin node)

I have look at port forwarding option, set up port 8333 and I get the reply "port already used"

I am a newbie.. maybe there something I don't understand,

Is it not possible to use software that need specific open with a VPN?

Ps: I need to open port 8333 and 18080

Share this post


Link to post

Bitcoin does't require port 8333. You can use another port and configure it either in the configuration file or as a command line option.

 

But generally, yes, it is not possible to use software that needs a specific open port. At least if you are not very lucky and nobody has claimed that port yet.

Share this post


Link to post

I assume that somebody else is already forwarding this port and it is not possible to forward one port to multiple people.

 

Is it possible to change the port in your software and use another port? If this is not possible you might try to open another port at the VPN server and try to map it to the port you need locally.

 

You can map a remotely forwarded port to a different local port: this is useful for a variety of cases, for example when your service listens to a port lower than 2048 or when it is already reserved.

https://airvpn.org/faq/port_forwarding/

Share this post


Link to post

This means that this port is already in-use by some other premium member.

The good news is that you can configure any port to run your bitcoin node, while 8333 is the default

option, it doesn't mean that any other port will not work.

 

Check this node for example:

https://bitnodes.21.co/nodes/217.172.32.18-20993/


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

Thanks for your reply I will do that,

Does this mean all user use the "exit server" as one computer? 
And if I look for another exit server I will find one with port 8333 not used by another user?
Trying to understand how VPN work

 

Share this post


Link to post

Well, this is not how VPN works but how AirVPN works.

 

If you reserve a port it is reserved on all exit servers. Frankly, it would be quite a mess otherwise.

Share this post


Link to post

Just map your internal 8333 to any forwarderd port you can find, might take some time to find a free port.

Here  Bitcoin core accepting in/out connections  with 8333> 53334 and listed as full-node at bitnodes after a while.

DO NOT configure port forwarding on your router...  ;-)

Share this post


Link to post

Hi,

 

It's my understanding that if you do not run the bitcoin node under port 8333 then your node is mostly ignored by other nodes who prioritize port 8333. You will still get some connections and bitcoin itself  will work... but it's not really contributing to the network or acting as a full node should be.

 

See here: https://bitcointalk.org/index.php?topic=617305.0

 

I notice that you can set up a local port when doing the port forwarding... however I'm unsure if that would help because the other nodes would still be connecting (or not connecting) to the 'wrong' port?

 

Is there something I am missing? I would like to be able to make sure my full node is running to it's fullest potential.

 

Thanks in advance

Share this post


Link to post

Sorry to bring this back from the dead, but Thone is absolutely correct about this. I have been setting up full nodes since the onset of BTC, and this is most definitely an issue. So basically... if you weren't the FIRST airvpn member to forward port 8333 - you are SOL. Yes it will still connect, but much much worse connection and the vast majority of other users and nodes, will ignore your node. It does the bitcoin network more of a dis-service than anything.

 

It is pretty lame that ONE SINGLE airvpn user gets access to use this, leaving everyone else SOL. There has the be a more practical way. Why not add a feature to have the port enabled GLOBALLY. Or make it a "question" to answer when you initially sign up. If you want 8333 forwarded, then you click "yes" and get added to the appropriate group. if  you say "no", you get added to the other group, whom doesn't require forwarding for this port. 

 

Just my two cents.

Share this post


Link to post

If you can't change the port that the node uses without connection problems, then there needs to be better implementation in the Bitcoin software so that you can change ports with no issue. I don't think it's possible for more than one user / application to share a port.

Share this post


Link to post

It is pretty lame that ONE SINGLE airvpn user gets access to use this, leaving everyone else SOL. There has the be a more practical way. Why not add a feature to have the port enabled GLOBALLY. Or make it a "question" to answer when you initially sign up. If you want 8333 forwarded, then you click "yes" and get added to the appropriate group. if  you say "no", you get added to the other group, whom doesn't require forwarding for this port.

 

There might be a more practical way but it's also a more complicated one. If you forward a port, the port will be forwarded on every server specifically for you. Now imagine someone else could forward the same port to his/her internal IP. Question: Where do packets travel if they don't have brains?


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

did this ever get solved? 

 

I'd like to run my bitcoin node while using AirVPN otherwise what the point of using/paying for AirVPN if I have to disconnect in order to keep running my Bitcoin node?

Share this post


Link to post

did this ever get solved? 

 

I'd like to run my bitcoin node while using AirVPN otherwise what the point of using/paying for AirVPN if I have to disconnect in order to keep running my Bitcoin node?

 

 

That's a "non-problem". Just forward remotely a random port from your account port panel and configure your Bitcoin client to listen to that port.

 

Important note: do not remap the remotely forwarded port to a different local port (in this case it would not work properly due to how Bitcoin works).

 

Kind regards

Share this post


Link to post

 

did this ever get solved? 

 

I'd like to run my bitcoin node while using AirVPN otherwise what the point of using/paying for AirVPN if I have to disconnect in order to keep running my Bitcoin node?

 

 

That's a "non-problem". Just forward remotely a random port from your account port panel and configure your Bitcoin client to listen to that port.

 

Important note: do not remap the remotely forwarded port to a different local port (in this case it would not work properly due to how Bitcoin works).

 

Kind regards

 

I am very much a layman at this stuff... I went to the client section and 'forwarded a port' to my local port that is required for a bitcoin node... when I reconnect AirVPN, it cuts off my node from receiving incoming connections.

 

Can you possibly (if you have a second) explain specifically what I need to do?

 

thanks

Share this post


Link to post

 

 

did this ever get solved? 

 

I'd like to run my bitcoin node while using AirVPN otherwise what the point of using/paying for AirVPN if I have to disconnect in order to keep running my Bitcoin node?

 

 

That's a "non-problem". Just forward remotely a random port from your account port panel and configure your Bitcoin client to listen to that port.

 

Important note: do not remap the remotely forwarded port to a different local port (in this case it would not work properly due to how Bitcoin works).

 

Kind regards

 

I am very much a layman at this stuff... I went to the client section and 'forwarded a port' to my local port that is required for a bitcoin node... when I reconnect AirVPN, it cuts off my node from receiving incoming connections.

 

Can you possibly (if you have a second) explain specifically what I need to do?

 

thanks

 

well, you did the opposite of what Staff said to do.   Reread what Staff wrote and try again?

Share this post


Link to post

It's a better idea just to use an AirVPN-forwarded port to the local port 8333.

This isn't ideal in case Bitcoin does not work like this, for example the client thinking it is running on 8333, therefore broadcasting that unroutable port.

 

He needs to configure a forwarded port (e.g. 12345) and forward it to the SAME local port (12345 in my example). He then needs to set his Bitcoin client to listen on 12345 instead of 8333. He should Google how to change the listening port on his Bitcoin client.

Share this post


Link to post

 

It's a better idea just to use an AirVPN-forwarded port to the local port 8333.

This isn't ideal in case Bitcoin does not work like this, for example the client thinking it is running on 8333, therefore broadcasting that unroutable port.

 

He needs to configure a forwarded port (e.g. 12345) and forward it to the SAME local port (12345 in my example). He then needs to set his Bitcoin client to listen on 12345 instead of 8333. He should Google how to change the listening port on his Bitcoin client.

 

I remember having nothing but hassles trying to force custom ports with Bitcoin and DROP all other connections, as opposed to AirVPN port forwarding to local 8333 which was a lot faster and made connections properly and through the proper interface.

Share this post


Link to post

Bitcoin core will only connect to other client on port 8333, so if you use a different port and forward it, you will not receive any incoming connections. There is, however, a method you can use to receive incoming connections when you cannot open port 8333. The solution to this problem is to use tor, and host a tor hidden hidden service on your computer, which will then connect to port 8333. A cool feature of bitcoin core:

 

"Starting with Tor version 0.2.7.1 it is possible, through Tor's control socket API, to create and destroy 'ephemeral' hidden services programmatically. Bitcoin Core has been updated to make use of this."

 

If you cannot get cookie authentication to work (for bitcoin core to be able to connect to tor and control it), old-fashioned password authentication will work fine too.

These days, bitcoin core has some good built-in support for tor, and I will provide a couple links which may be helpful. Setting up a hidden service is actually easier than it sounds

 

https://github.com/bitcoin/bitcoin/blob/master/doc/tor.md

 

https://en.bitcoin.it/wiki/Setting_up_a_Tor_hidden_service

 

https://medium.com/@lopp/how-to-run-bitcoin-as-a-tor-hidden-service-on-ubuntu-cff52d543756

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...