Jump to content
Not connected, Your IP: 34.204.169.76

Recommended Posts

Hello,

 

Sometimes, when I open up Youtube, I get redirected to the German or Irish site. This would normally not be an issue, but due to German copyright laws, many channels and videos can't be played (most notably, VEVO).

 

I ran a Traceroute between my computer and youtube while connected to AirVPN (Gianfar, Netherlands) none of the hops resolve to a German or Irish IP address. 

 

Normally this issue can be fixed by disconnecting from AirVPN and reconnecting to another server. Since it's not a permanent issue, it's more of an annoyance than anything else, but I'd still like to see if there's a fix.

 

Thanks a lot for your help!

 

Share this post


Link to post

Hi, just want to chime in that I see the same problem - connected to a NL server, but getting the youtube "not available in your country" notice. 

 

traceroute to youtube-ui.l.google.com (64.15.117.52), 64 hops max, 52 byte packets

 1  10.4.0.1 (10.4.0.1)  74.007 ms  58.167 ms  57.166 ms

 2  hosted-by.global-layer.com (109.202.101.65)  58.488 ms  57.388 ms  57.893 ms

 3  openpeering.nikhef.nl-ix.net (193.239.116.17)  59.561 ms  60.430 ms  65.176 ms

 4  telecity-cr.openpeering.nl (217.170.0.243)  61.115 ms  60.381 ms  59.471 ms

 5  nlix-rtm-02.google.com (213.207.9.197)  61.022 ms  61.088 ms  60.872 ms

 6  * * *

 7  * * *

 8  * * *

 9  * * *

Share this post


Link to post

So from reading around the forum and other places, I've found that what's most likely happening is that there are several hops between your computer, AirVPN entry servers, AirVPN exit servers and YouTube servers. One of the intermediary hops may be located in, or could at least be resolved to, Germany. I have not hard evidence for this, other than the fact that choosing a new server in the same country (NL for example) and clearing the browser cache will some times make YouTube change its location estimate. It would still be interesting to see if someone on the AirVPN team can shed light on this though...

 

If this is a persistent issue, I would also recommend looking into other avenues that Google may use to get your real location. The steps below should be treated as public brainstorming and not a fool-proof guide, but might give you a few ideas of what to investigate as well.

 

1) Activate AirVPN network lock and confirm the function by checking https://ipleak.net/. Also make sure to check that you're not leaking WebRTC requests on this site.

2) Uninstall Google programs on your computer or at least disable their update services.

3) Change the System and User Locale in your OS. For examples concerning Windows 8, see this Stackexchange thread.

4) Change the locale in Firefox:

  • Open about:config in the address bar
  • Set general.useragent.locale to en-US
  • Set browser.search.countryCode to US
  • Set browser.search.region to US
  • Set browser.search.geoip.url to 127.0.0.1
  • Note: I'm changing it to US because in general, there are few content restrictions for the US. You can of course set another country or region.

5) Disable Geolocation:

  • Open about:config in the address bar
  • Set geo.enabled to false
  • Set geo.wifi.uri to 127.0.0.1
  • Note: This will disable geolocation entirely. If you use it regularly, (although why would you through a VPN?) you might want to skip this. Mozilla says that firefox does not send out or request your location without your explicit approval, but I've seen a decrease in the number of occurrences like the one in the OP after disabling it. Probably pure imagination, but I've left it in here just in case.

6) Install the uBlock Origin add-on for Firefox. Blocking ads is a good idea in the first place, but Google runs a lot of the advertising scripts on the internet and if you swap between using a VPN and not using it, your computer might still be recognized and placed in its "proper" location by Google. This also applies if you regularly use a German VPN server and then switch to use YouTube.

 

7) Block unwanted hostnames using a Hosts file. This is the one that I use and it works by telling Windows to redirect the specified hostnames back to yourself (localhost). The hosts file is read before the DNS is queried and will work for ALL applications regardless of whether you use a VPN or not.

 

 

I've done the items above on my computer and I've seen a dramatic decrease in the number of times YouTube has placed me anywhere except in the location of my VPN. That's far from conclusive evidence, but since there have been no conclusive solution posted, I hope this might help someone with the same issue.

Share this post


Link to post

I had this problem on Diphda (NL) — YouTube and Blogspot send me to the German version. Switching to Aludra (CA) and reloading the page fixed the issue. (I'm actually in USA.)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...