Jump to content
Not connected, Your IP: 3.226.251.81

Recommended Posts

Hi I tried to forward 2 ports so I could use a fileshare program. I followed the scant instructions and forwarded 2 ports and used those port numbers in the program. This does not work, I tried without VPN and forwarded ports on router to test an that works ok. I have no clue as to what to input into the local port, I tried a port I opened in my router, that didn't work (used different port as told to) seems the instructions are for someone who all ready knows what to do. It took me 2 days to download the client,one day spent looking for Eddie the other going around in circles looking for the download section.

 

Any help here please, I'm sure it's the local port I need to get right. Thanks

Share this post


Link to post

You don't need to forward anything in your router, at all. If you have any entries there, delete them for security. 

 

Go to the Client Area > Forwarded ports. Choose a port number (there's a grid of ports, showing all taken and free ports, available at the bottom of the page if you click 'View the graph'). Enter your chosen port number into the box at the top and click 'Add'. If you're not bothered about the port number you use, and/or don't need blocks of ports (the tool can help you find a block of free adjoining ports) then you can just go ahead and hit the 'Add' button without doing anything else, and Air will generate a port and add it for you. Simple.

 

port-enter.png

 

Once you have the port added successfully, or have one you prepared earlier, open up your file sharing program. I'll use qBittorrent for ease but they are all very similar. Go into its settings and find the section (for example 'Connection' or 'Network') which requires the listening port. Enter here the port you forwarded in Air's interface. Like so:

 

port-settings.png

 

Note that any settings for UPnP and/or NAT-PMP should not be selected. They present a possible security risk, and you don't need them. They are for forwarding ports through your router, not the VPN. We want to keep our traffic inside the VPN only. Once this is done restart your client (for completeness, might not be necessary depending on the client). Now try a download. You should see that you are now connectable, usually signified by a green symbol (qBittorrent, Deluge, uTorrent etc). 

 

ports-connected.png

 

You can check connectivity in several other ways. You would need to ensure you were connected to the VPN and your download client was open at the time for it to work (else there would be nothing listening on the forwarded port and it would appear closed). 

 

1) You can go back to the Forwarded ports section of Air's Client Area. Find the forwarded port (in this example it's 22222) and click the little 'Test' button next to 'TCP Test'. If your icon shows green you are all set. Make sure you click the 'TCP Test' button in the right box if you are connected with more than one client. If you have two PCs connected at a time, they will each show up as connections in this section of Air's interface. You would need to click the test button for the connection you are testing else it will fail.

 

2) You could also go to a service such as CanYouSeeMe. It will show the IP of your VPN connection (provided you're connected properly) and give you the option to enter a port to test. As before, ensure your client is open and set up with the required port before proceeding, else it won't work. Once you're ready, enter your forwarded port (again in this example it's 22222) and then click 'Check port'. 

 

ports-canyouseeme.png

 

You should see a 'Success!  I can see your service on [YOUR IP] on port ([YOUR PORT]). Your ISP is not blocking port [YOUR PORT]'.

 

If you have any more issues feel free to post. I think you've just been over-complicating things.

Share this post


Link to post

@FromtheWalls Yes it comes up regularly. I'd be happy for Staff to reuse it in any way they wish.

 

@Tuco99 So you have a forwarded port in the Air cilent area, and have entered it into the torrent application. Did you make sure any boxes for 'random ports each start' was not checked? Does the client report it is listening on the port? If you are connected to AirVPN, have the port listed in the client area, and entered correctly in your client there shouldn't be a problem. OpenVPN tunnels through firewalls and doesn't use the features on your router, so it should be working.

 

What program are you trying to get working exactly?

What does it say in its log tab/window?

What is your operating system?

How are you connecting to AirVPN and with what versions of the given software you're using?

Have you got the program running while connected to the VPN, when you attempt to check the port in Air's forwarded ports section and canyouseeme.org?

 

Answer those and we'll help if we can.Usually in these cases it's a simple error on the part of the user, often something so 'obvious' it gets missed at first.

Share this post


Link to post

@rainmakerraw:

 

Thanks for a most detailed post on port-forwarding. I have completed all the steps listed in your post and have had port-forwarding up and running for a while now but it has suddenly stopped working. Nothing has changed in my OS or torrent client config. I have tried using another port but it is still the same. Here are some screencaps:

 

 

 

 

 

 

 

 

 

As you can see, both TCP Test in Air and CanYouSeeMe's checker still timed out. I made sure that the torrent client was running:

 

 

 

Do you have any suggestions? I am at a loss what to do next. It seems all the proper steps have been taken and still there is no port-forwarding.

 

Thanks.

 

 

You don't need to forward anything in your router, at all. If you have any entries there, delete them for security. 
 
Go to the Client Area > Forwarded ports. Choose a port number (there's a grid of ports, showing all taken and free ports, available at the bottom of the page if you click 'View the graph'). Enter it into the box at the top and click 'Add'.
 
Once you have the port added successfully, or have one you prepared earlier, open up your file sharing program. I'll use qBittorrent for ease but they are all very similar. Go into its settings and find the section (for example 'Connection' or 'Network') which requires the listening port. Enter here the port you forwarded in Air's interface. Like so:

 

...
 
Note that any settings for UPnP and/or NAT-PMP should not be selected. They present a possible security risk, and you don't need them. They are for forwarding ports through your router, not the VPN. We want to keep our traffic inside the VPN only. Once this is done restart your client (for completeness, might not be necessary depending on the client). Now try a download. You should see that you are now connectable, usually signified by a green symbol (qBittorrent, Deluge, uTorrent etc). 
 
ports-connected.png
 
You can check connectivity in several other ways. You would need to ensure you were connected to the VPN and your download client was open at the time for it to work (else there would be nothing listening on the forwarded port and it would appear closed). 

 

...

 
You should see a 'Success!  I can see your service on [YOUR IP] on port ([YOUR PORT]). Your ISP is not blocking port [YOUR PORT]'.
 
If you have any more issues feel free to post. I think you've just been over-complicating things.

Share this post


Link to post

Program is winmx

OS is win7 64

I am connected to airvpn via software from this site.

When not using VPN and forward ports on router winds works fine.

Besides when I am at the port forwarding section on this site and select any port and then test it,it never works all ways error 110 timed out.

Looks like the port is not been forwarded,

Share this post


Link to post

@TuttiFrutti Have you set qBittorrent to bind to the tun0 (Linux) or Ethernet 2 (Windows) interface? Try that, restart the app, test the forward and report back. I'm guessing from the front rendering that it's a Windows box. Just make sure you're connected via Eddie with network lock active, and that the IP you're testing matches your current VPN public IP. 

 

@Tuco99 As per generic advice, make sure you have network lock active (to rule out leakage) and if WinMX allows it bind the connections to the Ethernet 2 interface (that's the VPN unless you already had two NICs, in which case it'd be Ethernet 3 etc etc). Make sure you don't have the VPN port forwarded on the router and try again. After that I'm not sure what to suggest, sorry.

Share this post


Link to post

So after reading the network lock isn't an emergency off switch (should be called safe/unsafe mode),and it should be on I found out it would not connect in TOR mode, yet when I switched to udp mode TOR worked.

I tried to reload a new config but there isn't a way to do this? Went to get the latest client from github and could not find the download button.I have a local area connection 2 and 3 extra to what I had and have no clue if these are correct. I'm sort of pc savvy and never had problems making stuff work, but this is fubar

Share this post


Link to post

@rainmakerraw

 

@TuttiFrutti Have you set qBittorrent to bind to the tun0 (Linux) or Ethernet 2 (Windows) interface? Try that, restart the app, test the forward and report back. I'm guessing from the front rendering that it's a Windows box. Just make sure you're connected via Eddie with network lock active, and that the IP you're testing matches your current VPN public IP. 

 

Thanks for replying.

 

Yes. It is set to Ethernet 2. It has been running problem free for quite a while before this fault suddenly popped up. Network lock is active. IP matches VPN public IP.

 

I have done further testing since my last post:

 

1.   Uninstalled qbittorrent and reinstalled after deleting all config files in its app folder. It worked for a couple of days (green light in qbittorrent) but after that the fault reappeared (yellow light) and the specified port cannot be detected again.

 

2.   While the above was ongoing, I tested the port with a port listener utility (after exiting all file sharing programs) and both canyouseeme.org and AirVPN's Test TCP confirmed the port was open. This remains true until now.

 

My suspicion is that for some reason, something is blocking qbittorrent from opening the port and even though its log shows everything has been set properly, the port is not open. I am unable to explain why it worked for a couple of days after a fresh install before losing direct connection again. I do not know why the port listen can trigger the open port at any time but not qbittorrent.

 

Any ideas?

 

Thanks.

Share this post


Link to post

@rainmakerraw Quick refinement to your tutorial would be to tell users to just click the "Add" button instead of finding a free port. Clicking the "Add" button automatically picks a random free port.

Share this post


Link to post

So after reading the network lock isn't an emergency off switch (should be called safe/unsafe mode),and it should be on I found out it would not connect in TOR mode, yet when I switched to udp mode TOR worked.

I tried to reload a new config but there isn't a way to do this? Went to get the latest client from github and could not find the download button.I have a local area connection 2 and 3 extra to what I had and have no clue if these are correct. I'm sort of pc savvy and never had problems making stuff work, but this is fubar

 

Make sure the interface you're binding to is the TAP adapter that the VPN is using. If you have 'extra' ones you don't recognise it could be anything from you missing the real TAP adapter to malware. Take a closer look.

 

Any ideas?

 

Thanks.

 

Sorry mate I'm about out of ideas unless you happen to have a local firewall that is blocking the incoming connections. Try disabling your software firewall / AV for a few moments and see if that changes anything. If not I'd (respectfully) suggest you contact support as I'm out of ideas without being in front of the machine. Sorry. 

 

@rainmakerraw Quick refinement to your tutorial would be to tell users to just click the "Add" button instead of finding a free port. Clicking the "Add" button automatically picks a random free port.

 

Good call. I did consider it but since I like to get blocks of ports and I'm superstitious about numbers I decided to go into details. I'll add it in now you've suggested it, as I really shouldn't have left it out. Cheers.

Share this post


Link to post

@rainmakerraw

 

Sorry mate I'm about out of ideas unless you happen to have a local firewall that is blocking the incoming connections. Try disabling your software firewall / AV for a few moments and see if that changes anything. If not I'd (respectfully) suggest you contact support as I'm out of ideas without being in front of the machine. Sorry.

 

No worries. Could you tell me which version of qbittorrent are you using? I'm thinking it might be a client problem.

 

Thanks.

Share this post


Link to post

I'm running the latest version v3.2.3 which I complied from source on Debian. They have updated the Ubuntu PPA now, and added a DMG for Mac OS X. Windows users would be better to download the x64 build from the forum instead of the x86 version on the downloads page. There is a bug in the x86 version causing a crash when the host disk cache is full. The x64 build is made by one of the site's administrators and is made through Github so it's entirely safe.

Share this post


Link to post

Hi, I'm new to AirVPN and I'm just trying to set up the best possible config for p2p.
Right now it all works as it should, but for one thing: as I uncheck UnPNP/NAT-PMP on QTorrent's preferences, download performance drops from 650K to 450K.
I guess it's normal, but I want to be sure this is the way it should be.

Thanks

Share this post


Link to post

Hi.

I have port forwarding set up correctly to my home server.

 

Question is: if I have 2 or more sessions active (one with my home server, one with my phone, one with my notebook for example), how can I specify which device the port should be forwarded to?

(I always want it to be my home server).

 

Thanks in advance :-)

Share this post


Link to post

Old thread, but still relevant.  I'd like to add something in case anyone in future finds it helpful.  

 

If you are on Windows 10, have tried all of the above, have bound your connection in qbittorrent to the AirVPN connection, but are still unconnectable to your tracker/canyouseeme, and the TCP Test in AirVPN Client Area is not green, you have 1 more step to take

 

  • Open the Windows Defender Security Area 
  • Select "Firewall & Network Protection"
  • Select "Allow an app through the firewall"
  • Select "qbittorrent"
  • Select "Change Settings"
  • and make sure both Private and PUBLIC are selected (by default, the AirVPN network is created as a Public Network)

 

Run your tests again, all should work 

Share this post


Link to post

Hi.

I have port forwarding set up correctly to my home server.

 

Question is: if I have 2 or more sessions active (one with my home server, one with my phone, one with my notebook for example), how can I specify which device the port should be forwarded to?

(I always want it to be my home server).

 

Thanks in advance :-)

Hello!

 

If I understand your situation correctly, I think the answer to that is that it's based on where you set up a client which is listening on the port you opened, not on a per device basis. It's only when something is listening on the other end, that the TCP test works for example. So if on the Air site you forward XYZ port and then run a torrent client on your notebook which listens on the same XYZ port, then it gets forwarded to your notebooks client. But multiple clients could listen on the same forwarded port. But besides that, it's possible for you to forward up to 20 ports anyway, if you wish to keep things separate for some reason - and you can use the DDNS field as a label/name field, to remember what belongs where .


Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.


Tired of Windows? Why Linux Is Better.

Share this post


Link to post

Windows firewall is only opening ports automatically for software when using UPNP, meaning, requests from your torrent client to the LOCAL router.

 

It is not aware of this VPN end forwarding, meaning it's clueless that some port has been forwarded towards your computer.

If you don't know how to enable a specific port manually (it's quite complicated, having to go through Control Panel -> Administrative Tools -> Windows Firewall -> Inbound Rules ; New Rule... and a whole bunch of clicking and stuff...)

 

You might as well disable it when using VPN, since nobody can reach your computer ANYWAY, as you are behind that VPN server (which acts as the firewall !). That one will ONLY forward the specific ports you have configured in AirVPN interface, and none of the others.

Share this post


Link to post

I am getting a little bit stressed out with port forwarding and setting up qbittorrent.

I am windows 10 64bit.

using eddie.

I have a port forwarded on the site and have put that port into qbit.

I have then set the ethernet to ethernet 3 (which is the one airvpn created) and then the ip is set to the only other option apart from my actual ip.

The issue I have is, when i set it to the ip thats there I cant download anything and then when I check if the port works it fails.

If i set it to all addresses it works but im worried that obviously its using my actual ip which means ill be visable.

 

Ive been told to set in eddie to not use ipv6 which ive done. this hasn't helped.

 

Also when I use ipleak it wont detect that ive tried to download their file and never refreshes.

 

(ive attached images but have no idea how to get them to show in message)

Reinstalled qbit and now dont have any ip other than my own ip under ethernet 3. I am very worried what i am using qbit for is gonna be seen by my isp.

 

hopefully final edit...

 

after seeing shiver me whiskers post about turning off windows firewall, i did this and now i show up on ipleak with airvpns created ip. am i all ok now?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...