Jump to content
Not connected, Your IP: 3.234.214.179
spinmaster

Authenticate/Decrypt packet error / Warnings with P2P traffic

Recommended Posts

Hi,

 

while using P2P traffic, my VPN-client (I am using Viscosity on OS X) is hammered with (literally!) hundreds of thousands of log entries like this:

 

May 16 13:54:33: Authenticate/Decrypt packet error: bad packet ID (may be a replay): [ #256464 ] -- see the man page entry for --no-replay and --replay-window for more info or silence this warning with --mute-replay-warnings

May 16 13:54:33: Authenticate/Decrypt packet error: bad packet ID (may be a replay): [ #256465 ] -- see the man page entry for --no-replay and --replay-window for more info or silence this warning with --mute-replay-warnings

May 16 13:54:33: Authenticate/Decrypt packet error: bad packet ID (may be a replay): [ #256466 ] -- see the man page entry for --no-replay and --replay-window for more 

(...)

 

I cannot remember 100%, but I'm pretty sure this was with UDP-Connections only and regardless of the server geo-location. As a result, the CPU usage on my Macbook is going crazy (process for Viscosity uses >100% CPU) and the fan is becoming noisy.

 

While I know that I can mute log outputs, I'd like to know why these warnings are thrown.

 

Any input would be appreciated!

Share this post


Link to post

Dunno about that specific title, but if it's openvpn, you can modify the service passing the --mute-replay-warnings flag.  See the man page for more: 

 

 



--mute-replay-warnings

Silence the output of replay warnings, which are a common false alarm on WiFi networks. This option preserves the security of the replay protection code without the verbosity associated with warnings about duplicate packets.

 

Share this post


Link to post

 

Dunno about that specific title, but if it's openvpn, you can modify the service passing the --mute-replay-warnings flag.  See the man page for more: 

 

 

 

--mute-replay-warnings

 

Silence the output of replay warnings, which are a common false alarm on WiFi networks. This option preserves the security of the replay protection code without the verbosity associated with warnings about duplicate packets.

 

 

 

Yes, it's OpenVPN (that's the only protocol what is offered by AirVPN) and yes, I know that I can mute these warnings by modifying my VPN-client.

 

My question is: why are these warnings thrown hundreds of thousands of times when I use P2P traffic? Is this due to the nature of UDP, since there is no handshake / error-checking for each data-packet compared to TCP?

 

My connection speed is massively reduced (on pretty much all AirVPN servers) when using TCP, so I'd like to stay on UDP for now.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...