Jump to content
Not connected, Your IP: 18.207.108.191
Guest Chaf

ANSWERED OpenVPN > write UDPv4: Operation not permitted (code=1)

Recommended Posts

Guest Chaf

Hello ;-)

 

Configuration:

Ubuntu 14.04.2 LTS 32 bits

Using Airvpn client 2.8.8

Network lock enable

Protocol UDP port 443

 

Log Output:

Updating systems & servers data ...

OpenVPN > write UDPv4: Operation not permitted (code=1)

OpenVPN > write UDPv4: Operation not permitted (code=1)

OpenVPN > write UDPv4: Operation not permitted (code=1)

OpenVPN > write UDPv4: Operation not permitted (code=1)

...

OpenVPN > write UDPv4: Operation not permitted (code=1)

 

Any suggestion on how/why this happens ?

 

Share this post


Link to post

This happens to me and I've been talking with the staff about it.

 

Try to connect via TCP and see what happens.

 

Also, if you disconnect and refresh server list, it works. But you'll still get disconnected and will have to do that very frequently.

Share this post


Link to post
Guest Chaf

Does this happen only with Airvpn client or also with the openvpn client in command line ?

 

Not willing to use TCP as UDP is faster for me and I don't get disconnected...

Share this post


Link to post

I have this problem using udp 443 or 80, both on ubuntu 14.04 and windows 7.

 

I am now testing TCP, though I don't want this to be the only solution, as it more than halves my speed.

Share this post


Link to post

I have a similar problem with UDP and TCP on Windows 7 machine.

 

AirVPN won't download anything more than 6kbs when I use UDP (but upload is maximum), this just happened recently without any system change of my computer. TCP only lets me download and upload at 10% of my maximum without AirVPN on. UDP used to be like this too (the maximum) but something has changed somewhere. Have spent hours so far trying to find an answer but no luck yet.

 

Share this post


Link to post

I  am also getting this problem!

2015.05.24 07:25:21 - OpenVPN > write UDPv4: Operation not permitted (code=1)
*it seems to have started after I installed the new Ubuntu 15.04
like the other users, Eddie is constantly disconnecting with the above message.
I flush the iptables…
restart AirVPN and all will be OK again for a little while…
switching to TCP does not seem to help!

I have also tried disabling IPv6 (also disabled on my router)
https://askubuntu.com/questions/440649/how-to-disable-ipv6-in-ubuntu-14-04
 
…hopefully we can get this solved soon!

P.S
I just noticed as well
when visiting AirVPN website, It will say underneath, that I am not connected!
showing something like this:
But when I run a dns leak test, the test indicates that I am indeed connected to the airvpn servers!!!
 

Not connected.

Your current IP:2003:4r:8740:a0d5:563:f3ff:fe09:c5e7

 

Share this post


Link to post
Guest Chaf

You should try disabling "Update servers list", it is the only reason you get that message.

Somehow when AirVPN's servers list is updated (every 30 mn in automatic) this error pops out in the logs and eventually causes a disconnection.

Share this post


Link to post

you might be on to something there! :-)
I just checked my logs

. 2015.05.24 12:05:21 - Updating systems & servers data ...
. 2015.05.24 12:05:24 - OpenVPN > write UDPv4: Operation not permitted (code=1)
I'll try changing the update times first to manual every hour…
then Never…
 
"Never" can be a temporary solution until AirVPN get this sorted

Share this post


Link to post
Guest Chaf

No need...i've done that and it's confirmed to be related with the "servers update feature" ;-)

 

Airvpn staff is already informed of this issue...as soon as something relevant comes out of my support ticket, I'll update this post.

Share this post


Link to post

Thats good news Chaf! —thanks!
The continuous disconnecting was getting quite annoying!
Good to know AirVPN are already on it ;-)

Share this post


Link to post
Guest Chaf

When I say "its confirmed to be related to the update feature" is not an official statement of Airvpn staff but in my testing it is related.

 

AirVPN staff is however notified.

Share this post


Link to post

Well I can 2nd confirm it!
It definitively shows up on my logs as well after the servers update…

 

I am trying out the new Eddie 2.9 now…
but so far, it seems to act in the same way as the last version…
OpenVPN > write UDPv4: Operation not permitted (code=1)

but I will keep an eye on it over the day…

 

but on a good note, the AirVPN website is now showing me as properly connected! (underneath!)

…with the older version, it was saying I was not connected, despite being connected with the eddie software! (and passing various IP & DNS leak tests)

Share this post


Link to post
Guest Chaf

Eddie 2.10 Experimental resolves the issue.

Share this post


Link to post

Oh Great, thanks for the good news!
I will give it go!

*I have Eddie back on Automatic Server updates
so far so good; I will keep an eye on it…

EDIT:
if you disable ip6
Eddie complains he cant find:

Sysctl net.ipv6.conf.all.disable ipv6

Share this post


Link to post

This can be circumvented by setting ipv6 to "none" in the client. If you have manually disabled ipv6 there is no need for Eddie to try to do the same. What's more I think under Linux Eddie isn't even capable of disabling ipv6 properly.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...