Jump to content
Not connected, Your IP:
Sign in to follow this  

Multiple Custom OVPN Directives?

Recommended Posts

I'm trying to get rid of this error on Yosemite with the 2.9.2 version of the "Eddie" client.  The config I'm using over TCP 443.


"Protocol TCP, port 443"



  I am unable to connect, and I always see the following in the logs:


". 2015.04.17 16:23:46 - OpenVPN > Opening utun (connect(AF_SYS_CONTROL)): No buffer space available"


  If I go to "Preferences->Advanced->OVPN directives->Custom", I can set "sendbuf 8192", which causes fewer of these errors to happen.  I can also set "verb 5" to see lots of logging and I can set "recvbuf 8192".  What I am unable to do is set all three of these settings together.  I've even tried to add them with spaces, tabs, commas, and semicolons, to no avail.  How can I specify both sendbuf and recvbuf using the OVPN directive option?  Is this a bug in the Eddie client?


Share this post

Link to post


We just tried


sndbuf 8192
rcvbuf 8192
verb 5

in Preferences->Advanced->OVPN directives->Custom, with OS X, and everything works fine.

Maybe you have a simple typo issue, directives "sendbuf" and "recvbuf" do not exist, but "sndbuf" and "rcvbuf" do.

"Opening utun (connect(AF_SYS_CONTROL)): No buffer space available"
is a bug that sometimes appears on some systems. It's not related to Eddie (our client), it's related to OS X / BSD and OpenVPN.

Unfortunately, we are unable to reproduce it in our labs for investigation.

Does your sndbuf/rcvbuf solution resolve the issue, or does it limit it?
Do you have ALWAYS the above error? Can you post a full log?

Eddie doesn't have in bundle a TUN driver, because Maverick and above already have it (utun). One of the Tunnelblick solution for the 'No buffer space available' is adding a custom directive

dev-node tun

so that OpenVPN falls back to the older TUN driver. Maybe it could work for you if you have the older driver.

Sorry but we can't reproduce this issue, so we can only speculate.


Kind regards

Share this post

Link to post


  I found the issue with multiple options: on my Mac, at least, I have to combine click with the CTRL key in order to insert a line break into the options window.  Once I did that, I was able to combine multiple OVPN directives.


  Based on your suggestion, I removed "sndbuf" and "rcvbuf" and instead used "dev-node tun".  There are no more "No buffer space available" error messages, but I still can't connect.  I did open a support ticket, and they've noted my setup is causing new errors in the logs:


. 2015.04.18 15:57:36 - OpenVPN > us=924625 Options error: option 'redirect-gateway' cannot be used in this context ([PUSH-OPTIONS])

. 2015.04.18 15:57:36 - OpenVPN > us=924638 Options error: option 'dhcp-option' cannot be used in this context ([PUSH-OPTIONS])


  So, for those who are following this thread re: the ability to enter multiple OVPN directives, the trick is to use CTRL+Enter to enter multiple OVPN directives.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...