Jump to content
Not connected, Your IP: 54.242.193.41

Recommended Posts

Hello AirVPN!

 

I have a problem with UDP connections, I have had the problem with multiple different VPN services over the last 4 years. I have recently signed up to test with AirVPN and again the same issues. TCP works fine, albeit slower then I would like, so i would like to fix my UDP problem if possible. I use Wifi only, and from the room next to my router. I have a base stable connection at 30mbps (down) 9mbps (up). I get about 14-17mbps (down) and 8mbps(up) on TCP. I get sporadic results from UDP, from 1-3-7mbps (down) and anywhere from 1-8mbps (up). I can not even handle a normal 1080p stream in UDP. I would like to use UDP on AirVPN because I know its possible. I have tried many other VPN companies and all but one have this issue, one VPN company that does not have this issue gives me a stable 22-25mbps (down) and 8mbps (up) on UDP. I have a big family so normally we have two or three different VPN companies client subscriptions at a time and would like to keep AirVPN for my personal compuer, but again this issue. I really don't know whats causing it and if anyone has any ideas, I would be greatful. I don't know what the policy is about naming another VPN company here, but if it helps with the diagnostics and someone from AirVPN says its okay, then I can divulge that information.

 

Thanks!

Share this post


Link to post

Have you tried different UDP ports? The default is 443 I think, you could try port UDP port 80, 53 or 2018. On the config generator page just choose different ports @ the config files. Or in the Client just choose different ports. - Its possible your isp is limiting UDP traffic on what ever UDP port you're using.

 

If that doesn't work you could also try SSL or SSH.

Share this post


Link to post

Have you tried different UDP ports? The default is 443 I think, you could try port UDP port 80, 53 or 2018. On the config generator page just choose different ports @ the config files. Or in the Client just choose different ports. - Its possible your isp is limiting UDP traffic on what ever UDP port you're using.

 

If that doesn't work you could also try SSL or SSH.

 

Done and tried all that, on the other VPN "the one that works on UDP" all ports are fine. I don't have any isssues relating to ports.

Share this post


Link to post

 

Have you tried different UDP ports? The default is 443 I think, you could try port UDP port 80, 53 or 2018. On the config generator page just choose different ports @ the config files. Or in the Client just choose different ports. - Its possible your isp is limiting UDP traffic on what ever UDP port you're using.

If that doesn't work you could also try SSL or SSH.

 

Done and tried all that, on the other VPN "the one that works on UDP" all ports are fine. I don't have any isssues relating to ports.

I only mentioned the ports due to many isp's throttling specific connections / ports. Its extremely common.

​If you're using the client try SSH. It uses TCP.

Share this post


Link to post

 

Have you tried different UDP ports? The default is 443 I think, you could try port UDP port 80, 53 or 2018. On the config generator page just choose different ports @ the config files. Or in the Client just choose different ports. - Its possible your isp is limiting UDP traffic on what ever UDP port you're using.

 

If that doesn't work you could also try SSL or SSH.

 

Done and tried all that, on the other VPN "the one that works on UDP" all ports are fine. I don't have any isssues relating to ports.

I only mentioned the ports due to many isp's throttling specific connections / ports. Its extremely common.

​If you're using the client try SSH. It uses TCP.

 

Yeah, I know .

 

I am lucky enough to have an ISP that does not throttle and is true unlimited, they don't limit by protocol or port. It may seem hard to believe but its one of the reasons this specific company is very highly regarded in my country. I could try SSH in the client, but if the whole data stream is TCP under SSH then it really does not solve my problem due to my wish to use UDP for faster speeds. Thanks very much for the suggestions though, I appriciate it.

Share this post


Link to post

I would love an ISP like that. fwiw I can usually pull 60+ megs using ssh or ssl even.

​You mentioned getting sporadic results on udp. Have you tried a direct connection? Wireless is kind of the king of sporadic. -I used to have a roommate that had a room opposite the kitchen wall. We would troll him while he was gaming by turning on the microwave oven making his wireless go nuts. It might just be the wireless giving you issues.

Share this post


Link to post

I would love an ISP like that. fwiw I can usually pull 60+ megs using ssh or ssl even.

​You mentioned getting sporadic results on udp. Have you tried a direct connection? Wireless is kind of the king of sporadic. -I used to have a roommate that had a room opposite the kitchen wall. We would troll him while he was gaming by turning on the microwave oven making his wireless go nuts. It might just be the wireless giving you issues.

 

Yeah, I would have said you were right about the wireless but the other VPN over UDP is solid with its connection over UDP even with wireless. I have only found this company to be this way, all others are like I say, sporadic and get 300/KiB's maximum on single stream connetions. I get for example 300/KiB's with each connection basically meaning that I get full or better speeds when torrenting on AirVPN etc with UDP, my speeds are normal. Its just things like YouTube/Twitch etc things that download on a single connection that give me issues with UDP. I would also get a faster line but 30mbps (down) 9mbps (up) is the max speed of the contact I have even if its true unlimited, because I live on an Island. they have plans to raise it here though, which is cool.

Share this post


Link to post

I don't mean to be a thread bumper but I have had a very similar issue to this and a very similar story. Over multiple VPN providers every single thread would max out around 400 KB/s while using UDP but I could get full speed with torrents, and I knew my ISP didn't do any throttling. The problem has been consistent for years and no one could figure out what caused it. Then today I figured it out while doing some buffer testing for Air. In Eddie, go to AirVPN -> Preferences -> Advanced -> OVPN directives. In the "custom" field type sndbuf 65536 and on the line under it type rcvbuf 65536, then save and restart the client. (You can also try using 131072, 262144 or 524288 instead of 65536). This instantly solved the problem for me, my single thread speed went from 400 KB/s to over 4500 KB/s. Since I have been prowling the internet for a solution for a long time I hope this will help someone

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...